Jump to content
The simFlight Network Forums

PTT via WideFS


Recommended Posts

Hello,

I try to put the PTT button of the SQB3 onto my joystick button. I have seen, that there where a option under the Button Folder in FSUIPC. I do the following:

  1. Open dialog button and switches
  2. Press button, that will become the PTT button
  3. Check Select for FS Control
  4. Choose PTT on (I don't know the entry) in the upper dropbox
  5. Choose PTT off in the lower dropbox
  6. Check Control send when button released
  7. The Parameter fields remain empty

I'm not sure, if I have to define a special PTT button on the client machine at the SQB itself (there is actually the right CTRL - Key defined, because I'm using the clients keypad for open microphone) or if the Joystick Button must be defined with a key, that will be send to the client machine and lead to the opening of the microphone.

I have read several description about this problem, but there is a FSUIPC Function used, that is called Keysend 1-255

Thanks for help.

Oliver

Link to comment
Share on other sites

I try to put the PTT button of the SQB3 onto my joystick button. I have seen, that there where a option under the Button Folder in FSUIPC. I do the following:

You go into some detail, but omit some essentail information. Are you using WideFS? Are you using FS9 or FSX? What is the version number of the FSUIPC you are using?

Check Control send when button released

There is nowhere to check something called "Control send when button released". If you mean "Control to repeat when held", then certainly to do NOT want to check that! You just want "PTT Transmit On" when you press and "PTT Transmit Off" when you release. If it is repeating all the time you hold it it is probably jamming up SB3's operation.

I'm not sure, if I have to define a special PTT button on the client machine at the SQB itself (there is actually the right CTRL - Key defined, because I'm using the clients keypad for open microphone) or if the Joystick Button must be defined with a key, that will be send to the client machine and lead to the opening of the microphone.

No, the facility in FSUIPC/WideFS works automatically usding Windows messages: It doesn't use keypresses at all.

Regards

Pete

Link to comment
Share on other sites

Yes, you are right. There are some missing information.

I'm using FS2004, my FSUIPC Version is 3.93 and my WideFS is 6.8.6.0

I try to describe, what I have done and my you can see, what I make wrong.

First I start FS2004 and open the FSUIPC Dialog/ Buttons and Switches. I pressed the button from my joystick and FSUIPC recognizes the pressed button. Then I select the following options:

  • Check 'Select for FS Control'
  • choose PTT Transmit on
  • Choose transmit off
  • uncheck 'control to repeat while held'

Then I finished by pressing OK

On the client side I haven't changed anything, nor in the WideFS.ini or any other.

In my SB3 there is a button allocated to the PTT Function (right control). By pressing these button I can make sure, that ATC will hear me.

While pressing the defined button on the joystick, no mic will open....

Any idea to fix the problem?

Thanks

Oliver

Link to comment
Share on other sites

I'm using FS2004, my FSUIPC Version is 3.93 and my WideFS is 6.8.6.0

FSUIPC 3.93 is now very old. The earliest supported release is 3.999w.

In my SB3 there is a button allocated to the PTT Function (right control). By pressing these button I can make sure, that ATC will hear me.

You didn't read my previous reply? Keypresses aren't used by this facility. It uses Windows messages.

Please update your FSUIPC. That has got to be the first step. However, I must point out that this facility has been working fine for SB3 since version 3.50 of FSUIPC, in August 2005, as described in the FSUIPC History document thus:

  • The “Roger Wilco” (also AVC and SB) PTT control, assignable in the Keys and Buttons drop-downs, operates both locally and via WideFS without necessitating any use of the “KeySend” facilities nor, if the latest WideFS is used (6.50 or later), any parameter changes in the WideClient INI files. The PTT requests are broadcast to all Clients.

So you are doing something wrong. Perhaps you need to show me your FSUIPC.INI file. But first, test with a supported version of FSUIPC please!

Oh, check that your SB3 id up to date too -- at least up to date in 2005 terms!

Pete

Link to comment
Share on other sites

Hi Peter, it's me again :-)

I have updated both FSUIPC and WidFS and I will up to date now. But it doesn't work.

The following is the content of my FSUIPC.INI

I hope that helps.

!1=[JoyNames]

AutoAssignLetters=No

0=Saitek X52 Flight Controller

0.GUID={8EAEAD10-9394-11E0-8002-444553540000}

[General]

UpdatedByVersion=3999w

WindSmoothing=Yes

AutoTaxiWind=Yes

PropTaxiWind=Yes

TimeSetMode=Partial

WhiteMessages=No

ThrottleSyncAll=No

GraduatedVisibility=Yes

LowerVisAltitude=0

UpperVisAltitude=60000

UpperVisibility=6000

GenerateCirrus=Yes

WindShearSharp=No

UpperWindGusts=No

ExtendMetarMaxVis=Yes

CorrectVSsign=Yes

MouseWheelTrim=No

MouseWheelTrimSpeed=1

BrakeReleaseThreshold=75

AxisInterceptIfDirect=No

DontResetAxes=No

DisconnTrimForAP=No

ZeroElevForAPAlt=No

AutoClearWeather=Yes

ExtendTopWind=Yes

WindSmoothness=5

SmoothPressure=Yes

PressureSmoothness=5

SmoothVisibility=Yes

VisibilitySmoothness=2

MaxSurfaceWind=0

WindLimitLevel=200

WindDiscardLevel=400

WindAjustAltitude=No

WindAjustAltitude=No

MinimumVisibility=0

MaximumVisibilityFewClouds=0

MaximumVisibility=0

MaximumVisibility=0

MaximumVisibility=0

OneCloudLayer=No

ThinClouds=No

ThinThunderClouds=No

CloudThinness=1000

CloudThinness=1000

CloudTurbulence=Yes

CloudIcing=Yes

WindTurbulence=Yes

SuppressAllGusts=No

ExternalOptionControl=Yes

AutoTuneADF=No

KeepFS98CloudCover=No

ShowPMcontrols=No

MagicBattery=Yes

RudderSpikeRemoval=No

ElevatorSpikeRemoval=No

AileronSpikeRemoval=No

ReversedElevatorTrim=No

StopAutoFuel=Yes

TrapUserInterrupt=Yes

NavFreq50KHz=No

ClockSync=No

SmoothIAS=Yes

SetVisUpperAlt=No

VisUpperAltLimit=6000

MaxIce=3

MinIce=-1

WindSmoothing=Yes

WindSmoothAirborneOnly=No

LimitWindVariance=No

VisSmoothingDelay=0

VisSmoothAirborneOnly=No

TrafficControlDirect=Yes

CloudTurbulence=Yes

WindTurbulence=Yes

SpoilerIncrement=512

JoystickTimeout=20

PollGFTQ6=Yes

BlankDisplays=No

ZapSound=firework

ShortAircraftNameOk=Substring

UseProfiles=Yes

TCASid=Flight

TCASrange=40

TrafficScanPerFrame=10

AxisCalibration=No

CentredDialogue=Yes

ShowMultilineWindow=No

SuppressSingleline=Yes

SuppressMultilineFS=Yes

ClearWeatherDynamics=Yes

OwnWeatherChanges=No

FixWindows=No

FixControlAccel=No

WeatherReadInterval=4

MoveBGLvariables=Yes

TimeForSelect=4

WeatherReadsFast=No

LuaRerunDelay=66

MainMenu=&Modules

SubMenu=&FSUIPC ...

ForceWeatherKey=112,9

ThrottleSyncToggle=69,14

WindAjustAltitude=No

MaximumVisibility=0

MaximumVisibility=0

CloudThinness=1000

WindSmoothing=Yes

CloudTurbulence=Yes

WindTurbulence=Yes

WindAjustAltitude=No

MaximumVisibility=0

MaximumVisibility=0

CloudThinness=1000

WindSmoothing=Yes

CloudTurbulence=Yes

WindTurbulence=Yes

WindAjustAltitudeBy=2000

MaximumVisibilityOvercast=0

MaximumVisibilityRainy=0

ThunderCloudThinness=10000

WindSmoothingDelay=0

SuppressCloudTurbulence=No

SuppressWindTurbulence=No

AxesWrongRange=No

[JoystickCalibration]

AllowSuppressForPFCquad=Yes

ExcludeThrottleSet=Yes

ExcludeMixtureSet=Yes

ExcludePropPitchSet=Yes

SepRevsJetsOnly=No

ApplyHeloTrim=No

UseAxisControlsForNRZ=No

FlapsSetControl=0

FlapDetents=No

ReverserControl=66292

Reverser1Control=66422

Reverser2Control=66425

Reverser3Control=66428

Reverser4Control=66431

MaxThrottleForReverser=256

AileronTrimControl=0

RudderTrimControl=0

CowlFlaps1Control=0

CowlFlaps2Control=0

CowlFlaps3Control=0

CowlFlaps4Control=0

MaxSteerSpeed=60

Aileron=-16380,-512,512,16380

Elevator=-16383,0,0,16383

Rudder=-16380,-512,512,16380

Throttle=-16380,16380

MapMixture=Yes

Mixture1=0,8192,8192,16380/16

Flaps=0,16380

[sounds]

Path=E:\Flight Simulator 9\Sound\

Device1=Prim�rer Soundtreiber

Device2=Realtek HD Audio output

[buttons]

ButtonRepeat=20,10

2=R0,12,C65607,0

3=R0,13,C65615,0

4=U0,12,C65607,0

5=U0,13,C65615,0

6=R0,32,C1001,0

7=U0,32,C1002,0

8=P0,6,C1001,0

9=U0,6,C1002,0

[Keys]

1=49,10,1061,0

2=50,10,1062,0

3=51,10,1063,0

4=52,10,1064,0

5=71,8,66079,0

6=71,10,66080,0

7=76,10,65751,0

8=84,10,65560,0

10=191,9,1011,0

11=191,11,1010,0

[Window.Radar Contact]

Docked=252, 2886, 3532, 2346

[JoyNames]

AutoAssignLetters=No

0=Saitek X52 Flight Controller

0.GUID={72270E30-7F57-11E1-8001-444553540000}

Thanks for help

Oliver

Link to comment
Share on other sites

The following is the content of my FSUIPC.INI

You have two assignments to these functions, both on your Saitek X52 Flight Controller:

6=R0,32,C1001,0

7=U0,32,C1002,0

and

8=P0,6,C1001,0

9=U0,6,C1002,0

The first pair is actually to a hat position and is set to "repeat whilst held". Why do you have this? Are you sure that's not the reason for your problem?

If you still have a problem with this corrected (i.e. just delete those lines) then I really don't know. I've never used Squawkbox myself and can't really support it at all, but maybe others using it and this facility can help. Is there still a Support Forum or some place where users congregate?

BTW, I assume you do know that you have to keep the button pressed whilst talking? Otherwise you'd need to use a toggle switch or two separate buttons.

Regards

Pete

Link to comment
Share on other sites

all four lines above are deleted, after that I treid it once again. Without sucess.... Look at the screenshot....

Why do folks so insist on posting screenshots? I could barely make that one out!

Seems that something is broken either on your SB3 installation, or in the WideFS link. You could enable logging in the WideClient to ensure the message gets through. Try

Log=Keys

in the [user] section of the WideClient.INI file.

BTW did you check your SB3 version? Maybe it is out of date? Does it work otherwise? Does it link via WideFS? Is it running at the same priority level.

Oh, one other thing I thought of. The facility uses message broadcasting. Is it possible that you have the facilities for this turned off on the Client? Or are you perhaps using a very old version of Windows on that PC?

Pete

Link to comment
Share on other sites

Hello,

sorry for the screenshot. I allways believe that a picture says more than thousand words - even if 'writer' isn't a native speaker. But back to the topic...

My Squawkbox Version seems to be the latest version - it is version 4.x... I don't know, if there is an error with my SQbox Installation - it works very well so I think, the installation is ok... And the link via WideFS works too. The Squawkbox displays a little gauge on the simulator with some indicators to indicate if there is a receiving/ sending transmission...

But I don't know how to see, if they are running on the same priority level (to be honset - I don't know, what that really means)

Oh, one other thing I thought of. The facility uses message broadcasting. Is it possible that you have the facilities for this turned off on the Client?

No I don't.

Seems that something is broken either on your SB3 installation, or in the WideFS link. You could enable logging in the WideClient to ensure the message gets through. Try

Log=Keys

in the [user] section of the WideClient.INI file.

I will give it a try and let you know, what happen....

Link to comment
Share on other sites

When I look at the "About"-Screen, I see the following....

http://i1216.photobu...ool/SQAbout.jpg

Sorry, then. I don't understand at all. I always thought SB3 --> FSUIPC --> FD9, and SB4 --> SimConnect --> FSX.

I'm afraid you'll need to refer to the SB forums, if they exist.

From now till November 5th I am on holiday. Sorry. If this is still unresolved then I will again try to help, but currently I simply don't understand.

Regards

Pete

Link to comment
Share on other sites

No problem - I will let you know, how it works.

Have a nice holiday and enjoy your time...

Thanks

Oliver

PS: I have asked in the VA Forum I fly for and they told me, that SB3 is for the FS9 only, but FS4 is for FSY and for FS9...

So SB4 works with the WideFS and I will try to find out, what happen wrong on my machine...

A nice holiday

Oliver

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.