Jump to content
The simFlight Network Forums

Having problem with conecting WideFS & Client


 Share

Recommended Posts

Hi,

Ihave just install FSUIPC 4.8.6.0 & WideFS Client 6.9.8.9.

I have 2 XP Pro Sp3 PC

There is no way i have been able to conect them.

Here is the Wide server Log:

********* WideServer.DLL Log [version 7.86] *********

Blocksize guide = 8192 (double allowed)

Date (dmy): 18/02/13, Time 16:08:50.140: Server name is LINDARK-8E63565

15406 Initialising TCP/IP server

15421 Initialising IPX/SPX server

15421 ServerNode=0.0.6656.55442.59849

15421 Initialising UDP/IP server

16046 Broadcasting service every 1000 mSecs

Here is the Client Log

********* WideClient Log [version 6.989] Class=FS98MAIN *********

Date (dmy): 18/02/13, Time 15:45:41.312: Client name is VENDELS-9A6F183

141 Attempting to connect now

141 LUA: "C:\WideClient\Initial.LUA": not found

141 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

141 ... Okay, IP Address = 192.168.1.2

189172 Error on client pre-Connection Select() [Error=10060] Connection timed out

189172 Ready to try connection again

190203 Attempting to connect now

190203 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

190203 ... Okay, IP Address = 192.168.1.2

380266 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

380266 ... Okay, IP Address = 192.168.1.2

570266 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

570266 ... Okay, IP Address = 192.168.1.2

760266 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

760266 ... Okay, IP Address = 192.168.1.2

950266 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

950266 ... Okay, IP Address = 192.168.1.2

1140328 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

1140328 ... Okay, IP Address = 192.168.1.2

1330516 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

1330516 ... Okay, IP Address = 192.168.1.2

1520766 Trying TCP/IP host "LINDARK-8E63565" port 8002 ...

1520766 ... Okay, IP Address = 192.168.1.2

1609282 ****** End of session performance summary ******

1609282 Total time connected = 0 seconds

1609282 Reception maximum: 0 frames/sec, 0 bytes/sec

1609282 Transmission maximum: 0 frames/sec, 0 bytes/sec

1609282 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0

1609282 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

Hope you can give me some help

Best Regard

Christoffer Lindeberg

Link to comment
Share on other sites

  • 2 weeks later...

Good moring.

first I want to apologize for coming up with such a problem on a sunday whre time is better spend with the familiy.

After a complete FS2004 Reinstallation I have the same problem described above. I'm trying to connect one XP32 Home PC (FS2004) wit a Laptop (Vista). It has worked until the reinstallation properly. During the Reinstall I have updated the FSUIPC Version to 3.999z and the WideFS to 6.991.

Here are the Logs

Wide Client

********* WideClient Log [version 6.991] Class=FS98MAIN *********

Date (dmy): 03/03/13, Time 09:05:33.938: Client name is EINSTEINJUNIOR

562 LUA: "D:\WideFS\Initial.LUA": not found

577 Attempting to connect now

593 Trying TCP/IP host "Einstein" port 8002 ...

593 ... Okay, IP Address = 192.168.178.24

1591 Error on client pre-Connection Select() [Error=10061] Connection refused

1591 Ready to try connection again

2621 Attempting to connect now

33915 Error on client pre-Connection Select() [Error=10060] Connection timed out

33915 Ready to try connection again

34960 Attempting to connect now

79046 Trying TCP/IP host "Einstein" port 8002 ...

79046 ... Okay, IP Address = 192.168.178.24

145175 Trying TCP/IP host "Einstein" port 8002 ...

145175 ... Okay, IP Address = 192.168.178.24

211366 Trying TCP/IP host "Einstein" port 8002 ...

211366 ... Okay, IP Address = 192.168.178.24

277448 Trying TCP/IP host "Einstein" port 8002 ...

277448 ... Okay, IP Address = 192.168.178.24

343608 Trying TCP/IP host "Einstein" port 8002 ...

343608 ... Okay, IP Address = 192.168.178.24

409721 Trying TCP/IP host "Einstein" port 8002 ...

409721 ... Okay, IP Address = 192.168.178.24

475850 Trying TCP/IP host "Einstein" port 8002 ...

475850 ... Okay, IP Address = 192.168.178.24

542010 Trying TCP/IP host "Einstein" port 8002 ...

542010 ... Okay, IP Address = 192.168.178.24

608170 Trying TCP/IP host "Einstein" port 8002 ...

608170 ... Okay, IP Address = 192.168.178.24

674314 Trying TCP/IP host "Einstein" port 8002 ...

674314 ... Okay, IP Address = 192.168.178.24

740443 Trying TCP/IP host "Einstein" port 8002 ...

740443 ... Okay, IP Address = 192.168.178.24

806541 Trying TCP/IP host "Einstein" port 8002 ...

806541 ... Okay, IP Address = 192.168.178.24

872701 Trying TCP/IP host "Einstein" port 8002 ...

872701 ... Okay, IP Address = 192.168.178.24

938861 Trying TCP/IP host "Einstein" port 8002 ...

938861 ... Okay, IP Address = 192.168.178.24

1004958 Trying TCP/IP host "Einstein" port 8002 ...

1004958 ... Okay, IP Address = 192.168.178.24

1071134 Trying TCP/IP host "Einstein" port 8002 ...

1071134 ... Okay, IP Address = 192.168.178.24

1137341 Trying TCP/IP host "Einstein" port 8002 ...

1137341 ... Okay, IP Address = 192.168.178.24

I'm not sure, if it is the same problem, because have temporarily disabled the firewall on both sides without success.

May there is another reason.

Kind regards,

Oliver

Link to comment
Share on other sites

Here are the Logs

LogS? You only showed tnly the WideClient log -- the WideServer log would laso help as it it half of the connectin!

593 Trying TCP/IP host "Einstein" port 8002 ...

593 ... Okay, IP Address = 192.168.178.24

Is that really the IP address of your FS PC? The 192.168 part looks okay, but I'm not so sure about that 178. Please check. If you know the correct IP address it may be better to enter both the

Protocol=

and

ServerIPAddr= ...

parameters in your WideClient.INI file.

Pete

Link to comment
Share on other sites

Hello, thanks for your quick response...

There is just a file called Wide Server with the following content:

; PLEASE SEE the documentation for parameter details

; ==================================================

[Config]

Port=8002

; -----------------------------------------------

[user]

Log=Errors+

; ===============================================

But there is no text file called WideServer

I have checked the IP's yesterday and they are correct. My FlightSuim PC has the 192.168.178.24 and the machine with the WideFS on it has the number 192.168.178.23

The current wideclient.ini iks as follows:

; PLEASE SEE WideFS documentation for parameter details

; =====================================================

[Config]

Port=8002

Servername=Einstein

Protocol=TCP

Window=-8,-8,1280,786

Visible=Yes

ButtonScanInterval=20

ClassInstance=0

NetworkTiming=5,1

MailslotTiming=2000,1000

PollInterval=2000

Port2=9002

ResponseTime=18

ApplicationDelay=0

TCPcoalesce=No

WaitForNewData=500

MaxSendQ=100

OnMaxSendQ=Log

NewSendScanTime=50

Priority=3,1,2

; -----------------------------------------------

[user]

Log=Errors+

;KeySend1=123,16;Press F12

;KeySend2=123,24;Release F12

;UseSendinput=yes

Log=Keys

ButtonScreen=Yes

; ===============================================

[sounds]

Path=D:\WideFS\Sound\

Device1=Primärer Soundtreiber

Device2=Lautsprecher (8- Logitech Z205 )

Device3=Lautsprecher (Realtek HD Audio (With EDS))

[buttonScreen]

Size=4,5

0=T"Pause"

1=T"Slew"

2=B"Clear\rWeather"

3=B"Toggle\rTraffic"

4=B"Refresh\rScenery"

5=Ba"ESCape"

6=Bt"Cursor\rUp"

7=Ba"Home"

8=B"Reload\rAircraft"

9=Bl"Cursor\rLeft"

10=B"Stop/Clr\r(Num 5)"

11=Br"Cursor\rRight"

12=B"Restart\rFlight"

13=Ba"ALT\r(to get to\rFS menus)"

14=Bb"Cursor\rDown"

15=Ba"End"

16=B"Return"

17=B"Space\rBar"

Which Parameter has to add after the ServerIPAddr

Sorry for asking these stupid questions, I'm not a great expert in network things ;-)

Kind Regards

Oliver

Link to comment
Share on other sites

There is just a file called Wide Server with the following content:

That's the WideServer.INI file.("configuration settings".

But there is no text file called WideServer

It is called wideSever.log. If there is no such file then WideServer hasn't been run. Did you install it at all?

I have checked the IP's yesterday and they are correct. My FlightSuim PC has the 192.168.178.24 and the machine with the WideFS on it has the number 192.168.178.23

Okay. So it looks like you don't have the Server installed at all.

Regards

Pete

Link to comment
Share on other sites

WideFSContent_zps0d003d9a.jpg

Hello Pete,

I don't know, but I don't have such a file neither in my current folder nor in my former folder (I've made a copy of the complete former folder)

I have just unzipped the downloaded and just copied into my Harddrive....

Now I don't know, what to do. What do you mean with "The server isn't installed"? Are you talking about the FSUIPC Software? I have installed it yesterday...

May you can give a little hint to me...

Thanks

Oliver

Link to comment
Share on other sites

Oh my god - have you ever seen such an idiot like me????? For thos who can read it is no problem - but for me.... it's such a shame....

I have found the error - as you have written I forgot to copy the two files into the modules folder..... Well I have installed this machine more than once, but I have never made a mistake like that..... I'm getting older....

Thanks for help. It works very well.... Ich aknn wieder fliegen Juchu....:-)

Oliver

Link to comment
Share on other sites

  • 2 months later...

Good Morning, Sir...

after I have written about the need of updating FSUIPC/ WideFS I did it this morning before I want start to a long haul flight - but it is like every morning when I have a day off and I want to fly - technical issues prevent me from flying :-)

I have installed the new FSUIPC version - I have registered both (FSUIPC is tagged as a registered version in the FS)

I have copied the two WideServer - files (.dll and .ini) into the modules foider... But there is no connection between them.

Here are the WideFS Log file


********* WideServer.DLL Log [version 6.995] *********
Blocksize guide = 4096 (double allowed)
Date (dmy): 06/05/13, Time 09:17:00.546: Server name is EINSTEIN
23907 Initialising TCP/IP server
23922 Initialising IPX/SPX server
23922 IPX/SPX socket() failed [Error=10047] Address family not supported by protocol family
23922 Failed to start IPX/SPX Server
23922 Initialising UDP/IP server
24047 Broadcasting service every 1000 mSecs
35016 Restarting service due to total lack of use
35016 Failed to start IPX/SPX Server
158750 Closing down now ...
Memory managed: Offset records: 0 alloc, 0 free
Read buffer usage: 0 alloc, 0 free, max in session: 0
Write buffer usage: 0 alloc, 0 free, max in session: 0
Throughput maximum achieved: 0 frames/sec, 0 bytes/sec
Throughput average achieved for complete session: 0 frames/sec, 0 bytes/sec
********* Log file closed *********
[/CODE]

Here is another Logfile

[CODE]
********* FSUIPC, Version 3.999z2 by Pete Dowson *********
Running on Windows Version 5.1 Build 2600 Service Pack 3
Running inside FS2004 (FS9.1 CONTROLS.DLL, FS9.1 WEATHER.DLL)
User Name="Oliver Pohl"
User Addr="Lightforce@aopohl.de"
FSUIPC Key is provided
WideFS Key is provided
Module base=61000000
WeatherReadInterval=4
LogOptions=00000001
DebugStatus=255
4094 System time = 06/05/2013 09:17:00
4094 \\EINSTEIN\LW-E_Flusi\Flight Simulator 9\
4094 System time = 06/05/2013 09:17:00, FS2004 time = 12:00:00 (00:00Z)
11750 \\EINSTEIN\FS9_EigeneDateien\StandardCessna.flt
11766 AIRCRAFT\c172\Cessna172SP.air
11766 Aircraft="Cessna Skyhawk 172SP"
13282 ERROR: Can't change message filter: functions not available
13407 AES Link established
13516 Advanced Weather Interface Enabled
16375 \\EINSTEIN\FS9_EigeneDateien\Von der Benutzeroberfläche erzeugter Flug.flt
16500 Clear All Weather requested: external weather discarded
155860 \\EINSTEIN\FS9_EigeneDateien\Von der Benutzeroberfläche erzeugter Flug.flt
156032 Clear All Weather requested: external weather discarded
161485 System time = 06/05/2013 09:19:37, FS2004 time = 09:17:08 (16:17Z)
161485 *** FSUIPC log file being closed
Memory managed: 0 Allocs, 614 Freed
********* FSUIPC Log file closed ***********
[/CODE]

To be honest - I really don't know what this means - thats why I'm asking you for help...

In the meantime I will go to chop a hazelnut tree to calm down a little :-)

Kind regards

Oliver

Link to comment
Share on other sites

I have installed the new FSUIPC version - I have registered both (FSUIPC is tagged as a registered version in the FS)

When you say "both" you mean both FSUIPC and WideFS?

I have copied the two WideServer - files (.dll and .ini) into the modules foider... But there is no connection between them.

Between WideServer and its INI file? The INI file merely contains the settings. If you were using WideFS before there's no need to change your INI file.

Here are the WideFS Log file

No, you showed only the WideServer and FSUIPC log files, both of which show everything is fine. What about the Client log, from the PC where you are running WideClient?

There's always two (2) ends to a connection -- one on the FS PC and one on each client PC on the Network. Showing only the Server shows only one end, and that end is working fine.

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.