Jump to content
The simFlight Network Forums
Pete Dowson

Windows 8.1 and USB device disconnections

Recommended Posts

I have received this advice for Win8.1 users, from my good friend Thomas. He says that with thse changes in Windows he has solved the spontanjeous disconnection of joystick and other USB devices:

 

Action:

 

-          Open Energy Options (might be Power Options like in Win7) in Control Panel

-          Then go to change Energy Saving Options of the selected Energy Saving Plan

-          There like always everything should be set to always ON …

-          Then select Advanced Options on that page

-          On that new panel (Energy Options) under the selected Energy Saving Plan there are two setting to take care of

o   Energy Saving, again everything should be set to No saving/ Always ON ..

o   USB-Settings -> Selective USB Energy Saving -> Deactivated/ Disabled

The first Energy Setting is just global and makes you to believe it includes USB but it doesn’t.

The second one, Selective USB Energy Saving doesn’t give you any idea for what it really is or what it does but it needs to be Disabled to keep the devices alive.

Not even the Help button does give any help about those settings …

 

Hope this helps ...

 

Pete

 

Share this post


Link to post
Share on other sites

I still had the USB (Yoke, Rudder, etc.) items stop responding in FSX after doing the above.   Found a post that detailed how to change the power options in Device Manager, and haven't had a problem since.

 

Can't find the link, but basically open Device Manager.  Then expand Human Interface Devices.  Right click on every device, and for those that have a Power Management TAB, under that TAB disable (uncheck) the "Allow the computer to turn off this device to save power".

 

Some may be grayed out and already unchecked.

 

Then in Device Manager expand the Universal Serial Bus controllers.  Again right click each item and uncheck any that have the above setting under the Power Management TAB.

 

Not all entries will have a Power Management TAB.

 

Worked for me.

 

Now if I can just find out why FSX SE drops the Yoke and other USB items during flight (even though they are still active in Windows) I'll be happy.

 

I did find that when that happens, if I pause the flight, then select Full Screen (Alt Enter), then Windowed Mode (Alt Enter again) the controls are again available.

 

RodeoGeorge

Share this post


Link to post
Share on other sites

I still had the USB (Yoke, Rudder, etc.) items stop responding in FSX after doing the above.   Found a post that detailed how to change the power options in Device Manager, and haven't had a problem since.

 

Can't find the link, but basically open Device Manager.  Then expand Human Interface Devices.  Right click on every device, and for those that have a Power Management TAB, under that TAB disable (uncheck) the "Allow the computer to turn off this device to save power".

 

Some may be grayed out and already unchecked.

 

Then in Device Manager expand the Universal Serial Bus controllers.  Again right click each item and uncheck any that have the above setting under the Power Management TAB.

 

That is the normal way in Windows 7, and I have always replied in that vein when asked. The above is new to Windows 8 and apparently works alongside the changes you mention. That's why it became a FAQ.entry.

 

Pete

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.