Jump to content
The simFlight Network Forums
CBB

No wxr radar on ASN/Prosim after fsuipc upgrade

Recommended Posts

Hi, I am using P3D 2.5, Prosim 1.46b5, ASN and wxr radar has been working fine for months. Just upgraded fsuipc from 4.939v to 4.948 and no longer have any wxr visuals on my ND, even in heavy cb area. I checked the fsuipc ini and I still have the entry ASNwxRadarPath=c:\ProSim737\radar.bin and my latest prosim log has:

11/14/2015 5:50:26 PM * System:Active Sky Next integration enabled
11/14/2015 5:50:26 PM * System:Active Sky Next radar.bin loaded successfully, using prerendered ASN cloud data

Anyone else had this problem with fsuipc 4.948?

Looking in my simconnect log for today (14th nov) there is a simconnect error message, but I think this is something else as I had the same message yesterday (13th nov) and previously, when the wxr radar was working fine.

 

FSUIPC had an install error because it was looking for an old path to a dummy fsx folder which I no longer have, but the install to P3d seems ok

 

The logs are all attached here on the prosim forum (I couldn't attached them here)

 

http://prosim-ar.com/forum/viewtopic.php?f=13&t=8971&p=65571#p65571

Best
Charles

Share this post


Link to post
Share on other sites

Hi Charles,

 

just answered your post in the Prosim-Forum ;-)

 

I can confirm this issue. Everything seems to be fine at first glance, but there simply is no content inside the "radar.bin". Only "NULL"-characters.

 

So I reverted to 4.939n and it is working again.

 

Regards

 

Marc

Share this post


Link to post
Share on other sites

Hi Pete, when you return from your hols, pls have a look at this, confirmed there is a problem with 4,948 of fsuipc causing radar.bin to be null.  Version 4,939n of fsuipc is confirmed to be last version that worked with prosim radar.  Here is link to prosim threads

 

http://prosim-ar.com/forum/viewtopic.php?f=13&t=8971&p=65769#p65769

 

As for other reports I see there, It is working fine here. If FSUIPC creates a radar file, then it is connecting okay to ASN, and the file is exactly what ASN is returning. Why that would be affected by a difference in FSUIPC version I don't understand. Maybe it's a question also of loading order in the DLL.XML file. When you install FSUIPC it will be placed at the end. When you install ASN it places its DLL at the end. I think the latter is generally more reliable for ASN which is why it does it.

 

Anyway, I'll need to see the FSUIPC4 log file, not the Prosim logs or the Install log.

 

Also, just in case the minor changes since 4.948 have altered things, could you try this:

 

FSUIPC4948c_TEST.zip

 

Pete

Share this post


Link to post
Share on other sites

Great to have you back, Pete!  Now seems to be resolved after I installed 4948c.  But I don't know if it was that or the fact that this time, before installing 4948 (from 4939v) I cleared out the old registry entries for FSX (which I do not have) which were causing an issue on install of FSUIPC as detailed in the prosim forum.  I suspect these were messing something up on install.  Also, someone else on the prosim forum reported that the wxr radar worked for him after uninstalling the p3d fsx migration tool so maybe having FSX "left behind" is the culprit

 

Anyway, thanks again

Best

Charles

Share this post


Link to post
Share on other sites

maybe having FSX "left behind" is the culprit

 

I doubt it. That stuff may tend to confuse the Installer (though I think I've now caught most of the likely problems these migration tricks can cause), but once FSUIPC is installed none of that stuff matters -- it either works (because it recognises the underlying FS version) or it will cause all sorts of problems and crashes (because it thinks your P3D is FSX).

 

Pete

Share this post


Link to post
Share on other sites

Hi Mr Pete
I read and read all post that you tell me : http://prosim-ar.com/forum/viewtopic.php?f=13&t=8971
but I have always the same problem I don't see the weather metar on my prosim display!
This is my configuration:
Prepar3D 3.2 V
Last Fsuipc 4949p
Prosim737 1.46
Efis + MCP EL cpflight, WXR panel
Last ASN
I edit in fsuipc4.INI my Prosim folder : ASNwxRadarPath=C:\ProSim737\radan.bin (verified the path many times)
When I start all and I'm going in prosim folder I see the radar.bin but is only 1kb (NULL)
What do you think about my situation?

Maybe new version 3.2 of Prepar3D and Simconnect have a bag??

thanks in advance

Regards

Giosuè

Share this post


Link to post
Share on other sites

I edit in fsuipc4.INI my Prosim folder : ASNwxRadarPath=C:\ProSim737\radan.bin (verified the path many times)

 

But it should be "radar.bin" not "radan.bin"!

 

When I start all and I'm going in prosim folder I see the radar.bin but is only 1kb (NULL)

 

 

1kb or 0? What do you mean by "NULL" for 1kb? It migh well be 1kb if there's no weather to display. I don't know. The size will vary according to the range and resolution selected by Prosim. All FSUIPC does is pass its requests on, receives the data and writes it directly to the file. If the file is being created then FSUIPC has does its part.

 

It might be useful to check the FSUIPC4.LOG file. It will include the line 

... Creating WxRadar binary file as: ...

the first time it makes the file.

 

Maybe new version 3.2 of Prepar3D and Simconnect have a bag??

 

 

Maybe -- did it work for you before 3.2?  However, this facility is all to do with ASN making use of specific facilities in SimConnect. Have you contacted the ASN folks about it? Are there any P3Dv3 users with it working?

 

You can get me some extra information about the interface between FSUIPC and ASN by adding these lines to the [General] section of the FSUIPC4.INI file:

 

Debug=Please

LogExtras=5

 

Pete

Share this post


Link to post
Share on other sites

Since my post above,  I installed P3D3.2 on the same PC on which I use FSX-SE and ASN, and installed the

P3D version of ASN, to test.

With exactly the same weather being set in ASN, FSX-SE does generate the
weather radar data and it is received regularly by FSUIPC.

In P3D3.2 there's never any weather data provided.

I checked with exactly the same settings in both FSX-SE and P3D3, so I think
either ASN os broken in this area, or there's a P3D bug. I have no way of
finding out which, so I have asked the folks at Hi-Fi (the makers of ASN) to check this out for us.

 

I'll post any further information about this I may receive, but I can't do anything further myself at present.

 

Pete

 

P.S. For information, these were used in my tests:

ASN version = P3D, 1.0.5921.17125
FSUIPC version = 4.949p
P3D version = 3.2.3.16769

Share this post


Link to post
Share on other sites

Since my post above,  I installed P3D3.2 on the same PC on which I use FSX-SE and ASN, and installed the

P3D version of ASN, to test.

With exactly the same weather being set in ASN, FSX-SE does generate the

weather radar data and it is received regularly by FSUIPC.

In P3D3.2 there's never any weather data provided.

I checked with exactly the same settings in both FSX-SE and P3D3, so I think

either ASN os broken in this area, or there's a P3D bug. I have no way of

finding out which, so I have asked the folks at Hi-Fi (the makers of ASN) to check this out for us.

 

I'll post any further information about this I may receive, but I can't do anything further myself at present.

 

Pete

 

P.S. For information, these were used in my tests:

ASN version = P3D, 1.0.5921.17125

FSUIPC version = 4.949p

P3D version = 3.2.3.16769

 

Thanks Mr. Pete

I was going crazy!!!

Now I'm more relieved because this not is only my problem....

You are a precious heritage for all  us!!!

I  will wait  your Progress

kind Regard

Sincerely

Giosuè

 

Share this post


Link to post
Share on other sites

 

ASN version = P3D, 1.0.5921.17125

FSUIPC version = 4.949p

P3D version = 3.2.3.16769

 

Thanks Mr. Pete

I was going crazy!!!

Now I'm more relieved because this not is only my problem...

 

 

Sorry, but it appears it is local to you after all. In my hurry to test and compare with FSX, I didn't quite get things the same in the tests. In fact, because the parameters were not correct in my P3D test, the WX Radar was turned off. When it is turned off you get a blank file of 1kb.

 

I ran some more tests, and once things are definitely the same in both FSX and P3D, then the results are definitely the same -- a good Radar image.

 

To check that your radar option has been turned on by Prosim, you need to examine some offsets (the WX radar is controlled by offsets, as listed in the back of the "ASN WX Radar facilities in FSUIPC4" document in your FSUIPC Documents subfolder.

 

So, as well as the logging I suggested earlier, do this:

 

In FSUIPC options, Logging tab, on the right-hand side add these two offsets to the 4-entry table:

 

861C type U16 (this is the range in nm)

8624 type U16 (the top bit here is the ON/OFF switch, the other bits are for options).

 

Then check "normal Log" below, and ok out of there.

 

Run like that with ASN running and Prosim presumably asking for weather radar for display, then show me the log.

 

Pete

Share this post


Link to post
Share on other sites

Hi Pete

You are a great MAN

after adding two off set that you tell me now radar.bin is 79K

Thanks so much

sincerely

Giosue

 

this is my fsuipc4.log .....can you check for me?

 

********* FSUIPC4, Version 4.949p by Pete Dowson *********
Prepar3D.exe version = 3.2.2.16659
Reading options from "C:\Prepar3D v3\Modules\FSUIPC4.ini"
Running inside Prepar3D v3 on Windows 7
Module base=5DAA0000
User Name="giosue pirozzi"
User Addr="giosuepirozzi@libero.it"
FSUIPC4 Key is provided
WideFS7 Key is provided
       16 System time = 22/04/2016 21:02:47
       16 FLT UNC path = "\\PCFLIGHT\Users\Giuseppe\Documents\Prepar3D v3 Files\"
       16 ------ Module Version Check ------
       16        acontain.dll: 3.2.2.16659
       16             api.dll: 3.2.2.16659
       16        controls.dll: 3.2.2.16659
       16      fs-traffic.dll: 3.2.2.16659
       16             G3D.dll: 3.2.2.16659
       16        language.dll: 3.2.2.16659
       16            sim1.dll: 3.2.2.16659
       16        visualfx.dll: 3.2.2.16659
       16         weather.dll: 3.2.2.16659
       16          window.dll: 3.2.2.16659
       16 ----------------------------------
       16 Trying C:\Prepar3D v3\Modules\SimConnectP3D3.dll
       32 Found it: trying to connect
       32 FS UNC path = "C:\Prepar3D v3\"
      312 ---------------------- Joystick Device Scan -----------------------
      328 Product= SideWinder Precision Racing Wheel USB version 1.0
      328    Manufacturer= Microsoft
      328    Vendor=045E, Product=001A (Version 0.38)
      328    Serial Number= Microsoft
      328 Product= Saitek Pro Flight Rudder Pedals
      328    Manufacturer= Saitek
      328    Vendor=06A3, Product=0763 (Version 1.0)
      328    Serial Number=
      328 Product= 5-Axis,12-Button with POV
      328    Manufacturer=
      328    Vendor=12BD, Product=A02F (Version 1.0)
      328    Serial Number=
      328 Product= Plasma-MM2
      328    Manufacturer= Beta Innovations
      328    Vendor=12DA, Product=0920 (Version 1.36)
      328    Serial Number= 000
      328 -------------------------------------------------------------------
      344 LogOptions=00000000 00000001
      344 -------------------------------------------------------------------
      344 ------ Setting the hooks and direct calls into the simulator ------
      344 --- CONTROLS timer memory location obtained ok
      344 --- SIM1 Frictions access gained
      344 --- FS Controls Table located ok
      344 --- Installed Mouse Macro hooks ok.
      344 --- Wind smoothing fix is installed
      344 --- All links okay (except older global weather setting method)
      344 -------------------------------------------------------------------
      344 SimConnect_Open succeeded: waiting to check version okay
      344 Trying to use SimConnect Prepar3D
    42729 Running in "Lockheed Martin® Prepar3D® v3", Version: 3.2.3.2 (SimConnect: 3.2.0.0)
    42729 Initialising SimConnect data requests now
    42729 FSUIPC Menu entry added
    42745 \\PCFLIGHT\Users\Giuseppe\Documents\Prepar3D v3 Files\Napoli Capodichino.fxml
    42745 C:\Prepar3D v3\SimObjects\Airplanes\Prosim 737-800 Regular\Prosim738.air
    43337 Monitor IPC:861C (U16) = 0
    43337 Monitor IPC:8624 (U16) = 0
    93663 System time = 22/04/2016 21:04:21, Simulator time = 21:03:30 (19:03Z)
    93663 Aircraft="Prosim_737_800_Alitalia"
    94677 Starting everything now ...
    94693 ASN active function link set
    94693 Ready for ASN WX radar
    94693 ... Creating WxRadar binary file as:
    94693 C:\ProSim737\radar.bin
    95988 Advanced Weather Interface Enabled
   124489 Weather Mode now = Theme
   147000 Monitor IPC:861C (U16) = 50
   147000 Monitor IPC:8624 (U16) = 130
   154519 Monitor IPC:8624 (U16) = 2
   170353 Monitor IPC:8624 (U16) = 130
 

Share this post


Link to post
Share on other sites

after adding two off set that you tell me now radar.bin is 79K

 

Er, just monitoring those offsets doesn't change them. It doesn't change anything. You must have done something else differently. Maybe you didn't have WX Radar switched on before?

 

You didn't add those two lines to the INI file I mentioned, so the logging is not diagnostic in any case, so if it wasn't working it wouldn't have helped. All the monitoring shows is:

 

Before everything is started:

    43337 Monitor IPC:861C (U16) = 0  ......range = 0

    43337 Monitor IPC:8624 (U16) = 0  .......wx radar = off

Then things kick off:

    94677 Starting everything now ...

    94693 ASN active function link set

    94693 Ready for ASN WX radar

and the Radar is switched on nearly 30 seconds later (presumably when Prosim starts):

   147000 Monitor IPC:861C (U16) = 50  ........range 50 mn

   147000 Monitor IPC:8624 (U16) = 130 ........radar switched on with stabilised antennae option selected

7.5 seconds later:

   154519 Monitor IPC:8624 (U16) = 2 ............radar switched off again!

(Maybe the battery was off and Prosim just finished initialising)

16 seconds later, I assume you switched things on, and the WX Radar is switched on again:

   170353 Monitor IPC:8624 (U16) = 130

 

This is what FSUIPC's monitor is telling us. But monitoring values does NOT change them, so you definitely did something differently!

 

Pete

Share this post


Link to post
Share on other sites

Hi Pete!

 

Please have some patience with me. I know there has been alot of talk about this issue on the prosim forum and that it seem solved, But I'm still having problems getting a radar image.

 

I paste some log text - 

First from FSUIPC4.log

"....

  40015 Starting everything now ...
    40015 Note: "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\PFCFSX.DLL", Error 126 (The specified module could not be found. )
    40015 Note: "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\EPICINFO5.DLL", Error 126 (The specified module could not be found. )
    40015 Ready Flags: Ready-To-Fly=Y, In Menu=N, In Dlg=N
    40062 ###ASN[2]: as_btstrp.dll is present at 69550000, with procedure isActive at 69554270
    40062 ###ASN[2]: ... and IsRunning returned this: 69590DC4
    40062 ASN active function link set
    40062 ###ASN[2]: ASN running flag = 1
    40062 Ready for ASN WX radar
    40062 ###ASN[2]: ASN Active flag at 69590DC4 = 01
    40062 ###ASN[2]: DoWX: Options=0000, range=0
    40062 ... Creating WxRadar binary file as:
    40062 C:\Prosim\Prosim\radar.bin

    40062 ###ASN[2]: WXradar data requested
    40250 Monitor IPC:861C (U16) = 50
    40250 Monitor IPC:8624 (U16) = 130

    41343 Advanced Weather Interface Enabled
    42578 ###ASN[2]: DoWX: Options=0082, range=50
    42578 ###ASN[2]: WXradar data requested
    45078 ###ASN[2]: DoWX: Options=0082, range=50
    45078 ###ASN[2]: WXradar data requested
    47593 ###ASN[2]: DoWX: Options=0082, range=50
    47593 ###ASN[2]: WXradar data requested

".............

In my prosim folder I got a radar.bin file of 79kB.

 

Here is some text from the DLL.xml file

 

"... <Launch.Addon>
    <Name>FSUIPC 4</Name>
    <Disabled>False</Disabled>
    <Path>Modules\FSUIPC4.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp.dll</Path>
  </Launch.Addon>
</SimBase.Document>  

 

"........

 

Here you can see that the as_btstrp.dll is loading AFTER the FSUIPC4 that has been an issue too.

 

From the FSUIPC4-log you can see that the wx-radar in prosim is turned on. 

If I turn the gain up the gain of the weather radar about half way from max the radar gives me a overall covering red image on the screen. If I turn the gain down again I cant see anything again. 

 

Do you have a clue why I cant get my weatherradar working? Is there any other log files og diagnostics that could reveal some more info about whats going on?

 

regards, 

Tor Christian 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.