Jump to content
The simFlight Network Forums

P3D v3 + FSUIPC v4.949f not running

Recommended Posts

Hi all,

I've tried just about everything I can think of and am coming up 100% empty. I purchased a license for FSUIPC under the understanding that it would run on Prepar3D v3. However, once I installed it, Prepar3D no longer starts at all - it just sits and hangs on the the initial loading screen, with nothing happening thereafter. I've tried completely wiping both things entirely from the system and reinstalling fresh, with no results. I have also tried installing the SP2 simconnect in the P3D redist directory, with no results. In all honesty, I'm entirely at wits end, and don't understand what is happening - the only way I can even get Prepar3D to start is by renaming the Modules/FSUIPC4.DLL file so it fails to locate, at which point Prepar3D starts as usual - just without FSUIPC. I am running Windows 10 Pro and Prepar3D v3.1. I have below included my FSUIPC4 Install log and the most recent FSUIPC4 log.


Thanks in advance for your help!


Install log:


Installer for FSUIPC4.DLL version 4.949f
Looking in registry for FSX install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0
Not there, so looking in:
     HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0
... NOT found! ...
Looking in registry for FSX-SE install path:
Not there, so looking in:
Not there, so looking in:
     HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator - Steam Edition\10.0
Not there, so looking in:
     HKEY_CURRENT_USER\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator - Steam Edition\10.0
... NOT found! ...
Looking in registry for Prepar3D v1 install path:
Not there, so looking in:
... NOT found! ...
Looking in registry for Prepar3D v2 install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Lockheed Martin\Prepar3D v2
Not there, so looking in:
     HKEY_CURRENT_USER\SOFTWARE\Lockheed Martin\Prepar3D v2
... NOT found! ...
Looking in registry for Prepar3D v3 install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Lockheed Martin\Prepar3D v3
... >>>  OK! FOUND Prepar3D v3!  <<< ...
     SetupPath=C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\
SetupPath="C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\"
Checking version of the Prepar3D v3 EXE:
... Version  (Need at least 1.0.677.0)
Checking compatibility with installed SimConnect:
Checking if there's already a version of FSUIPC4 installed in:
       C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\FSUIPC4.DLL
... Version 4.949f found.
Prepar3D v3 Modules folder already exists.
Okay -- installed FSUIPC4 into "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\FSUIPC4.DLL"
Looking for the current user's Application Data path: 
... found as "C:\Users\jeremy\AppData\Roaming"
Now finding \Lockheed Martin\Prepar3D v3\Prepar3D.CFG for all users, including this one
Looking in "C:\Users\All Users\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Default\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Default User\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Default.migrated\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\jeremy\AppData\Roaming"
Found Prepar3D.CFG in "C:\Users\jeremy\AppData\Roaming\Lockheed Martin\Prepar3D v3\Prepar3D.CFG"
Now checking DLL.XML ...
... There is a previous DLL.XML, checking for FSUIPC4 section.
... FSUIPC4 section already exists but will be replaced.
     (for FSUIPC4, without Loader)
... FSUIPC4 section of DLL.XML written okay
Now checking for a SimConnect.XML file ...
... No SimConnect.XML file found. This is okay.
Looking in "C:\Users\Public\AppData\Roaming"
 ... No Prepar3D.CFG there
"Modules\FSUIPC Documents" folder already exists.
Now installing the Prepar3D SimConnect interface for FSUIPC4 into the "Modules" folder:
   Installed "SimConnectP3D2.dll" okay
Now installing additional files into the "Modules\FSUIPC Documents" folder:
   Installed "FSUIPC4 User Guide.pdf" okay
   Installed "FSUIPC4 for Advanced Users.pdf" okay
   Installed "FSUIPC4 History.pdf" okay
   Installed "List of FSX and P3D controls.pdf" okay
   Installed "FSUIPC Lua Library.pdf" okay
   Installed "FSUIPC Lua Plug-Ins.pdf" okay
   Installed "Lua License.pdf" okay
   Installed "Lua Plugins for VRInsight Devices.pdf" okay
   Installed "LuaFileSystem.pdf" okay
   Installed "Example LUA plugins.zip" okay
   Installed "ASN WX Radar facilities in FSUIPC4.pdf" okay
   Installed "Offset Mapping for PMDG 737NGX.pdf" okay
   Installed "Offset Mapping for PMDG 777X.pdf" okay
   Installed "FSUIPC4 Offsets Status.pdf" okay
   Installed "Profiles in Separate Files.pdf" okay
All installer tasks completed.
Registration dialog exit: selected  FSUIPC REGISTER
Providing FSUIPC registration dialogue ...
Registration for FSUIPC4 was successful! (result code 00)
*************** End of Install Log ***************
FSUIPC4 log:
********* FSUIPC4, Version 4.949f by Pete Dowson *********
Prepar3D.exe version =
Running inside Prepar3D v3 on Windows 8.0
Module base=63000000
User Name="Jeremy Holland"
User Addr="jeremy@jeremypholland.com"
FSUIPC4 Key is provided
WIDEFS7 not user registered, or expired
       62 System time = 02/03/2016 15:21:23
       62 FLT path = "C:\Users\jeremy\Documents\Prepar3D v3 Files\"
       62 ------ Module Version Check ------
       62        acontain.dll:
       62             api.dll:
       62        controls.dll:
       62      fs-traffic.dll:
       62             G3D.dll:
       62        language.dll:
       62            sim1.dll:
       62        visualfx.dll:
       62         weather.dll:
       62          window.dll:
       62 ----------------------------------
       62 Trying C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\SimConnectP3D2.dll
       62 Found it: trying to connect
       62 FS path = "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\"


Link to comment
Share on other sites

You reported this twice. Please see other thread reply.


Also, looking at the log, the hang is occurring at the exact point where FSUIPC is scanning your joystick devices -- is it possible that you have some old joystick driver relating to a now disconnected device? I've seen some drivers hang whilst scanning a missing device.


To check this you can temporarily de-register FSUIPC by renaming or removing the FSUIPC4.KEY file from the Modules folder. An unregistered install won't be scanning devices.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.