Jump to content
The simFlight Network Forums

Flight Simulator has detected a problem...

Recommended Posts

I had installed NvidiaInspector and deleted it. I'm getting that error message (image) when FSX runs. After several reinstallatons of FSUIPC I recognized that my graphics card was runnng at idle in FSX. So I deleted the FSX.cfg and I got that error message again. I reinstalled FSUIPC and I didn't get this message. So I stopped FSX and changed the graphics card setting via the Nvidia control. I got this error message again. I had to reinstall FSUIPC several time then and also changed the graphics card setting to app controlled. Finally, I deleted the FSUIPC line in the .dll and deleted the FSUIPC out of the FSX.cfg. FSX ran without an error message and my GPU was running well. Thereafter I restarted FSX but now I'm getting that error message and FSX crashes to desktop after clicking on YES.





Screenshot (15).png

Link to comment
Share on other sites

The problem you have is nothing to do with any video drivers.

Usually it is a SimConnect trust bug. There is a thread about this. in the FAQ subforum. The report occurs before FSUIPC is even loaded.

The log you supply shows a perfectly good FSX session. I assume that was a previous one.

Both Event Viewer logs show:

Faulting application name: fsx.exe, version: 10.0.61472.0, time stamp: 0x475e17d3
Faulting module name: FSUIPC4.dll, version:, time stamp: 0x58933f1b
Exception code: 0xc0000005
Fault offset: 0x0001f145

Now 1F145 is the ENTRY point into FSUIPC from SimConnect (the exported function called DLLStart), so it really isn't getting to run at all.

There's a similar investigation into this going on for P3D users -- see the pinned thread at the top of the Forum. Please read that, and though you are using FSX, i think parallel investigation into the same startup problem is warranted. If you email me, as it says, I can supply another FSUIPC version which should give us more information.



Link to comment
Share on other sites

Yes it was. I have deleted the modules folder and deleted the line in the .cfg and .dll. Trusted the program as before. Therafter, I ran FSX the 3 times without an error message, but my FPS are usually by 5 higher. I also had no precipitation on the weather radar and ASN (on client) showed a wrong position. I unlinked the LAN from the FSX server to the router and tried another network setup without changing a file of FSX. I'm getting the same error message as before, now, and FSX crashes.

Link to comment
Share on other sites

I reinstalled my OS. I had no issue. Then I had that issue again. FSUIPC was the 1st addon I installed. I have installed lots of addons and a simmconnect update to ...259.0 at the end. So I had the same issue. I also had a simconnect network issue. I reinstalled FSUIPC without uninstalling 2 times. Then, FSX has worked for the 3rd time without an error message.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.