Jump to content
The simFlight Network Forums

fsuipc 5 problems

Recommended Posts

Moved to Main Forum! Please ask questions about FSUIPC always in Main Forum.

Hello. I installed fusipc 5 on p3d v4. today began a strange problem. As soon as p3d starts, I go into modules to configure the controls. Fsuipc opens the window. then I close it and open it again. The third time I try to open, it does not open the fsuipc window anymore. He's at the munu bar, but it does not open. I've done the installation about 30 times, and this problem always happens. I need help; --- Besides these files, in the modules folder, there are others, but I could not send you. As far as fsuipc is concerned, they are just those.
attached files for evaluation - thank you




File deleted !!! Please never send Key information !!!


Link to comment
Share on other sites

Hi Thomas,

I am so unhappy with this problem, that I uninstalled the p3d and installed again, to see if the problem ended. But not! remains the same.
Open p3d, psuipc opens, once, twice and then does not open anymore. It appears on the screen, but when it clicks it does nothing,

Unfortunately I can not send the files because an error message appears when sending.
Look: There was a problem processing the uploaded file. Please contact us for assistance.

Vou copiar aqui o log file

********* FSUIPC5, Version 5.123c (1st February 2018) by Pete Dowson *********
Running inside Prepar3D v4
Module base=7FEC4060000
Windows 7 Professional 64 Bit with SP 1.0 reported as Build 7601 (OS 6.1)
Prepar3D.exe version =
Reading options from "C:\Prepar3D v4\Modules\FSUIPC5.ini"
Checking the Registrations now ...
User Addr="meirellesmm@gmail.com"
FSUIPC5 Key is provided
WideFS7 Key is provided
        0 System time = 04/02/2018 07:28:22
        0 FLT UNC path = "\\MM2017-PC\Users\FLIGHT\Documents\Prepar3D v4 Files\"
        0 ------ Module Version Check ------
        0        acontain.dll:
        0             api.dll:
        0        controls.dll:
        0      fs-traffic.dll:
        0             G3D.dll:
        0        language.dll:
        0            sim1.dll:
        0        visualfx.dll:
        0         weather.dll:
        0          window.dll:
        0 ----------------------------------
        0 FS UNC path = "C:\Prepar3D v4\"
      187 ---------------------- Joystick Device Scan -----------------------
      187 Product= 
      187    Vendor=0000, Product=0001 (Version 1.2)
      203    GUIDs returned for product: VID_0000&PID_0001:
      203       GUID= {B227ED60-A48B-11E7-8001-444553540000}
      203       Details: Btns=24, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R511,U511,V127,X511,Y511,Z127
      203 Product= 
      203    Vendor=0000, Product=0002 (Version 1.3)
      203    GUIDs returned for product: VID_0000&PID_0002:
      203       GUID= {B227ED60-A48B-11E7-8002-444553540000}
      203       Details: Btns=112, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R474,U472,V96,X511,Y511,Z-512
      203 Product= ByFly BR01
      203    Manufacturer= Vassini
      203    Vendor=04D8, Product=002B (Version 1.0)
      203    GUIDs returned for product: VID_04D8&PID_002B:
      203       GUID= {B227ED60-A48B-11E7-8007-444553540000}
      203       Details: Btns=16, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R1023,U1023,V1023,X853,Y708,Z1023
      203 Product= Stargate-NG
      219    Manufacturer= USBI
      219    Vendor=04D8, Product=F6B4 (Version 0.1)
      219    GUIDs returned for product: VID_04D8&PID_F6B4:
      219       GUID= {B227ED60-A48B-11E7-800A-444553540000}
      219       Details: Btns=24, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R511,U511,V511,X511,Y511,Z511
      219 Product= ByFly-16
      219    Manufacturer= USBI
      219    Vendor=04D9, Product=BF10 (Version 0.1)
      219    GUIDs returned for product: VID_04D9&PID_BF10:
      219       GUID= {B227ED60-A48B-11E7-800B-444553540000}
      219       Details: Btns=24, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R2047,U2047,V2047,X2047,Y2047,Z2047
      219 Product= Saitek Pro Flight Rudder Pedals
      219    Manufacturer= Saitek
      219    Vendor=06A3, Product=0763 (Version 1.0)
      219    GUIDs returned for product: VID_06A3&PID_0763:
      219       GUID= {B227ED60-A48B-11E7-800C-444553540000}
      219       Details: Btns=0, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R511,U0,V0,X127,Y127,Z0
      219 Product= Saitek Pro Flight Yoke
      219    Manufacturer= Saitek
      219    Vendor=06A3, Product=0BAC (Version 3.0)
      219    GUIDs returned for product: VID_06A3&PID_0BAC:
      219       GUID= {B227ED60-A48B-11E7-800D-444553540000}
      219       Details: Btns=23, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U255,V255,X1023,Y1023,Z255
      219 Product= USB Game Controllers
      219    Manufacturer= Thrustmaster, Inc.
      219    Vendor=07B5, Product=0316 (Version 1.1)
      219    GUIDs returned for product: VID_07B5&PID_0316:
      219       GUID= {B227ED60-A48B-11E7-8011-444553540000}
      219       Details: Btns=4, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U0,V0,X127,Y127,Z127
      219 Product= Steering wheel
      219    Manufacturer= HORI CO.,LTD.
      219    Vendor=0E8F, Product=0003 (Version 1.0)
      219    GUIDs returned for product: VID_0E8F&PID_0003:
      219       GUID= {B22A5E60-A48B-11E7-8012-444553540000}
      219       Details: Btns=13, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R255,U0,V0,X255,Y255,Z255
      219 -------------------------------------------------------------------
      234 Device acquired for use:
      234    Joystick ID = 5 (Registry okay)
      234    5=Brco
      234    5.GUID={B227ED60-A48B-11E7-8001-444553540000}
      234 Device acquired for use:
      234    Joystick ID = 1 (Registry okay)
      234    1=m2
      234    1.GUID={B227ED60-A48B-11E7-8002-444553540000}
      234 Device acquired for use:
      234    Joystick ID = 3 (Registry okay)
      234    3=ByFly BR01
      234    3.GUID={B227ED60-A48B-11E7-8007-444553540000}
      250 Device acquired for use:
      250    Joystick ID = 8 (Registry okay)
      250    8=Stargate-NG
      250    8.GUID={B227ED60-A48B-11E7-800A-444553540000}
      250 Device acquired for use:
      250    Joystick ID = 2 (Registry okay)
      250    2=ByFly-16
      250    2.GUID={B227ED60-A48B-11E7-800B-444553540000}
      250 Device acquired for use:
      250    Joystick ID = 4 (Registry okay)
      250    4=Saitek Pro Flight Rudder Pedals
      250    4.GUID={B227ED60-A48B-11E7-800C-444553540000}
      250 Device acquired for use:
      250    Joystick ID = 7 (Registry okay)
      250    7=Saitek Pro Flight Yoke
      250    7.GUID={B227ED60-A48B-11E7-800D-444553540000}
      250 Device acquired for use:
      250    Joystick ID = 0 (Registry okay)
      250    0=USB Game Controllers
      250    0.GUID={B227ED60-A48B-11E7-8011-444553540000}
      250 Device acquired for use:
      250    Joystick ID = 6 (Registry okay)
      250    6=Steering wheel
      250    6.GUID={B22A5E60-A48B-11E7-8012-444553540000}
      250 -------------------------------------------------------------------
      265 LogOptions=00000000 00000001
      265 -------------------------------------------------------------------
      265 SimConnect_Open succeeded: waiting to check version okay
      265 Opened separate AI Traffic client okay
     7036 Running in "Lockheed Martin® Prepar3D® v4", Version: (SimConnect:
     7036 Initialising SimConnect data requests now
     7036 FSUIPC Menu entry added
     7036 ... Using Prepar3D with Academic License
     7067 \\MM2017-PC\Users\FLIGHT\AppData\Local\Lockheed Martin\Prepar3D v4\Prepar3D_Default.fxml
     7067 C:\Prepar3D v4\SimObjects\Airplanes\IRIS Raptor Driver\Raptor.air
    26739 Aircraft loaded: running normally now ...
    26786 User Aircraft ID 1 supplied, now being used
    27737 System time = 04/02/2018 07:28:50, Simulator time = 07:28:34 (13:28Z)
    27753 Aircraft="F-22 Raptor - 525th Fighter Squadron"
    45911 -------------------- Starting everything now ----------------------
    45927 ASN active function link set
    45927 Ready for ActiveSky WX radar with additional data
    47253 Advanced Weather Interface Enabled
   141899 Sim stopped: average frame rate for last 62 secs = 24.0 fps
   141899    Max AI traffic was 0 aircraft
   145877 === Closing session: waiting for DLLStop to be called ...
   162631 === DLLStop called ...
   162631 === Closing external processes we started ...
   163630 === About to kill any Lua plug-ins still running ...
   163770 === Closing global Lua thread
   164784 === About to kill my timers ...
   164987 === Restoring window procs ...
   164987 === Unloading libraries ...
   164987 === stopping other threads ...
   164987 === ... Button scanning ...
   165081 === ... Axis scanning ...
   165190 === Releasing joystick devices ...
   165190 === Freeing macro memory
   165190 === Removing any offset overrides
   165190 === Closing all WideFS threads
   173037 === Clearing any displays left
   173037 === NOTE: not calling SimConnect_Close ...
   173037 === AI slots deleted!
   173037 === Freeing button memory ...
   173037 === Closing my Windows ...
   173037 === Freeing FS libraries ...
   174051 === Closing devices ...
   174051 === Closing the Log ... Bye Bye! ...
   174051 System time = 04/02/2018 07:31:16, Simulator time = 07:30:09 (13:30Z)
   174051 *** FSUIPC log file being closed
Minimum frame rate was 23.4 fps, Maximum was 24.3 fps
Average frame rate for running time of 94 secs = 24.0 fps
Maximum AI traffic for session was 0 aircraft
Memory managed: 298 Allocs, 298 Freed
********* FSUIPC Log file closed ***********


Link to comment
Share on other sites


the log file doesn't show any error.

To open and operate any buttons ... FSUIPC uses Windows facilities. If the FSUIPC window doesn't respond then that is related to windows itself. In the past there have been Graphic driver problems that could showed those symtoms when FS was running in full screen. Try running FS in Windowed mode and see if it happens there as well, also make sure your graphics driver is up-to-date.


Link to comment
Share on other sites

Thanks for answering. Very strange. Everything worked. I never fly in full screen, always in window mode.
What can I do to fix this problem? If there is no solution, which file keeps the settings saved? I can set it up and if I need to, I'll change the file into the folder.
Even then, what kind of problem can windows be presenting? I have already passed several windows verification programs, logs, etc.
it's all OK.

Link to comment
Share on other sites

Hello again.
I set it all up, and I put here the ini file that he recorded.
If I have to reinstall the entire fsuipc, then if I replace the ini file with the one I have now configured, does it automatically save to the simulator without having to do anything, without having to configure the buttons and axes again?



0=USB Game Controllers
3=ByFly BR01
4=Saitek Pro Flight Rudder Pedals
6=Steering wheel
7=Saitek Pro Flight Yoke

0=0X,256,D,1,0,0,0    -{ DIRECT: Aileron }-
1=0Y,256,D,2,0,0,0    -{ DIRECT: Elevator }-
2=6X,256,D,36,0,0,0    -{ DIRECT: SteeringTiller }-

1=P1,26,C65983,0     -{MIXTURE1_RICH}-
2=P1,27,C65987,0     -{MIXTURE1_LEAN}-
3=P1,25,C65988,0     -{MIXTURE2_RICH}-
4=P1,24,C65992,0     -{MIXTURE2_LEAN}-
5=R1,2,C65966,0     -{THROTTLE1_DECR}-
6=U1,2,C65820,0     -{THROTTLE1_SET}-
7=R1,5,C65971,0     -{THROTTLE2_DECR}-
8=U1,5,C65821,0     -{THROTTLE2_SET}-
9=P1,17,C65752,0     -{PARKING_BRAKES}-
10=U1,17,C65752,0     -{PARKING_BRAKES}-
11=P1,0,C65860,0     -{AUTO_THROTTLE_ARM}-
12=P2,12,C65938,0     -{STARTER2_SET}-
13=P2,8,C65932,0     -{STARTER1_SET}-
14=P2,6,C66224,0     -{ENGINE_AUTO_START}-
15=P2,5,C66531,0     -{ENGINE_AUTO_SHUTDOWN}-

Link to comment
Share on other sites


when you reinstall FSUIPC and leave the old FSUIPC INI file the it will not automatic create a new one or overwrite it. Did you try delete the INI file before re-install and let FSUIPC create a new one?

FSUIPC doesn't save anything of or in FS itself, for FSUIPC itself.

Did you try a uninstall and new install of P3D client? If FSUIPC doesn't open or react when you try the third time then it is not a FSUIPC internal problem, as said, it is more a P3D or Windows problem.


Link to comment
Share on other sites

Hi, Thomas.
What could be happening ?? Never had a case like this that you solved?
I think it's strange to be a p3d problem, beecause I installed it again from the beginning. I can not believe Windows either, because nothing has been done. there was no update or anything. Anything!
I need to understand better. If one day the fsuipc commands do not work, if I get this INI file that I showed you, install psuipc again and replace with this one, does it work again in the simulator or do I have to configure everything again?

But what I really wanted to do was understand what's happening now. I've never seen this in fsuipc.

Link to comment
Share on other sites


no multiple installation of FSUIPC or different versions don't conflict or do any harm. You can have installed FS9 (FSUIPC3) / FSX (FSUIPC4) / FSX-SE FSUIPC4) / P3Dv2-3 (FSUIPC4) / P3Dv4 (FSUIPC5), all together and that's fine.

Openening FSUIPC is a call to Windows to open a Windows Standard-Window. To do this FSUIPC ask P3D to add the Menu Item for it. FSUIPC itself runs within FS, so if FSUIPC hangs with its window then FS hangs as well as you can not get back to FS. Does FS hangs then? How do you close FS when the FSUIPC doesn't react?

I would first disconnect all controller and start feom there if that might be the cause. You said you use the configuration from a different installation, that might have been different. Also use in the setting Yes for



Btw- the dll.xml file you sent earlier on doesn't show FSUIPC installed?

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">


After FSUIPC installation and a FS Run and Close the most important files to show are (all located in \Modules\ folder). May be zip them and attach the zip file.

FSUIPC5 Install.log


Link to comment
Share on other sites

I sincerely apologize for all this. I did not mean to be disturbing you. But this problem must be solved.
I do not know if I understood very well what I should do .. Come on:
Where do you want me to write this sentence? [JoyNames]
AutoAssignLetters = Yes (in which place?)

*** Does not the dll.xml file you sent previously show the installed FSUIPC?
Answer: This dll.xml file is no longer in the Modules folder. He does not stay there. I think it has in the app folder roaimng, etc etc ..
In the modules folder are only the files of fsuipc, in my case is a software VAinreface, and also Spad (inside the modules folder)
But after I did my last install of fsuipc5, I did not move anymore. I opened the fsuip inside p3d, did all the configuration of buttons and axes and everything works. The fact is that I can not change. If I need to change something in fsuip, I will have to uninstall and install again, and so I will lose the configs and have to configure all the axes and buttons again, this is because the fsuipc on the screen in p3d does not want to open the module. Like I said - it's there .. it shows up, but when I click it it does not open.
You want those files, is that it?

FSUIPC5 Install.log


* sorry for my English

Link to comment
Share on other sites



Where do you want me to write this sentence? [JoyNames]
AutoAssignLetters = Yes (in which place?)

In FSUIPC5.ini file, the section is already there in your file with = No  So just change that to Yes

This is from Your FSUIPC.ini file



Answer: This dll.xml file is no longer in the Modules folder.

The dll.xml or exe.xml are never in \Modules\ folder, if you didn't placed them there. FSUIPC doesn't move those files but adds entries to start FSUIPC to the dll.xml file. Those files are located in ...\AppData\Roaming\Lockheed Martin\Prepar3D v4\ folder.


 I will have to uninstall and install again, and so I will lose the configs and have to configure all the axes and buttons again, 

There is no Uninstall for FSUIPC other than deleting files. So if you want to keep previous settings just don't delete the FSUIPC5.ini file.


You want those files, is that it?

FSUIPC5 Install.log

Yes please, they might give some information.

Do a FSUIPC5 installation and run FS, do this opening of FSUIPC the three times (with couple seconds in-between) and close  (if possible) FS and wait all files are written.


Link to comment
Share on other sites

My dll.xml is configured correctly and appears in the list.
As I said, FSUIP is awesome, when it installs the first time, it appears to open in p3d. I have made the settings of all buttons and axes and it is working perfectly. The fact is that after that, the FSUIP icon keeps appearing in the P3d menu, but it does not open. Click on it and it will not open. That is, if I need to remove a button or add, I can not. I will have to reinstall FSUIP again. But that does not happen every time. I need to find the solution to know what might be happening to not open. This problem appeared from day to day, everything was normal. I did not do anything different.Yes! My dll.xlm 

Link to comment
Share on other sites

Ok so I am running P3Dv4.1 and installed the latest version of FSUIPC 5 and it is registered. I am running default aircraft, with Orbx FTX Global, Rex Textures, ChasePlane and I think that's it. I am having the exact same issue... FSUIPC shows in the Add-ons menu and when I select it the first few times, the window displays no problem, however after about the 2nd or 3rd time, nothing happens. FSUIPC continues to provide the controls I have assigned it, but I can't get the window open to make any changes. Restarting the sim does nothing, deleting the Prepar3D.cfg does nothing. If I re-run the FSUIPC installation, it does nothing... however if I remove the FSUIPC.DLL file from the modules folder and then re-run the installation.. presto, it works again... for another 2 or 3 times then back to not working again. 

The nice thing is, since it still provides control... and simply deleting the .DLL file and nothing else it retains all the controls and assignments I have given it, I don't have to rebuild everything whenever I need to get back into FSUIPC to make changes. Inconvinent...very, but not as bad as it could be. 

I hope this information helps get this issue sorted. Please let me know if you would like any further information. I love FSUIPC and can't imagine simming without it! :)


I'm running P3D Version 4.1 (Non Academic version - the $199.00 version)
Windows 10 Pro - 64bit
Nvidia GeForce GTX970
Intel iCore 7-7700K
16GB - 3200 Ram
CH Products Yoke, Pedals, Throttle Quadrant
Orbx FTX Global
REX Essentials Plus Overdrive (Textures only)

Thanks for the help!

Link to comment
Share on other sites

Hello, Thomas. I'm really very sad. You said that my problem was not with FSUIPC but with my Windows, right?
Here's what you wrote: "FSUIPC uses Windows facilities. If the FSUIPC window does not respond then that is related to windows itself."
Now I can give you THE SURE THE WORLD that is not in my problem windows. I formatted the machine yesterday and installed windows 10, from the start. Then I installed P3d and then FSUIPC. I have the same problem. He is there. appears there. But it does not open. I click on it and it just DOES NOT OPEN. I need a solution, after all I paid for the product, I have not seen similar problems, so I need a solution.
I can not go unanswered.
Thank you very much

Link to comment
Share on other sites

I have a very similar problem. Prepar3d v4.2 installed Windows 10 everything up-to-date Sim working fine, decided to update FSUICP5 to the latest version of FSUICP and now it has messed everything up! 

I can't access it in the mene. I see it a few times in the menu bar , but if I try to hover over it  I have no joy (this applies to all the functions in the menu they disappear when I hover over them). NONE of this happened prior to updating FSUICP!

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.