Jump to content
The simFlight Network Forums
gmcraib

Controller inputs not detected

Recommended Posts

Having recently isntalled windows and FSX I recently noticed that controller inputs had no effect in FSX.

I checked the FSUIPC console and nothing was coming up, then checking the controller profile checked calibration etc and all ok.

I did notice, however that the initial value did not reflect the controlelr position but quickly cleared.

 

I then went to check this against FSX and with the properties dialogue open the controls were recognised in the sim.

This remains the only way I can workaround this problem and I have no idea where to even start!

 

Set-up is Saitek yoke with an extra throttle quadrant (ie so 6 x axis) plus X, Y of the yoke and Z of the rudder pedals.

I also have set-up an X-55 stick and throttle.  I don't remember having this problem before addint the X-55 to FSUIPC.

All controls handled by FSUIPC.

Share this post


Link to post
Share on other sites
21 minutes ago, gmcraib said:

I did notice, however that the initial value did not reflect the controlelr position but quickly cleared.

The initial value will not reflect the controller position - values are only received from the controller when it changes/moves.

22 minutes ago, gmcraib said:

I recently noticed that controller inputs had no effect in FSX

What do you mean by this? Do you mean that you cannot see the controller in FSUIPC, or you can see and assign/calibrate the controller in FSUIPC but it has no effect in FSX?

Have you installed the Saitek drivers for the X-55? If so, try removing them.

25 minutes ago, gmcraib said:

All controls handled by FSUIPC.

And controllers disabled in FSX?

 

Share this post


Link to post
Share on other sites

Hi John,

 

I seemed to remember opening calibration screen and the controller position was on it, not a neutral starting value.  But checked again and that's how it is.  Must have been thinking about older PC's, maybe.

 

I mean that I have set the controller up in FSUIPC, but the control inputs were not being picked up by FSUIPC.  It has been suggested to look at power saving plan in windows, so I will try that.

I do have Saitek drivers for the x-55, I don't use the Saitek software/profiles though.

 

Controllers are disabled in FSX, all inputs via FSUIPC.

 

Share this post


Link to post
Share on other sites
16 hours ago, gmcraib said:

but the control inputs were not being picked up by FSUIPC

Do you mean that you cannot see them in the assignments tab? Is this for all your devices or just the X-55?

Could you post your ini, log and joyscan.csv files please (all in your modules folder). You can also try uninstalling the Saitek drivers to see if this solves your issue.

16 hours ago, gmcraib said:

It has been suggested to look at power saving plan in windows

Yes, you should disable power saving mode on your USB device hubs as this will prevent Windows from putting your devices to sleep.

If you have a mixture of USB 2 and USB 3 ports, you can also try changing the USB port - some USB2 devices don't seem to work well with USB3 connections.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.