Jump to content
The simFlight Network Forums

CH Throttle Quadrant and FSUIPC Throttle Problem

Recommended Posts

I have the latest registered version of FSUIPC installed.  I just installed a CH Products Throttle Quadrant and I have been struggling for days to calibrate the throttles.  

I have calibrated the throttle quadrant device with the CH Control Manager software per the instructions.  When I do, all 6 levers show a smooth continuous change in output value as I move the levers from full back, through the detent to full forward.   When I then assigned the two left levers  to Throttle1 and Throttle2 and calibrate in FSUIPC, Throttle 1 shows a smooth continuous change in input/output as I move it from full back to full forward. But Throttle 2 doesn't.  It's input/output values increase much more rapidly to about half way of the lever movement where if maxes out at the high calibration value.   This does NOT occur if I assign the throttles to the middle two or the right two levers so this would indicate a hardware problem except that in the CH Control Manager software all 6 levers show to be operating properly and therefore would indicate this is not a potentiator problem.

If I remove the two left lever assignments and calibrations from FSUIPC and assign as throttles and calibrated them directly in P3DV4.  They work fine.  So the problem is only within FSUIPC again indicating that this is not a hardware problem.

Another unexpected results is that the SLOPE response curve behaves differently for any lever assigned as throttle.  The curve remains linear up to about 50% of it's travel.  The slider to change the shape of the curve only affects the top half of the curve.  Again this occurs regardless of which lever is assigned as the throttle.  If the levers are assigned as Prop Pitch or Mixture the slope adjustment acts as expected. (This may be as Pete designed it but I'm not sure why that might be the case).

 I've never seen these problems with my single throttle/no detent device I used for many years (also a CH Products device)

 I've deleted the FSUIPC.ini file and let the software generate a new one with the same results.

Any thoughts?

Link to comment
Share on other sites


as indicated on top of the Main Forum (READ BEFORE POSTING FSUIPC PROBLEM REPORT) it is always best to attach/include your FSUIPC5.ini / FSUIPC5.logFSUIPC5.JoyScan.csv files.

Also if you want to assign controllers in FSUIPC and calibrate then it any additional driver/ setup program like CH Control Manager might calibrate internal, but FSUIPC uses the Windows API and the controller needs to be calibrated in Windows. The CH Control Manager shouldn't be installed.


Link to comment
Share on other sites

Thanks for the reply Thomas.  I had tried without the CH Control Manager but couldn't get the CH Quadrant to calibrate properly.  The first two levers actually show up in the Windows API as a single joystick with an X and Y axis (have not idea why).  The calibration would trip out when I tried to calibrate those two levers.  That's why I thought the CH Control Manager was necessary.

This morning I started all over.  I uninstalleld CH Control Manager, reinstalled FSUIPC, calibrated in the Windows API (the first two levers still show up as a single joystick but it worked this time) and yes the problem is solved.  Thanks for your help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.