Jump to content
The simFlight Network Forums

Logitech Joystick inputs cause massive FPS drop Ejets V3 E195 - SOLVED


Recommended Posts

UPDATE:  This does not happen on the E175.  Only the E195 so far.  


I have loaded this plane in various places with various scenery complexities, and just sitting at a gate or rolling down a taxiway without touching any flight controls, I get 30+ FPS regardless and I'm happy with that situation. But turning the plane on a taxiway, or doing a flight control check, or trying to maintain centerline on takeoff, the second I move the joystick in any way, the FPS immediately drops to 7 or less and the plane is unusable, and then about two seconds later after I haven't touched anything, the FPS returns to it's normal, high, usable value.  AP commands do not affect FPS.  

I use a Logitech extremepro3D.


Win 10

P3D 4.5

i7 7800K

2x GTX 1080 SLI

64GB RAM at 3000Mhz


subject line edit by mods - added Logitech to description as this is possibly a controller specific issue and not users-wide; subject line noting issue solved with work-around discussed in the thread.

Link to comment
Share on other sites

Disable windows defender real time protection while flying the aircraft. There's a massive spike in CPU usage any time a control input is received by the aircraft. This can be seen if you have the task manager running. Don't know why this occurs. Happens with all my CH stuff as well on all the feelthere aircraft.

Edited by turbojetfan
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

4 hours ago, turbojetfan said:

I have to temporary disable windows defender when I load up the 175 or the 195. It was that way for v2 and for the ERJ145. No other work arounds seem to alleviate the issue for me. It sucks but it's not a huge deal.

Disable it as to switch it off completely? I'm running into this issue.

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

I had the same problem (high FPS, but jittering and stuttering sim) with all Feelthere aircraft (other aircrafts no problems whatsoever) and stumbled on the workaround in the following link:


It worked for me! My analysis is that somehow the Feelthere loading and control assignment manager outputs the preferences (including the control assignments) in an incompatible way to a respective file leading to stutters... With win7 compatibility and admin rights of the setup.exe file, all stutter and jitter are gone..  

  • Upvote 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.