Jump to content
The simFlight Network Forums

strange behavior Saitek (Logitech TMP and rudder pedals) devices


iwerbrouck
 Share

Recommended Posts

I have been using FSUIPC for 10 years. I started with MSFS2020 and FSUIPC7 and I have a problem that I can't solve. Everything normal around installation and configuration, I use the Cessna 152... but the controls seem to have a life of their own, Throttle (Saitek TPM module) suddenly goes full throttle without touching and does it again after some time... Reinstalled USB buses changed, all ctrs of MSFS2020 disabled with "empty" profile...I really don't what now...can anyone give me an idea in which direction to look?

Link to comment
Share on other sites

Your log shows multiple conflicting throttle axis controls being sent:

Quote

   ...
   143687 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= -13124 (0xffffccbc) AXIS_THROTTLE_SET
   143703 ***  AXIS: Cntrl= 65697 (0x000100a1), Param= 15871 (0x00003dff) THROTTLE_SET
   143765 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= -11092 (0xffffd4ac) AXIS_THROTTLE_SET
   143765 ***  AXIS: Cntrl= 65697 (0x000100a1), Param= 15551 (0x00003cbf) THROTTLE_SET
   143765 ***  AXIS: Cntrl= 65697 (0x000100a1), Param= 15871 (0x00003dff) THROTTLE_SET
   ...

Looking at your assignments, you have the throttle set on 2  of your TPM axes:

Quote

0=CX,256,D,4,0,0,0    -{ DIRECT: Throttle }-
1=CY,256,F,65697,0,0,0    -{ TO SIM: THROTTLE_SET }-

Try deleting one of those, probably the second one - best to use direct settings and calibrate.

 

Link to comment
Share on other sites

Btw, you have set-up all your assignments in a profile, and don't have any general assignments for axes or buttons. It is generally better to set-up a general profile first, for all your main axes and button assignments. Then you can create profiles with this as a starting point, and change/add whatever is needed for that profile. Doing it this way, you will at least have basic controls assigned for all aircraft. As it stands, if you load any other aircraft apart from the Cessna 152, you will have no assignments.

Link to comment
Share on other sites

Dear John,

Everything works perfectly again, FSUIPC as I was used to... I cleaned up the ini-file and modified it with a group of settings outside the aircraft profiles. The problem was the USB configuration of my PC, formatted everything, windows 10 again and then the new sim... but... I forgot to install the drivers for the ASUS motherboard, specifically to make the USB buses work properly.. stupid, but yeah...

Anyway, THANK YOU for the very quick help!!

FSUIPC7.ini

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.