Jump to content
The simFlight Network Forums

Joystick sometimes freezes


Recommended Posts

Hi John, sometimes, preferrably during take off, my joystick freezes with a maximum deflection sideways (aileron) although the (physical) joystick is centered. I then go into the FSUIPC menue, axis assignment, and only need to move the joystick to unstick it. Still, it has ruined a number of take offs. I cannot conjure this situation, but is there anything I can log and send to you, so you can have a look? I have made sure that no other joystick axis, for example from my separate throttle, interferes.

Best regards,

-shorthauler

Link to comment
Share on other sites

First, can you check the power management settings on your USB devices and hubs. Make sue Allow the computer to turn off the device to save power is disabled/unchecked. That is usually the reason for such issues.

You also have your axes assigned to multiple devices and multiple axes:

Quote

[Axes.A320]
RangeRepeatRate=10
0=0X,256,D,1,0,0,0    -{ DIRECT: Aileron }-
1=0Y,256,D,2,0,0,0    -{ DIRECT: Elevator }-
2=0Z,256,D,1,0,0,0    -{ DIRECT: Aileron }-
3=2X,256,D,1,0,0,0    -{ DIRECT: Aileron }-
4=2Y,256,D,2,0,0,0    -{ DIRECT: Elevator }-
5=2Z,256,D,4,0,0,0    -{ DIRECT: Throttle }-
6=4X,256,D,1,0,0,0    -{ DIRECT: Aileron }-
7=4Y,256,D,2,0,0,0    -{ DIRECT: Elevator }-
8=4Z,256,D,4,0,0,0    -{ DIRECT: Throttle }-
9=5R,256,D,3,0,0,0    -{ DIRECT: Rudder }-

i,e you have your ailerons assigned to 2 axes on one Logitech Attack 3 (0), on one axis on another Logitech Attack 3 (2), and another on a device called New (4), which you also have two of.
This seems very strange and can cause issues, as each axis can send values on the slightest movement. Better to only assign axes to one controller.

Pease check and correct these issues and try again. If you get the same issues, please activate logging for Axes controls and fly with the logging console window open. When the joystick freezes, take a note of the timestamp of the latest log entry before unfreezing. Once you have recovered and finished the flight, zip up the log file and attach it here, with a description of what you saw in the logging console when this occurred, together with the timestamp.

John

 

Link to comment
Share on other sites

  • 3 weeks later...

Hi John, I deleted the complete [Axes.A320] section, restarted FSX and assigned the Axes anew (profile specific, FSX, FSL A320).

Unfortunately, at some point during the flight, I touched the throttle and then aileron went to maximum deflection and stuck there.

In order to continue the flight, I went back into FSUIPC and checked the axis assignments. They all seemed to be ok.

After the flight I found multiple axis again:

 

[Axes.A320]
RangeRepeatRate=10
0=0X,256,D,1,0,0,0    -{ DIRECT: Aileron }-
1=0Y,256,D,2,0,0,0    -{ DIRECT: Elevator }-
2=0Z,256,D,4,0,0,0    -{ DIRECT: Throttle }-
3=2X,256,D,1,0,0,0    -{ DIRECT: Aileron }-
4=2Y,256,D,2,0,0,0    -{ DIRECT: Elevator }-
5=5R,256,D,3,0,0,0    -{ DIRECT: Rudder }-

 

Best

- shorthauler

 

 

 

FSUIPC4.ini

Link to comment
Share on other sites

There is no way that FSUIPC can add these axes assignments by itself. You probably edit the ini file when FSUIPC was still running. When editing the axes sections, you must do this either when FSUIPC is not running, or if it is running with the axes assignment tab open, and click the Reload all assignments button after you have saved your changes.

You should also change to use substrings in your profiles, i.e. change

Quote

[Profile.A320]
1=FSLabs A320-X Saudi Arabian Airlines
2=FSLabs A320X CFM - Uzbekistan Airways (UK32011)
3=FSLabs A320X CFM - Austrian Airlines (OE-LBS)
4=FSLabs A320X CFM - Gulf Air (A9C-AF)
5=FSLabs A320X CFM - Easyjet (new colors) (G-EZTA)
6=FSLabs A320X CFM - Middle East Airlines (CFM) (T7-MRC)
7=FSLabs A320X IAE - QATAR Airways (A7-AHU)
8=FSLabs A320X CFM - Air Arabia (A6-ANL)
9=FSLabs A320X CFM - Iran Air EP-IEG
10=FSLabs A320X CFM - Lufthansa (D-AIZB)

to

Quote

[Profile.A320]
1=FSLabs A320

Also switch to using joyletters - change
    AutoAssignLetters=No
to
    AutoAssignLetters=Yes

in your [JoyNames] section.

John

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.