Jump to content
The simFlight Network Forums

Access denied


Recommended Posts

I have downloaded 3.5.3 and tried to put it into my modules folder. Stupidly I deleted the previous 3.5.0 without backup. Now the modules folder refuses to accept either version. It is a windows message with a x saying Access denied, and gives some reasons. There is no problem with available space so I have run up against a problem that is beyond my knowledge. I would be grateful for assistance, as now I do not have FSUIPC at all. :(

Link to comment
Share on other sites

I have downloaded 3.5.3 and tried to put it into my modules folder. Stupidly I deleted the previous 3.5.0 without backup. Now the modules folder refuses to accept either version. It is a windows message with a x saying Access denied, and gives some reasons. There is no problem with available space so I have run up against a problem that is beyond my knowledge.

First, why delete the previous version? The update merely involves copying the later FSUIPC.DLL fileinto your FS Modules folder. Nothing else, that is all you needed to do.

It would have helped if you had said what the reasons displayed were, but I think "Access Denied" can only occur for one of several fairly basic reasons:

1) The folder is protected -- you've restricted it in the access permissions. If this were the case you would not have been able to delete FSUIPC.DLL in the first place.

2) The file you are replacing is protected. Again, this cannot be so if you have deleted it, as it isn't there to be protected!

3) The file you are replacing is actually being used! This could only be the case if (a) you haven't already deleted it after all, and (b) FS is actually still running -- you can't change parts of a program which is running.

I can't think of anything else which could give you "access denied". The most likely conclusion therefore is that:

1. You have not actually deleted FSUIPC.DLL from the FS Modules folder after all, which is jolly good because you don't need to.

2. EITHER the FSUIPC.DLL already there is read-only, or FS is actually still running. To check and change the former, right-click on it in Windows Explorer and select "Properties", then look down near the bottom of the window which appears. Uncheck the "Read-only" check box.

To check if FS is still running, use Ctrl_Alt_Del to bring up the Windows Task Manager, select Processes, and look through the list. FS2004 will show as FS9.EXE. If it is still there, but with nothing showing for it on the desktop, then it didn't close down properly -- forcefully end it here using the button bottom right.

Regards,

Pete

Link to comment
Share on other sites

Pete: many thanks for such a rapid reply. I am extremely impressed and grateful. When I put the 353 DLL into the folder it asked me whether I wanted to overwrite the 350 that was there. But after the action I still ended up with the 350. However I am not sure that I really worked it out, but I did the old standard action and rebooted. Then I had no trouble. So even though I had closed down FS something must have been running somewhere. However my crude remedy worked, 3.5.3 is installed and the Wilco 737 no longer dives out of control when the autopilot is activated. Once again I am impressed with your service and support.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.