Jump to content
The simFlight Network Forums
Splodge

FSUIPC 4.0 - Addons menu not appearing

Recommended Posts

If you can post there, please refer them to this thread. It is likely to be the same problem. If Simconnect is being blocked it will affect lots of add-ons -- more and more as time goes on. And not just those which use FSUIPC, as TrackIR does not.

Regards,

Pete

Share this post


Link to post
Share on other sites

Hi Pete,

sorry for delay, was a bit busy at least.

I think my problem was (it didn't come up again since I disabled the autosave-feature) that FSUIPC4 does some kind of crash.

It was there and suddenly it was gone.

Maybe you dont have this problem, cause you are using not a german Version of FSX and WindowsXP.

Here on my system some pathes have different names, so even FSX couldn't find his own previous flight, for example (in german, vorheriger Flug)

I found him temporarly stored in the folder where you find FSX.cfg and dll.xml. But he disapeared when I close FSX.

What I will do is to test a while without autosave-funktion and if nothing happens I'll activate it and see what happens then. And surely I will do a log.

Share this post


Link to post
Share on other sites

I think my problem was (it didn't come up again since I disabled the autosave-feature) that FSUIPC4 does some kind of crash.

It was there and suddenly it was gone.

Actually that cannot remove the menu entry as far as I can tell -- it needs a specific call to Simconnect to remove it.

Furthermore, a DLL cannot really crash in a process without crashing the process -- FSX would have crashed. FSUIPC4 runs in the same main thread as most of FSX.

Here on my system some pathes have different names, so even FSX couldn't find his own previous flight, for example (in german, vorheriger Flug)

The "previous flight" facility is broken in FSX. There is such a file saved in the same folder as FSX.CFG, but that only exists whilst FSX is running, so it is useless for the main purpose.

All of the path identification code in FSUIPC4 uses Windows APIs and the Registry. After seven years dealing with FS versions in different languages i know how to obtain these. Just check the FSUIPC4.LOG file, the paths that matter are always logged there.

Regards

Pete

Share this post


Link to post
Share on other sites
Guest

If you can post there, please refer them to this thread. It is likely to be the same problem. If Simconnect is being blocked it will affect lots of add-ons -- more and more as time goes on. And not just those which use FSUIPC, as TrackIR does not.

Regards,

Pete

ok, will do now!

Share this post


Link to post
Share on other sites
Guest

peter,

i testet now on the addons working OPS setup trackir4 (with IR3 vector hardware) and it is working fine there. it wasnt working on the other OPS with no win update, no addons menue and no trackir....

firewall is up running, the same configuration (web, proxy, LAN and so on as on the other OPS setup....)

so this must have to do with some corrupted win setup, no idea what else the reason can bee....

hopefully now, to get all back running in some days....

Best

Share this post


Link to post
Share on other sites

Hello Pete,

I have a similar problem but with a slight variation. The addon menu appears when I first load FSX and FSUIPC works perfectly but seems to disappear after a few minutes. I've assigned all my joysticks directly in FSUIPC and loose all controls after a few minutes, when I look for the addon menu - it's gone!

I don't have any other addon's installed and have disabled my firewall.

OS : XP Pro sp2

antivirus : AVG

FSUIPC v4.02

regards

Paul

Share this post


Link to post
Share on other sites

I have a similar problem but with a slight variation. The addon menu appears when I first load FSX and FSUIPC works perfectly but seems to disappear after a few minutes. I've assigned all my joysticks directly in FSUIPC and loose all controls after a few minutes, when I look for the addon menu - it's gone!

FSUIPC4 only ever adds its menu entry ("FSUIPC", not "Add-Ons") once, and that is upon initialisation. It never deletes it. Something else must be going wrong, and, in fact, it must be an FSX bug.

Can you show me any FSUIPC4 logs? A simconnect log might be useful too. you'll find instructions on how to get one of those eariler in this thread, I think. if not get back to me.

Regards

Pete

Share this post


Link to post
Share on other sites
that's strange, I'll resend

Paul

Got it now. I'll take a quick look now, but it is getting late so it may be morning before I get back to you.

[LATER]

No need to get back to you in the morning.

There's definitely an FSX bug happening there. The FSUIPC log shows everything okay, it doesn't "disappear", it simply contines for the 10 minutes of your test session (599 seconds in fact), and terminates normally.

However, the Simconnect log shows a different story. As I mentioned, FSUIPC only creates its menu entry once. That is done here, 13 seconds after FSX is started:

> 13.10964 [63, 20]MenuAddItem:szMenuItem="&FSUIPC ...", MenuEventID=10, dwData=0

> 13.10966 [63, 21]MenuAddItem:szMenuItem="&Load Flight ...", MenuEventID=11, dwData=0

> 13.10967 [63, 22]MenuAddItem:szMenuItem="Load Pla&n ...", MenuEventID=12, dwData=0

I see you've also enabled the options for the Flight and Plan loading entries.

The SimConnect log runs fine for 505 seconds (up to less than two minutes before you closed FS -- was that when you saw that the Add-Ons menu had disappeared?

The Simconnect ends abruptly with

505.47342 [63] I/O Error!

.... and that's it. not very informative, but it seems that SimConnect just suffered an irrecoverable error and stopped working. thus, on the next menu re-draw it wasn't there to provide the Add-Ons entry. As well as this, FSUIPC4 would have effectively been left marooned with no access to FSX data!

I'll report this with these details to Microsoft through my channels, but please also do so "officially" via tell_fs@microsoft.com, please.

I can't really do anything about this myself, not unless Microsoft come up with a suggestion or solution, but I still think it is most likely related to your security software or its settings.

You said earlier that you used AVG anti-virus (which others have reported as ok), and that you had "disabled" you firewall (what software though?). I know it isn't a good or nice thing to do, but if you could just try uninstalling all such software (just switching it off doesn't always seem to help) temporarily, it would prove it for MS attention. Please provide all those details in your report too.

Reinstall afterwards, but maybe try to adjust the settings to make FSX completely trusted. This may be a "privacy" part of the firewall program rather than a straight firewall as such. Some programs seem to differentiate between these.

Thanks,

Pete

Share this post


Link to post
Share on other sites

Hello Pete,

Thanks for your feedback

The SimConnect log runs fine for 505 seconds (up to less than two minutes before you closed FS -- was that when you saw that the Add-Ons menu had disappeared?
yes, that's when I noticed control inputs had gone and then checked for the addon menu which had disappeared.
but please also do so "officially" via tell_fs@microsoft.com, please.
will do this evening
You said earlier that you used AVG anti-virus (which others have reported as ok), and that you had "disabled" you firewall (what software though?).
I have disabled Microsoft's security centre firewall and use AVG's firewall (temporarily disabled). Would my router's hardware firewall have any influence?
Reinstall afterwards, but maybe try to adjust the settings to make FSX completely trusted. This may be a "privacy" part of the firewall program rather than a straight firewall as such. Some programs seem to differentiate between these.
will check that this evening

regards

Paul

Share this post


Link to post
Share on other sites

Hello Pete,

The new FSX don't have a module file in your main dir. - as you well know.

I need help and i ask you how the new FSUIPC4 can make possible to install modules in FSX like FSNavigator?

I have a FSUIPC4 registered license since yesterday.

Cheers!

J.Luis

Share this post


Link to post
Share on other sites

Would my router's hardware firewall have any influence?

No. this stuff is not leaving your PC. In fact for FSUIPC4 it isn't even leaving the FSX Process. That's what so daft and annoying about it all! Grrr.

Regards

Pete

Share this post


Link to post
Share on other sites

Pete,

I uninstalled the firewall and excluded the microsoft games folder from the anti-virus, the sim has run for about 2.5 hours without any problems.

regards

Paul

Share this post


Link to post
Share on other sites

The new FSX don't have a module file in your main dir. - as you well know.

That's just one of the reaspns FSUIPC4 comes in an Installer which creates it for you.

I need help and i ask you how the new FSUIPC4 can make possible to install modules in FSX like FSNavigator?

Sorry, I don't know how FSNavigator will install. I expect each module author will choose a different way, unless they use FSUIPC4 (which FSNavigator doesn't).

I only chose to create a Modules folder to install FSUIPC4 into to keep some compatibility and understanding with previous versions, but it didn't have to be like that. Simconnect will load modules from anywhere -- the path is given to it.

Regards

Pete

Share this post


Link to post
Share on other sites

I uninstalled the firewall and excluded the microsoft games folder from the anti-virus, the sim has run for about 2.5 hours without any problems.

Thanks for letting me know -- yet another symptom of the same problem by the look of it. Could you please be sure to report your findings via tell_fs@microsoft.com., with as much information 9which firewall program etc) as possible?

Thanks,

Pete

Share this post


Link to post
Share on other sites

Hi Pete,

thats it, your new interim version 4062 (and hopefully the new 4063) is very robust. After some hours online flying and doing several aircraft change, the module is still there and doesn't disapear from the menu.

Thats great!!!

Thanks a lot, you are doing a good job :-)))

Share this post


Link to post
Share on other sites

thats it, your new interim version 4062 (and hopefully the new 4063) is very robust. After some hours online flying and doing several aircraft change, the module is still there and doesn't disapear from the menu.

If you check the log you'll probably find that it is actually disappearing and re-initialising the SimConnect connection when messages from SimConnect dry up! If that happens there will actually be little intervals of 2-5 seconds with no FSUIPC4 service.

I hope all this will be cleared up in the first update MS issue for FSX!

Regards

Pete

Share this post


Link to post
Share on other sites

I've got the same problem, but I can not fix it.

I've done some logging and stuff for you to check out.

Installation: (this is the second time I install it)

Installer for FSUIPC4.DLL version 4.06

Looking in registry for FSX install path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0

Parameter"SetupPath"

SetupPath="C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\"

Checking version of FSX.EXE:

... Version 10.0.60905.0 (Need 10.0.60905.0)

Checking compatibility with installed SimConnect:

... Okay, Probe Manifest matches an installed SimConnect module

Checking if there's already a version of FSUIPC4 installed in:

C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.DLL

... Version 4.060 found.

FSX Modules folder already exists.

Okay -- installed FSUIPC4 into "C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.DLL"

Looking for the current user's Application Data path:

... found as "C:\Documents and Settings\tommyi\Application Data"

Now finding \Microsoft\FSX\FSX.CFG for all users, including this one

Looking in "C:\Documents and Settings\All Users\Application Data"

No FSX.CFG there

Looking in "C:\Documents and Settings\Default User\Application Data"

No FSX.CFG there

Looking in "C:\Documents and Settings\LocalService\Application Data"

No FSX.CFG there

Looking in "C:\Documents and Settings\NetworkService\Application Data"

No FSX.CFG there

Looking in "C:\Documents and Settings\tommyi\Application Data"

Found FSX.CFG in "C:\Documents and Settings\tommyi\Application Data\Microsoft\FSX\FSX.CFG"!

Now checking DLL.XML ...

... There is a previous DLL.XML, checking for FSUIPC4 section.

... FSUIPC4 section already exists and is correct.

Now checking for a SimConnect.XML file ...

... No SimConnect.XML file found. This is okay.

Now installing additional files into the Modules folder:

Installed "FSUIPC4 User Guide.doc" okay

Installed "FSUIPC4 for Advanced Users.doc" okay

Installed "FSUIPC4 History.doc" okay

Installed "List of FSX controls.pdf" okay

All installer tasks completed okay!

---

FSUIPC4.DLL - This is version 4.06, made 25th November 2006 (vers 4.0.6.0)

In IE, I've checked tabs for "Trusted" and "untrusted" publishers. You are not in ANY of them.

I did NOT get a warning the next time (or the first time) I ran FSX.

The C:\Documents and Settings\tommyi\Application Data\Microsoft\FSX dir has the dll.xml

Its last entries are:

FSUIPC 4

False

Modules\FSUIPC4.dll

I've then made the Simconnect.ini and put it in "My Documents\Flight simulator X Files" folder.

It looks like this:

[simConnect]

level=Verbose

file=C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\Simconnect%01u.Log

file_max_index=1

In C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\Simconnect0.Log file all I get is:

0.00000 SimConnect version 0x00000002

Nothing else.

I have no firewalls other than the windows built-in. Iv added FSX as a trusted program there. I use Norman virus checker. Iv tried to kill all programs, boot with nothing auto-starting, turned off firewall, turned off viruschecker. Nothing helps.

Hope this helps you a bit when trying to figure this out, but my guess is that we have to wait for MS to fix this.

Share this post


Link to post
Share on other sites
I

Installation: (this is the second time I install it)

The installation is okay, as it says, though 4.06 has been superseded by later interim versions here - up to 4.063 now..

In IE, I've checked tabs for "Trusted" and "untrusted" publishers. You are not in ANY of them.

Of course not. I am not trusted by you until you trust me. You do that in the initial security warning you get when running FSX after installing FSUIPC4. There's a drop down where you can say "trust anything by this publisher". There's no way anything of mine is going to act so maliciously as to mess with your trust list!

I did NOT get a warning the next time (or the first time) I ran FSX.

That will be because you said to run it and add it into FSX's list. But next time you get an update for FSUIPC4 you will have to do that again. And each time you do that for every piece of software it adds a line to your FSX.CFG file. That's okay, but it isn't going to affect your trusted publisher list.

The C:\Documents and Settings\tommyi\Application Data\Microsoft\FSX dir has the dll.xml

Its last entries are:

FSUIPC 4

False

Modules\FSUIPC4.dll

And what are the earlier entries? Maybe they are in a mess and things don't get that far?

In later versions ( 4.063 is downloadable above) I put the FSUIPC4 entry at the start to avoid problems with other programs or users messing that file up.

In C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\Modules\Simconnect0.Log file all I get is:

0.00000 SimConnect version 0x00000002

Nothing else.

Hmmm. Either the DLL.XML file is messed up, or there's a simconnect.xml file which prevents local clients, or simconnect is not correctly installed. (The latter seems to happen quite a lot).

Downloading and installing FSUIPC 4.063 should fix the first two, but if the problem persists you'll need to try repairing the Simconnect installation, as described in the FSX Help announcement.

Regards

Pete

Share this post


Link to post
Share on other sites
The installation is okay, as it says, though 4.06 has been superseded by later interim versions here - up to 4.063 now..

http://www.schiratti.com/dowson.html Only have 4.06. So where can we find this 4.063? Could not find a link in your previous post.

Edit:

Ah.. Found this googling: http://fsuipc.simflight.com/beta/Instal4_4063.zip

Now it says: This is version 4.063, made 7th December 2006

And dll.xml looks like this now:

<?xml version="1.0" encoding="Windows-1252" ?>

-

Launch

dll.xml

False

False

-

FSUIPC 4

False

Modules\FSUIPC4.dll

-

Object Placement Tool

True

False

..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll

-

Traffic Toolbox

True

False

..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll

-

Visual Effects Tool

True

False

..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll

Have to see if this help when i get home from work.

Share this post


Link to post
Share on other sites

http://www.schiratti.com/dowson.html Only have 4.06. So where can we find this 4.063? Could not find a link in your previous post.

You should never need a link -- as I said "above". Just scroll to the top of this Forum where all my Announcements are, and you will find Announcements of all new Interim versions. There are links to new versions, notes on changes and so on. Do you NEVER scan the Announcements? The whole point of them and this forum is to help users, but you have to look!!

:-(

Pete

Share this post


Link to post
Share on other sites

http://www.schiratti.com/dowson.html Only have 4.06. So where can we find this 4.063? Could not find a link in your previous post.

You should never need a link -- as I said "above". Just scroll to the top of this Forum where all my Announcements are, and you will find Announcements of all new Interim versions. There are links to new versions, notes on changes and so on. Do you NEVER scan the Announcements? The whole point of them and this forum is to help users, but you have to look!!

:-(

Pete

I'm sorry Pete. I misunderstood you. My fault. Ofcourse I read the announcements, somehow I missed this one. Anyway, good news. Version 063 fixed everything. I now have the meny and I'v managed to register FSUIPC4 and WIDEFS7. Thank you very much for your help Pete.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.