Jump to content
The simFlight Network Forums

Setup Problems


Recommended Posts

Good evening!

After a long time of absence I have to ask a stupid Question, sorry.

I lost my main PC, so I setup th PC new. After installing FS2004, FSUIPC and WideFS in current versions, I registered both successfully, and copy the Backup Files of my FSUIPC.INI and WIDEFS.INI.

Setup LAN like before (Static IP 172.20.20.200, Firewall off, Client can ping the main PC (FS_00))

FSUIPC works fine.

But I am not able to get a connection from any (unchangesd) client PC to the Main PC.

After playing arround for some hours, I decide to ask for help here.

I poste the INI file from the Wideserver and the Client, and also the LOG´s

Thanks for help.

Best Regards from Austria

Peter

[Config]

AutoRestart=0

AutoUpdateTime=13

MaximumBlock=4096

NoStoppedRestarts=Yes

Port=8002

RestartTime=10

SendTimeout=15

TCPcoalesce=No

AdvertiseService=1

ProtocolPreferred=UDP

Port2=9002

; -----------------------------------------------

[user]

Log=Errors+

AllowShutdown=Yes

ShuddownHotKey=67,10

;Run1=c:\fs.exe

;Run2=C:\Programme\SA_WXR\sa_wxr.exe

;Run3=C:\pmSounds\PMSounds.exe

;Run4=C:\pmwetherset\pmGetWeather.exe

;Run5=C:\FS_Override.exe

;Close1=Yes

;Close2=Yes

;Close3=Yes

;Close4=Yes

;Close5=Yes

; ===============================================

[ClientNames]

1=FS_01

2=FS_04

3=FS_02

4=FS_03

5=FS_05

6=FS_06

********* WideServer.DLL Log [version 6.78] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 17/03/09, Time 19:19:50.375: Server name is FS_00

17375 Initialising TCP/IP server

17375 Initialising IPX/SPX server

17375 IPX/SPX socket() failed [Error=10047] Address family not supported by protocol family

17375 Failed to start IPX/SPX Server

17375 Initialising UDP/IP server

18047 Broadcasting service every 1000 mSecs

18047 Preferred protocol = UDP

28515 Restarting service due to total lack of use

28515 Failed to start IPX/SPX Server

; PLEASE SEE WideFS documentation for parameter details

; =====================================================

[Config]

ServerIPAddr=172.20.20.200

Port=8002

Window=32000,32000,112,27

Visible=Yes

ButtonScanInterval=20

ClassInstance=0

NetworkTiming=5,1

PollInterval=2000

ResponseTime=18

ApplicationDelay=0

TCPcoalesce=No

WaitForNewData=500

MaxSendQ=100

Priority=3,1,2

OnMaxSendQ=Log

NewSendScanTime=50

ProtocolPreferred=UDP

MailslotTiming=2000,1000

Port2=9002

; -----------------------------------------------

[user]

Log=Errors+

Run1=c:\FS\PFD\PFD.EXE

AllowShutdown=Yes

Close1=Yes

Keysend4=115,8,ThunderRT5Form,"Project Magenta Glass Cockpit"

Keysend5=112,8,ThunderRT5Form,"Project Magenta Glass Cockpit"

Keysend6=118,8,ThunderRT5Form,"Project Magenta Glass Cockpit"

; ===============================================

********* WideClient Log [version 6.78] Class=FS98MAIN *********

Date (dmy): 17/03/09, Time 19:04:28.911: Client name is FS_01

981 c:\FS\PFD

981 c:\FS\PFD\PFD.EXE

1051 Attempting to connect now

2083 Trying to locate server: Protocol not yet decided

2083 Failed to connect: waiting to try again

4146 Attempting to connect now

11116 New Client Application: "pfd" (Id=1736)

68618 Trying to locate server: Protocol not yet decided

313200 New Client Application: "pfd" (Id=1664)

382650 Trying to locate server: Protocol not yet decided

Link to comment
Share on other sites

I poste the INI file from the Wideserver and the Client, and also the LOG´s

You failed to note which was which, but I worked it out, hopefully correctly:

In the Server INI you have

  • ProtocolPreferred=UDP

implying that you wish the connection to work automatically, and that when it does the Server shall tell the client to use UDP if it is given a choice.
But in the Client you have:
  • ServerIPAddr=172.20.20.200
    ProtocolPreferred=UDP

Four points there:

1. For automatic connection you must not provide the Server name or address.

2. In general it is far better to give the ServerName rather than the IP address, if you are specifying it.

3. "ProtocolPreferred" is not a valid Client parameter. The preference is dictated by the Server, not the Client.

4. If you do specify the Server, as you have done, you should really specify the protocol too: "Protocol=UDP", for example.

That said, I still believe you should have had a connection, though it may have been via TCP not UDP because the client will be trying to initiate the connection instead of waiting for the broadcasts from the Server (it only waits when the client has no specified Server).

Neither WideClient nor WideServer ses any trace of the other. So, these are the possible problems:

a) The most obvious one would be a firewall, or two firewalls, one in each PC. If you have an operating firewall you need to allow WideClient and FS through, on ports 8002 and 9002 (as configured).

b) For the Broadcasting to work (for automatic connection) both PCs need to be in the same workgroup -- i.e. the workgroup names must be the same in both PCs. [Note that broadcasting only applies between WinXP/Vista PCs, not any using Win2K, NT or 98 or earlier].

c) Possibly the IP address is in error: double check the server IP address, or omit it, or use the ServerName=FS_00 parameter instead, and add the Protocol=UDP line too, in this case.

Regards

Pete

Link to comment
Share on other sites

Thanks for help, I changed the INI from the Client as told, and its working again. Strange is only that I didnt change the Client for the last Years, 'only' have to change the main PC?

Best Regards from Austria

Peter

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.