Jump to content
The simFlight Network Forums

Problem with button assignment


Recommended Posts

Hello Peter,

I use FS9 and have installed ver 3.989j.

I would like to assign a joystick button to A/P disconnect on the PMDG737NG. PMDG uses keystroke Z for this purpose - tested OK. However, if I assigned that key press to my button, FSUIPC does recognise the input and saves the assignment but then nothing happens. I have tried both "momentary" and "hold down": same result.

I must be missing something obvious...

Here is the relevant extract of FSUIPC.cfg

[buttons]

ButtonRepeat=20,10

1=H0,2,K90,8

[buttons.B737-700 Easy Jet - Stairs]

0=P0,2,C65791,0

1=P0,3,K71,11

Thanks for your help,

Phil - registered user.

Link to comment
Share on other sites

I would like to assign a joystick button to A/P disconnect on the PMDG737NG. PMDG uses keystroke Z for this purpose - tested OK.

"Z" is, by default, assigned to the FS control 'AP Master", to which of course you can also assign a joystick button in FS itself. If that is what is doing it then, as always, assigning to the control directly, in FSUIPC, is more efficient and often more effective.

However, if I assigned that key press to my button, FSUIPC does recognise the input and saves the assignment but then nothing happens. I have tried both "momentary" and "hold down": same result.

I must be missing something obvious...

Here is the relevant extract of FSUIPC.cfg

[buttons]

ButtonRepeat=20,10

1=H0,2,K90,8

[buttons.B737-700 Easy Jet - Stairs]

0=P0,2,C65791,0

1=P0,3,K71,11

Two things wrong there:

1. With the button repeating whilst held, as you have set in the general button assignments, the AP control will be repeatedly sent, alternately turning the A/P off and on. You certainly don't want that!

2. You have the same button re-assigned specifically for the aircraft named "B737-700 Easy Jet - Stairs", so with that aircraft the assignment to 'Z' will be overruled. For that aircraft the same button will send control 65791, which is "AUTOPILOT OFF".

If that is the aircraft you are testing it with, then it sounds like PMDG have re-used 'Z' for their Autopilot control, but are ignoring the FS controls. In that case you'd need to change your aircraft-specific assignment for that button to send Z too, or instead.

If it isn't the aircraft you are testing it on, then something else is wrong. Enable Button logging in the Logging tab of FSUIPC and re-test, then paste the resulting FSUIPC.LOG text into a message here.

Regards

Pete

Link to comment
Share on other sites

If I remember correctly, the "Z" control in the PMDG 737 operates the A/P disconnect only, not the general A/P on/off that the default FS9 aircraft (and many others use).

It is a while since I flew this aircraft, but I had a look in my FSUIPC .ini file and see that I use a mouse macro to press the A/P 1 switch. I then assign this macro to one of my yoke buttons.

This is probably the way for the OP to proceed. Then it is one press to turn the A/P on and anoher press to turn it off. You dont actually need to use the A/P disconnect switch at all.

Link to comment
Share on other sites

If I remember correctly, the "Z" control in the PMDG 737 operates the A/P disconnect only, not the general A/P on/off that the default FS9 aircraft (and many others use).

It is a while since I flew this aircraft, but I had a look in my FSUIPC .ini file and see that I use a mouse macro to press the A/P 1 switch. I then assign this macro to one of my yoke buttons.

This is probably the way for the OP to proceed. Then it is one press to turn the A/P on and anoher press to turn it off. You dont actually need to use the A/P disconnect switch at all.

Thank you, both Petes, for your quick responses.

I, too, thought that PMDG used keystroke Z for disconnect only, which is what I wanted the button to do. I therefore did not mind if the keypress was repeated. I thought I had also unsuccessfully tried the "no repeat" setting but maybe not.

Upon retest, I have found out that the PMDG "Z" command toggles the Autopilot on/off, so that my setting was wrong. I unticked the "keypress to be held" and... problem solved. I don't see why a mouse macro is required - it seems to work as is.

Thanks again!

Philippe

In

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.