Jump to content
The simFlight Network Forums

again widefs and radar contact


Recommended Posts

I'm trying again to get radar contact working on a second machine using widefs but still no success.

Can you tell me what am I doing wrong ?

Thanks!

Vic

here's the log I got from widefs:

---------

********* WideClient Log [version 6.78] Class=FS98MAIN *********

Date (dmy): 23/11/10, Time 17:07:32.444: Client name is VIC-PC

344 Attempting to connect now

344 Trying TCP/IP addr 192.168.0.3, port 50300 ...

359 Connection made okay!

36552 Timed out response: connection assumed lost!

36552 Ready to try connection again

36598 Timed out response: connection assumed lost!

37597 Attempting to connect now

37597 Connection made okay!

49765 New Client Application: "rcv4" (Id=3036)

55630 Timed out response: connection assumed lost!

55630 Ready to try connection again

55677 Timed out response: connection assumed lost!

56676 Attempting to connect now

56676 Connection made okay!

74928 Timed out response: connection assumed lost!

74943 Ready to try connection again

74990 Timed out response: connection assumed lost!

75989 Attempting to connect now

75989 Trying TCP/IP addr 192.168.0.3, port 50300 ...

75989 Connection made okay!

----

Link to comment
Share on other sites

here's the log I got from widefs:

Well that's only the WideClient log -- half the story. Network connections between PCs have at least two ends. The server is operating at the FS end, and there will be a WideServer log there, showing what it did.

The thing that concerns me in your client log is this:

344 Trying TCP/IP addr 192.168.0.3, port 50300 ...

What have you been changing in the WideClient INI file? Why port 50300, and if you want to use that port (assuming it's legal and available), have you changed the settings in the Server too, to match?

Is that IP address correct? Why are you specifying IP addresses? Providing both your PCs are in the same workgroup you shouldn't need to change anything at all in either INI file.

Please tell me what you are doing and why you are doing it and I might be able to help. Generally it is best to stick to the documented methods, which really involve no messing with INI files at all.

Regards

Pete

Link to comment
Share on other sites

Well that's only the WideClient log -- half the story. Network connections between PCs have at least two ends. The server is operating at the FS end, and there will be a WideServer log there, showing what it did.

Yes I just looked up the wideserver log and here it is:

********* WideServer.DLL Log [version 7.634] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 24/11/10, Time 02:42:16.454: Server name is VICKY-PC

15023 Initialising TCP/IP server

15023 Initialising IPX/SPX server

15023 IPX/SPX socket() failed [Error=10044] Socket type not supported

15023 Failed to start IPX/SPX Server

15023 Initialising UDP/IP server

16131 Broadcasting service every 1000 mSecs

-------------------

-

>What have you been changing in the WideClient INI file? Why port 50300, and if you want to use that port (assuming it's legal and available), have you changed the settings in the Server too, to match?

----

I have added IP and port to both inis so that they matched.

>Is that IP address correct? Why are you specifying IP addresses? Providing both your PCs are in the same workgroup you shouldn't need to change anything at all in either INI file.

>Please tell me what you are doing and why you are doing it and I might be able to help. Generally it is best to stick to the documented methods, which really involve no messing with INI files at all.

---

Both pcs are in the same workgroup and I changed things because things were not working out for some reason and i thought that adding those lines maybe I would get both pcs to "talk".

I just added protocol tcp, server address 192.168.03 (which is right) and port numbers.This is it really.Now widefs seems to be connecting but the fsx machine throws up an error.

Thanks

Vic

Link to comment
Share on other sites

Yes I just looked up the wideserver log and here it is

That simply shows that nothing even attempted to connect to it.

But it does show the Server name: VICKY-PC

And the fact that it is broadcasting its details for WideClient to find:

16131 Broadcasting service every 1000 mSecs

I have added IP and port to both inis so that they matched.

You do NOT set any IP address in the Server files!

WHY are you changing anything? You should really leave all alone.

Both pcs are in the same workgroup and I changed things because things were not working out for some reason and i thought that adding those lines maybe I would get both pcs to "talk".

Do NOT change the port numbers. There's never any need unless you have other FS programs using the same ports already. The one you chose could well be taken or invalid for all I know.

I just added protocol tcp, server address 192.168.03 (which is right) and port numbers.

Why port numbers? Wherever did you read you needed to set those?

And if your network is working AND they are truly in the same Workgroup, you should not change anything. No protocol line, no IPaddress line. Even if you do specify things it is usually best to give the ServerName, not the IP address.

This is it really.Now widefs seems to be connecting but the fsx machine throws up an error.

And you provide no information for me to help .... no logs, no details of the error, nothing?

I think you'd be better off deleting the WideClient INI file and the complete [WideServer] section in the FSUIPC4.INI file, and trying again without making any changes at all. THEN show me both logs.

Regards

Pete

Link to comment
Share on other sites

...

I think you'd be better off deleting the WideClient INI file and the complete [WideServer] section in the FSUIPC4.INI file, and trying again without making any changes at all. THEN show me both logs.

Regards

Pete

Hi,

Ok will do as you suggested and report back

Vic

P.S.= the port 50300 is one of the ports I use to network active sky/rex weather engines

Link to comment
Share on other sites

I think you'd be better off deleting the WideClient INI file and the complete [WideServer] section in the FSUIPC4.INI file, and trying again without making any changes at all. THEN show me both logs.

Regards

Pete

I have done what you suggested. here's the wideclient log

-------

********* WideClient Log [version 6.78] Class=FS98MAIN *********

Date (dmy): 24/11/10, Time 14:01:14.482: Client name is VIC-PC

250 Attempting to connect now

1264 Trying to locate server: Need details from Server Broadcast

1264 Failed to connect: waiting to try again

3307 Attempting to connect now

45958 New Client Application: "rcv4" (Id=5064)

----------

here's the wideserver log. The time difference is because the client pc's clock is one hour behind..

--------

********* WideServer.DLL Log [version 7.634] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 24/11/10, Time 15:00:35.428: Server name is VICKY-PC

15990 Initialising TCP/IP server

15990 Initialising IPX/SPX server

15990 IPX/SPX socket() failed [Error=10044] Socket type not supported

15990 Failed to start IPX/SPX Server

15990 Initialising UDP/IP server

16115 Broadcasting service every 1000 mSecs

-----------

Vic

----------------

Link to comment
Share on other sites

I have done what you suggested. here's the wideclient log

Okay. Then the broadcasts from the Server are definitely NOT reaching the client, which either means the client is running an old version of Windows (before XP), or you've not got the WorkGroup names the same as you said.

Please double check the workgroup names. Win7/Wista and XP default to different names, so you can't rely on just leaving it. I name mine "PETES" throughout.

Alternatively, you CAN put "ServerName=VICKY_PC" and "Protocol=TCP" into the [Config] section of the WideClient.INI (don't touch the Server end, or the Ports). But it would be better to have it operating automatically.

Pete

Link to comment
Share on other sites

Okay. Then the broadcasts from the Server are definitely NOT reaching the client, which either means the client is running an old version of Windows (before XP), or you've not got the WorkGroup names the same as you said.

Pete

None of the above. I'm running win 7 (fsx machine) and Vista (client) and the workgroups are named the same .

2 screenies.

post-17121-0-97604800-1290614461_thumb.j

post-17121-0-58796100-1290614532_thumb.j

Link to comment
Share on other sites

[quote name='Pete Dowson' timestamp='1290609819' post='41895

Alternatively, you CAN put "ServerName=VICKY_PC" and "Protocol=TCP" into the [Config] section of the WideClient.INI (don't touch the Server end, or the Ports). But it would be better to have it operating automatically.

Pete

I put servername vicky-pc and protocol tcp and now it works :P. Thanks a lot.can't wait till I can figure it out how to do it automatically since you say it's better.

Thx

Vic

Link to comment
Share on other sites

I put servername vicky-pc and protocol tcp and now it works :P. Thanks a lot.can't wait till I can figure it out how to do it automatically since you say it's better.

It's only "better" because it is automatic, saving you putting any parameter changes in. Now you've got the right parameters (the ones advised by the documentation, in fact, if you do have difficulties), it makes no difference.

I don't understand why the Broadcasts aren't seen by another PC on the same workgroup. Makes no sense to me. But then I moved off Vista as soon as I could. Win7 is soooo much better! ;-)

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.