Jump to content
The simFlight Network Forums

2 versions of fsuipc in fs9 modules


Recommended Posts

Hi, my thanks to Pete Dawson for a fantastic product. I need help with an issue where the ch throttle quadrant, the throttles are not being recognized. This is on a Win 7 machine. If I play with the fsuipc joystick programs, it will recognize it for one flight, but then kicks it out. I ran "flight instructor" through compatability manager, and I get an error "2 instances of fsuipc running" I comb through the modules folder,and can not find what it means. There is only 1 fsuipc.dll, version 3.9.8, there are other fsuipc only modules, including a default microsoft one, but they all look like they are necessary. There are no errors being reported in the fsuipc log. The install reports that there was an instance of fsuipc.dll 3.8 running (an add-on?), but can not find what it means. Any help so I can get flying, appreciated. Thanks in advance.

AMD 2.66 quadcore, nvidea graphics, 2 gigs ram

Link to comment
Share on other sites

Hi, thanks for responding. I have done that, I have "show hidden files/folders checked, I have even done searches with "hide system files" unchecked. It only brings up the one instance of fsuipc.dll. That has been upgraded to 3.9.9.1, as of last night. The error message only says "fsuipc", but searching for that brings up a couple of text files, and then config settings and the key code. I lost track of how many searches I have done, including removing the "index" function.

It is very weird, the yoke and pedals (ch) work fine, the throttle quadrant I have set up as 4 throttles, 1 mix, and 1 prop, and the mix and prop always are fine. Whenever i bring up a plane, or switch planes, I have to go into "joystick calibrations" move the throttle levers, and then the plane will recognize the control. Switch planes and I have to do that again. Then the flight is normal. I have taken snap shots of the modules directory, if that would help. Searching the entire fs9 directory for "fsuipc", will have that file showing up in certain add-ons....I guess I have to investigate that now. But it only shows the one licensed version of fsuipc.dll, 3.9.9.1. This is a recent set up of a new Win 7 pc. it is about a month old. Everything has been installed anew, no folders being copied from back up.

Hi,

No, there is no FSUIPC.dll from Microsoft. There is an FSUI.dll from Microsoft and that stays.

Search your FS directory for FSUIPC.dll and see how many instances show up.

Link to comment
Share on other sites

Hi, thanks for responding. I have done that, I have "show hidden files/folders checked, I have even done searches with "hide system files" unchecked. It only brings up the one instance of fsuipc.dll. That has been upgraded to 3.9.9.1, as of last night. The error message only says "fsuipc", but searching for that brings up a couple of text files, and then config settings and the key code. I lost track of how many searches I have done, including removing the "index" function.

The apparent presence of more than one copy of FSUIPC running most usually occurs when the previous run of FS is actually still running, in the background, with no windows showing. This is caused by one or more threads hanging in what is known as a "deadly embrace", and seems to occur quite often with some add-ons.

So next time it happens, call up the Windows task manager, and look for a Process called "FS9.exe". Terminate it forcibly from the task manager.

It is very weird, the yoke and pedals (ch) work fine, the throttle quadrant I have set up as 4 throttles, 1 mix, and 1 prop, and the mix and prop always are fine. Whenever i bring up a plane, or switch planes, I have to go into "joystick calibrations" move the throttle levers, and then the plane will recognize the control. Switch planes and I have to do that again.

That's an entirely different matter, and really more related to the hardware driver for the throttle quadrant. There should never be any reason to have to revisit FSUIPC options when changing planes. Maybe I need to see your FSUIPC.INI file.

Regards

Pete

Link to comment
Share on other sites

Hi Pete. OK, I will look for the next time it reports two running. I find that the forum won't allow me to upload the ini file...it says "can not upload a file of this type" -Could this be because I sit at a mac for my forum reading...Or do I need to find some other way of getting it to you? It also deleted my first response when I tried to upload the files.

I should report something else. When I first set up fs 9 on this Win 7 machine, I had some serious problems with the elevator axis( pushing forward on the yoke, would bring the plane down, but pushing more and the plane would dive and not recover) and I solved this by running and calibrating everything in CH Control Manager. It was after I did this I stumbled on "Compatibility Manager", which I had not known about. I should add that I use fsuipc exclusively for the controls. This led to the plane flying "just right", but the throttle issue crept in, first I could get the plane to read throttle adjustments, or regain them, by just clicking one of the programmed switches, but quickly led to it dropping the throttles completely, and having to run through throttles in "joystick calibrations". Now I have deleted the CH software, it retained all axis's, one strange thing occurred however, the elevator trim (set up on the yoke prop axis) has no effect on the trim of the default King Air 350. But does work on a P. A. D. Beech 1900. I kind of wish I had left the CH software intact.

I also ran a log for about ten minutes, trying to see if the log would catch something, but it only listed the first plane I tried and not the other ones I switched in to produce the issue.

OK, I am going to post this, and then try to repost at the pc the ini and log file. Let me know if I am supposed to use a different method to upload the ini file.

jeff

Link to comment
Share on other sites

I find that the forum won't allow me to upload the ini file

Just paste the text into a message. That's what everyone has to do. INI, CFG asnd LOG files are only text files, it isn't a problem.

I had some serious problems with the elevator axis( pushing forward on the yoke, would bring the plane down, but pushing more and the plane would dive and not recover

Sounds correct. Why would you want to do that?

) and I solved this by running and calibrating everything in CH Control Manager. It was after I did this I stumbled on "Compatibility Manager", which I had not known about. I should add that I use fsuipc exclusively for the controls. This led to the plane flying "just right", but the throttle issue crept in, first I could get the plane to read throttle adjustments, or regain them, by just clicking one of the programmed switches, but quickly led to it dropping the throttles completely, and having to run through throttles in "joystick calibrations". Now I have deleted the CH software, it retained all axis's

Sounds like conflicting inputs. Too many things trying to provide inputs.

one strange thing occurred however, the elevator trim (set up on the yoke prop axis) has no effect on the trim of the default King Air 350. But does work on a P. A. D. Beech 1900.

i can't imagine any aircraft not responding to elevator trim. That makes no sense.

I kind of wish I had left the CH software intact.

There's a forum known as the CH Hangar. Google it. Bob Church over their gives good advice on setting up CH software and FSUIPC to run harmoniously.

I also ran a log for about ten minutes, trying to see if the log would catch something, but it only listed the first plane I tried and not the other ones I switched in to produce the issue.

Sorry, no idea what you mean here.

Regards

Pete

Link to comment
Share on other sites

Hi. The log file I tried to generate, I was trying to see if it would pick up the dropped throttle.

The thing with the elevator axis, before I put in the ch control manager, pushing forward would cause a normal tilt down, yet all of a sudden the plane would make a very abrupt dive.

I will look into the ch forum. Before I deleted the ch manager, the plane would fly beautifully, except for the thing with the dropped throttles. I had suspected there was a conflict with the ch manager. Here is the ini:

********* FSUIPC, Version 3.991 by Pete Dowson *********

Running on Windows Version 5.1 Build 2600 Service Pack 2

Verifying Certificate for "C:\Program Files (x86)\Microsoft Games\Flight Simulator 9\MODULES\FSUIPC.DLL" now ...

SUCCESS! Signature verifies okay!

Running inside FS2004 (FS9.1 CONTROLS.DLL, FS9.1 WEATHER.DLL)

User Name="jeff harr"

User Addr="bpmdawn@earthlink.net"

FSUIPC Key is provided

WideFS Key is provided

Module base=61000000

WeatherReadInterval=4

LogOptions=00000001

DebugStatus=255

8596 System time = 01/06/2011 16:25:29

8596 \\PCFLTSIM\Flight Simulator 9\

8596 System time = 01/06/2011 16:25:29, FS2004 time = 12:00:00 (00:00Z)

42807 FLIGHTS\OTHER\FLTSIM.flt

42854 AIRCRAFT\c172\Cessna172SP.air

42869 Aircraft="Cessna Skyhawk 172SP"

43759 Clear All Weather requested: external weather discarded

85395 Advanced Weather Interface Enabled

85411 Traffic File #14 = "scenery\world\scenery\traffic030528"

409253 WeatherOptions set, now 4000B627 (timer=0)

462231 AIRCRAFT\B1900C_2_9\Beech_B1900.air

462278 Aircraft="B1900CC ACE"

601259 \\PCFLTSIM\Users\jeff\Documents\Flight Simulator Files\ Program generated temporary flight.flt

603459 Clear All Weather requested: external weather discarded

1229475 AIRCRAFT\beech_king_air_350\Beech_King_Air_350.air

1229522 Aircraft="Beech King Air 350"

1332779 FLIGHTS\OTHER\FLTSIM.flt

1332826 AIRCRAFT\c172\Cessna172SP.air

1332857 Aircraft="Cessna Skyhawk 172SP"

1333653 Clear All Weather requested: external weather discarded

1359346 System time = 01/06/2011 16:48:00, FS2004 time = 10:15:13 (17:15Z)

1359346 *** FSUIPC log file being closed

Memory managed: 0 Allocs, 12112 Freed

********* FSUIPC Log file closed ***********

I think this is the ini. If you mean something else like the install log.....I can provide that. Thanks, Jeff

Link to comment
Share on other sites

Hi Pete. I am a newbie, been at this for a year, but had no problems with the old comp with xp, slow graphics though, no problem except if trying to use default MSFT for controls. This Win 7 machine is only about 2 months old.

It occurs to me after browsing forums, by .ini you mean the configurqtion settings file, so here it is. Ini is not marked unless I am mistaken about that too. ::

[JoyNames]

AutoAssignLetters=No

0=CH ECLIPSE YOKE

0.GUID={705D7600-7951-11E0-8001-444553540000}

1=CH THROTTLE QUADRANT

1.GUID={EAEAFD70-7776-11E0-8003-444553540000}

2=CH PRO PEDALS USB

2.GUID={EAEAFD70-7776-11E0-8002-444553540000}

[General]

UpdatedByVersion=3991

WindSmoothing=No

AutoTaxiWind=No

PropTaxiWind=No

TimeSetMode=Partial

WhiteMessages=No

ThrottleSyncAll=Yes

GraduatedVisibility=No

LowerVisAltitude=0

UpperVisAltitude=25000

UpperVisibility=6000

GenerateCirrus=No

WindShearSharp=No

UpperWindGusts=Yes

ExtendMetarMaxVis=Yes

CorrectVSsign=Yes

MouseWheelTrim=No

MouseWheelTrimSpeed=1

BrakeReleaseThreshold=75

AxisInterceptIfDirect=No

DontResetAxes=No

DisconnTrimForAP=Yes

ZeroElevForAPAlt=No

AutoClearWeather=Yes

ExtendTopWind=No

WindSmoothness=5

SmoothPressure=No

PressureSmoothness=1

SmoothVisibility=No

VisibilitySmoothness=2

MaxSurfaceWind=0

WindLimitLevel=0

WindDiscardLevel=0

WindAjustAltitude=No

WindAjustAltitudeBy=2000

MinimumVisibility=0

MaximumVisibilityFewClouds=0

MaximumVisibility=0

MaximumVisibilityOvercast=0

MaximumVisibilityRainy=0

OneCloudLayer=No

ThinClouds=No

ThinThunderClouds=No

CloudThinness=100

ThunderCloudThinness=10000

CloudTurbulence=No

CloudIcing=No

WindTurbulence=No

SuppressAllGusts=No

ExternalOptionControl=Yes

AutoTuneADF=No

KeepFS98CloudCover=No

ShowPMcontrols=No

MagicBattery=20

RudderSpikeRemoval=No

ElevatorSpikeRemoval=No

AileronSpikeRemoval=No

ReversedElevatorTrim=No

StopAutoFuel=No

TrapUserInterrupt=Yes

NavFreq50KHz=Yes

ClockSync=Yes

SmoothIAS=Yes

SetVisUpperAlt=No

VisUpperAltLimit=0

MaxIce=3

MinIce=0

WindSmoothingDelay=0

WindSmoothAirborneOnly=No

LimitWindVariance=No

VisSmoothingDelay=0

VisSmoothAirborneOnly=No

TrafficControlDirect=Yes

SuppressCloudTurbulence=No

SuppressWindTurbulence=No

SpoilerIncrement=512

JoystickTimeout=20

PollGFTQ6=Yes

BlankDisplays=No

ZapSound=firework

ShortAircraftNameOk=No

UseProfiles=No

TCASid=Flight

TCASrange=40

TrafficScanPerFrame=10

AxisCalibration=No

CentredDialogue=Yes

ShowMultilineWindow=Yes

SuppressSingleline=No

SuppressMultilineFS=No

ClearWeatherDynamics=Yes

OwnWeatherChanges=No

FixWindows=No

FixControlAccel=Yes

WeatherReadInterval=4

MoveBGLvariables=Yes

TimeForSelect=4

WeatherReadsFast=No

MainMenu=&Modules

SubMenu=&FSUIPC ...

History=4D5EZ2NZLVX53Z27UTL5U

ThrottleSyncToggle=77,9

AllEngHotKey=78,9

LuaRerunDelay=66

[JoystickCalibration]

AllowSuppressForPFCquad=Yes

ExcludeThrottleSet=Yes

ExcludeMixtureSet=Yes

ExcludePropPitchSet=Yes

SepRevsJetsOnly=No

ApplyHeloTrim=No

UseAxisControlsForNRZ=No

FlapsSetControl=0

FlapDetents=No

ReverserControl=66292

Reverser1Control=66422

Reverser2Control=66425

Reverser3Control=66428

Reverser4Control=66431

MaxThrottleForReverser=256

AileronTrimControl=0

RudderTrimControl=0

CowlFlaps1Control=0

CowlFlaps2Control=0

CowlFlaps3Control=0

CowlFlaps4Control=0

MaxSteerSpeed=60

MapCowl1to1234=Yes

Aileron=-16253,-780,0,16128

Elevator=-16253,0,256,16256

LeftBrake=-15343,16383/16

RightBrake=-15993,16383/16

Throttle1=-16253,-11963,-9232,14464

Throttle2=-15733,-11833,-10012,14592

Throttle4=-15343,-11572,-9622,14208

ElevatorTrim=-16223,-161,352,16320

CowlFlaps1=-16384,16383

MapCowl12to123=Yes

MapCowl12to34=Yes

Rudder=-16253,0,0,16128

PropPitch=-16384,14848

Mixture=-16253,14336

Throttle3=-16384,-12353,-10922,13696

[buttons]

ButtonRepeat=20,10

1=P0,1,C65589,0

2=P0,20,C66531,0

3=P0,22,C66224,0

4=P0,5,C65603,0

5=P0,4,C65595,0

6=P0,7,C65758,0

7=P0,6,C65759,0

8=P1,8,C65561,0

9=P1,9,C65752,0

10=R0,32,C65734,0

11=R0,33,C65856,0

12=R0,34,C65672,0

13=R0,35,C65857,0

14=R0,36,C65735,0

15=R0,37,C65855,0

16=R0,38,C65671,0

17=R0,39,C65854,0

18=P0,8,C65567,0

19=P0,9,C65749,0

20=P1,7,C65570,0

21=P1,10,C65567,0

22=P1,11,C65749,0

23=P2,10,C65567,0

24=P2,11,C65830,0

25=P2,8,C65561,0

26=P2,9,C65752,0

27=P2,7,C65570,0

28=P0,0,C65559,0

[Axes]

0=0X,256,D,0,1,0,0

1=0Y,256,D,2,0,0,0

2=0Z,256,D,0,0,0,29

3=0R,256,D,0,2,0,0

4=0U,256,D,21,0,0,0

5=0V,256,D,0,0,21,0

6=1X,256,D,0,5,0,0

7=1Y,390,D,6,0,0,0

8=1Z,390,D,0,0,0,12

9=1R,390,D,9,0,0,0

10=1U,260,D,0,10,0,0

11=1V,130,D,0,0,11,0

12=2X,384,D,0,7,0,0

13=2Y,640,D,0,0,8,0

14=2Z,256,D,3,0,0,0

15=2R,256,D,0,0,11,0

16=2U,256,D,0,10,0,0

17=2V,256,D,9,0,0,0

[sounds]

Path=C:\Program Files (x86)\Microsoft Games\Flight Simulator 9\Sound\

Device1=Primary Sound Driver

Device2=Speakers (Realtek High Definition Audio)

Device3=Realtek Digital Output (Realtek High Definition Audio)

I hope i am not bogging things up by posting a wrong and large file

Thanks, yours, Jeff

Link to comment
Share on other sites

Hi. The log file I tried to generate, I was trying to see if it would pick up the dropped throttle.

The thing with the elevator axis, before I put in the ch control manager, pushing forward would cause a normal tilt down, yet all of a sudden the plane would make a very abrupt dive.

Sounds like a spiking to max deflection. Usually a symptom of a bad connection or faulty or dirty pot in the control.

I will look into the ch forum. Before I deleted the ch manager, the plane would fly beautifully, except for the thing with the dropped throttles. I had suspected there was a conflict with the ch manager. Here is the ini:

No, that's the Log file.

I think this is the ini. If you mean something else like the install log.....I can provide that.

No. There will be two logs -- the install log and the run-time log (the one above), a KEY file, containing your registration, and an INI file, which contains all of your FSUIPC settings. It sounds as if you have Windows set to hide the proper filenames from you! You should change that, it's not good.

Ah, I've just seen your second message:

It occurs to me after browsing forums, by .ini you mean the configurqtion settings file, so here it is. Ini is not marked unless I am mistaken about that too. ::

You really need to change the Explorer options if you want to find files properly. There are instructions in the FSUIPC Installing and Registering guide, at the end (see "ADDENDUM: IDENTIFYING FILES IN WINDOWS EXPLORER"

In your INI file you seem to have an odd assortment of Axis assignments:

[Axes]

0=0X,256,D,0,1,0,0

1=0Y,256,D,2,0,0,0

2=0Z,256,D,0,0,0,29

3=0R,256,D,0,2,0,0

4=0U,256,D,21,0,0,0

5=0V,256,D,0,0,21,0

6=1X,256,D,0,5,0,0

7=1Y,390,D,6,0,0,0

8=1Z,390,D,0,0,0,12

9=1R,390,D,9,0,0,0

10=1U,260,D,0,10,0,0

11=1V,130,D,0,0,11,0

12=2X,384,D,0,7,0,0

13=2Y,640,D,0,0,8,0

14=2Z,256,D,3,0,0,0

15=2R,256,D,0,0,11,0

16=2U,256,D,0,10,0,0

17=2V,256,D,9,0,0,0

Sometimes you used the first line, sometimes the second or third or even forth. Why? Generally you'd only use the 2nd 3rd or 4th when assigning 2, 3 or 4 controls to the one axis.

And you have a number of duplicates too. Is that intentional? e.g. 2 x 2 (Elevator), 2 x 21 (elevator trim axis), 2 x 9 (Throttle 1), 2 x 10 (Throttle 2), 2 x 11 (Throttle 3), 2 x 12 (Throttle 4).

You also have the generic throttle (3) assigned "direct to FSUIPC calibration", yet you've not even calibrated it!

I reckon all of your problems are due to multiple axes all trying to operate the same controls. Why have you done that?

If I were you I'd delete the whole [Axes] section, and start again, this time keep it simply. Assign only one of each, not several to different levers. You are inevitably going to get them cross-interfering!

If you really don't know what you are doing, do NOT do any assignments whatsoever in FSUIPC, only in FS. You can still calibrate them in FSUIPC.

Regards

Pete

Link to comment
Share on other sites

I will try that. I did not realize you had responded, sitting here and there was no email notification that I expected. I hope it is this simple. The only multiple assignment I thought I had done was the cowl flaps on one lever.

Deleting the CH manager ultimately was no problem. I will post how I make out.

Thanks, jeff

Link to comment
Share on other sites

I did not realize you had responded, sitting here and there was no email notification that I expected.

There might be a way of "subscribing" to threads here, but I don't know (I've not looked, sorry). I don't think any Forums automatically send emails -- with most, unless it is automatic, no one even knows your email address in any case.

Regards

Pete

Link to comment
Share on other sites

Hi Pete, thanks for response. There is an email notification check box, and at first it would tell me of a response, and now doesn't. Anyway. I just went through the fsuipc users guide, and under "resetting defaults" you can try using the "reset" buttons, or it says you can just go into the ini file, and delete the section under "joystick calibrations" _it seems if I do that, I will be starting from a completely clean start. Do I need to concern myself with the section under "axes", or do I Ieave that alone?

Thanks for your time and help, Jeff

Link to comment
Share on other sites

There might be a way of "subscribing" to threads here...

The "Watch Topic", or "Watch Forum" buttons at the top right corner will e-mail you on your registered address when a new post is made on the topic or forum as appropriate.

Cheers,

Ian P.

Link to comment
Share on other sites

The "Watch Topic", or "Watch Forum" buttons at the top right corner will e-mail you on your registered address when a new post is made on the topic or forum as appropriate.

Ah yes, thanks. So obvious there I never noticed! Of course I wouldn't really have looked for it in this Forum as I watch all topics! ;-)

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.