Jump to content
The simFlight Network Forums

OOM with new updated FSUIPC


Recommended Posts

Pete,

I updated FSUIPC as needed in May. After I did that, I have OOM issues in FSX.

Everything starts fine when starting FSX. Once I fly to an airport with more complex scenery like Flightbeam KIAD, I hear the warning sound of FSUIPC that I run out of memory. After about 7 to 8 minutes FSX closes with an OOM message.

The thing is, before the update I had never problems. I could fly the whole day with complex scenery and 100% AI traffic and everything went fine without ever reloading FSX.

I also tried to switch off AI traffic, but same problem.

Firstly I thought it is a matter of time, the longer I fly the bigger the memory issue. But when I startup at for example at KIAD with Flightbeam scenery. I taxi to the runway and the OOM occurs after having run FSX for about 20 minutes.

If I use default scenery, the OOM thing does not happen.

Do you have any idea?

I updated as it was described, but I must say, that I updated FSUIPC, not WideFS, but the FSUIPC screen in FSX looks right with FSUIPC enabled and registered, under the button Wide FS is "disable", so it is also activated and it works fine.

I have 6 GB of Ram, an I7 core CPU 3.33 GHZ (4CPU's), Windows 7 Home premium 64 bit, Direct X 11.,

2x Nvidia GeForce Gtx 460.

I run FSX in windowed mode. Tried also to switch to fullscreen, but no difference.

Thanks very much for help!

Kind regards,

Stefan

Link to comment
Share on other sites

I updated FSUIPC as needed in May. After I did that, I have OOM issues in FSX.

 

There is no way FSUIPC can cause OOM issues, it is merely reporting them. You have something else going on. You'll need to undertake a series of eliminations of your add-ons and scenery installations.

 

Also if you haven't upgraded since May then you are out of date and using an unsupported version. The earliest currently supported version is 4.91, and there's a 4.911 interim update already released since then.

 

 

under the button Wide FS is "disable", so it is also activated and it works fine.

 

The "disable" button it there to disable it should you need to. When disabled it changes to an enable button to reverse that action. It does what it says.

 

Pete

Link to comment
Share on other sites

Hi Pete,

thanks for your reply!

I have the 4.90 version from May 5th 2013.

I don't say, that FSUIPC causes the crash. It started after the update, so thought about what did I change and only FSUIPC came in my mind.

I inserted 12 GB Ram now to see if it works. If not, I try to eliminate scenery. I assume that maybe Flightbeam KIAD can be a part of it.

I just asked you, because maybe you heard about these OOM issues before. I couldn't find anything about in the net.

Thanks anyway!

Regards,

Steffen

Link to comment
Share on other sites

I have the 4.90 version from May 5th 2013.

 

Yes, and that is now unsupported. it was superseded by 4.91 as I said.

 

I inserted 12 GB Ram now to see if it works.

 

There is no point. FS cannot use more than 4Gb as it is a 32-bit program! The OOM never means you are out of physical memory in any case as Windows is a paged system -- it swaps less-accessed areas out to a page file on disk.

 

I couldn't find anything about in the net.

 

Really? You've not looked far then. It is one of the most discussed topics on many Forums. Check the appropriate threads in the AVSIM FSX Forum. You will learn a lot. One of the things to do is turn down some of the sliders in FSX's graphics settings, for instance. There are many causes and many ways of reducing their occurrence. But adding more real memory is not one of them!

 

Pete

Link to comment
Share on other sites

There is no point. FS cannot use more than 4Gb as it is a 32-bit program! The OOM never means you are out of physical memory in any case as Windows is a paged system -- it swaps less-accessed areas out to a page file on disk.

 

My understanding is that FSX will only use 2Gb in the user mode virtual address space. More info here:

http://msdn.microsoft.com/en-us/library/windows/desktop/aa366778%28v=vs.85%29.aspx#memory_limits

 

However there seems to be a Large Memory Address aware fix (to use 4Gb) for Win 7 64bit here:

http://kostasfsworld.wordpress.com/2012/09/24/oom-out-of-memory-helperfix/

 

Haven't tried it as I still only use fs9.

 

Like you said adding more physical ram will do nothing for FSX.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.