Jump to content
The simFlight Network Forums

Wide Client loss of communication during flight


Recommended Posts

Hi Pete,

RCV4 and  VAFS5 stop communicating with FSX (server PC) midway along the route (PHNL-MHTG).  This has happened 3 flights in a row (same route).

On the third flight attempt, I shut down RCV4.  Then I shut down and restarted Wide Client,  and VAFS5 started responding and it continued to function

properly until the successful conclusion of the flight.  What might be causing Wide Client to suddenly stop functioning?  The malfunction does not

occur at the same point along the route.

  I have just reinstalled the WideClient.exe file on my client laptop, and have reinstalled the FSUIPC.dll file on the FSX (server) PC. 

  FYI,  I also have ASNext installed on the laptop.  As you likely know, ASN connect to the server via Simconnect and appears to be unaffected by whatever

is interrupting Wide Client.

My setup >>

Win7-64

FSX Acceleration

the aircraft = PMDG B777-200LR

FSUIPC version = 4939k

Wide FS version = 6999n

 

Thank you,

Ken Boardman

 

Link to comment
Share on other sites

RCV4 and  VAFS5 stop communicating with FSX (server PC) midway along the route (PHNL-MHTG).  This has happened 3 flights in a row (same route).

On the third flight attempt, I shut down RCV4.  Then I shut down and restarted Wide Client,  and VAFS5 started responding and it continued to function

properly until the successful conclusion of the flight.  What might be causing Wide Client to suddenly stop functioning?  The malfunction does not

occur at the same point along the route.

 

I'd need to see the WideClient and FSUIPC4 log files from the server and the Wideclient log file from the client. That's what logs are for, to show what might be going on.  You can paste them into a message here. Use the <> button above the edit area to enclose them neatly.

 

FSUIPC version = 4939k

 

The current version is 4.939n. Please update first.

 

Pete

Link to comment
Share on other sites

Hi Pete,

  I completed two successful flights > KSFO-KDEN and MHTG-PHNL.  Then retried the PHNL-MHTG route and had the same problem as earlier.  I'm getting prepared to (re)start the problematic PHNL-MHTG route again, and this time with a new (different) flight plan.

The logs from tonight's failed flight are below.

Wide FS Client >

********* WideClient Log [version 6.999n] Class=FS98MAIN *********
Date (dmy): 10/05/15, Time 01:11:16.158: Client name is KENS_LAPTOP1
      234 LUA: "C:\WideFS\Initial.LUA": not found
      281 Attempting to connect now
      281 Trying TCP/IP addr 192.168.0.10, port 8002 ...
      343 Connection made okay!
      343 New Client Application: "VAFS5" (Id=2928)
      531 Connection closed by server!
      531 Attempting to connect now
      546 Connection made okay!
   151134 New Client Application: "rcv4" (Id=1476)

   338865 ****** End of session performance summary ******
   338865 Total time connected = 338 seconds
   338865 Reception maximum:  30 frames/sec, 4550 bytes/sec
   338865 Reception average whilst connected:  25 frames/sec, 2916 bytes/sec
   338865 Transmission maximum:  10 frames/sec, 820 bytes/sec
   338865 Transmission average whilst connected:  0 frames/sec, 33 bytes/sec
   338865 Max receive buffer = 1741, Max send depth = 14, Send frames lost = 0

   338865 **************** Individual client application activity ****************
   338865 Client 2928 requests: 1011 (Ave 2/sec), Data: 1127735 bytes (3336/sec), Average 1115 bytes/Process
   338865 Client 1476 requests: 36819 (Ave 108/sec), Data: 2929752 bytes (8667/sec), Average 79 bytes/Process

   338865 ********* Log file closed (Buffers: MaxUsed 15, Alloc 49029 Freed 49029 Refused 0) *********

 

FSUIPC Server log >

********* FSUIPC4, Version 4.939n by Pete Dowson *********
Reading options from "D:\Flight Simulator X\Modules\FSUIPC4.ini"
Running inside FSX on Windows 7
Module base=69E70000
User Name="Kennedy Boardman II"
User Addr="deleted by forum mod"
FSUIPC4 Key is provided
WideFS7 Key is provided
      187 System time = 09/05/2015 22:57:47
      202 FLT UNC path = "\\KENS-PC\Flight Simulator X Files\"
      577 Trying to connect to SimConnect Acc/SP2 Oct07 ...
      592 FS UNC path = "\\KENS-PC\Flight Simulator X\"
      826 LogOptions=00000000 00000001
      826 --- CONTROLS timer memory location obtained ok
      826 --- SIM1 Frictions access gained
      826 --- FS Controls Table located ok
      826 --- Installed Mouse Macro hooks ok.
      826 --- Wind smoothing fix is fully installed
      826 --- G3D.DLL fix attempt installed ok
      826 SimConnect_Open succeeded: waiting to check version okay
      826 Trying to use SimConnect Acc/SP2 Oct07
     3432 Running in "Microsoft Flight Simulator X", Version: 10.0.61637.0 (SimConnect: 10.0.61259.0)
     3432 Initialising SimConnect data requests now
     3432 FSUIPC Menu entry added
     3478 \\KENS-PC\Flight Simulator X\FLIGHTS\OTHER\FLTSIM.FLT
     3478 \\KENS-PC\Flight Simulator X\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR
   200445 \\KENS-PC\Flight Simulator X\SimObjects\Airplanes\PMDG 777F\B777-200F.AIR
   290692 Weather Mode now = Theme
   348069 System time = 09/05/2015 23:03:35, Simulator time = 03:20:01 (13:20Z)
   348069 Aircraft="PMDG 777-FS2 FedEx Express (Panda Express)"
   353732 Starting everything now ...
   354871 Advanced Weather Interface Enabled
   355994 ASN active function link set
   355994 Ready for ASN WX radar
   534194 Sim stopped: average frame rate for last 185 secs = 26.7 fps
   607358 Sim stopped: average frame rate for last 66 secs = 28.2 fps
  1063895 FSUIPC Display Title set = "Radar Contact"
  8160349 Sim stopped: average frame rate for last 7537 secs = 27.0 fps
  8388704 Sim stopped: average frame rate for last 228 secs = 23.7 fps
  8392089 \\KENS-PC\FSX Config Files\Previous flight.FLT
  8409530 System time = 10/05/2015 01:18:07, Simulator time = 05:33:30 (15:33Z)
  8409530 *** FSUIPC log file being closed
Minimum frame rate was 12.8 fps, Maximum was 29.8 fps
Minimum available memory recorded was 1504Mb
Average frame rate for running time of 8022 secs = 26.9 fps
G3D fix: Passes 38866, Null pointers 0, Bad pointers 0, Separate instances 0
Memory managed: 6857 Allocs, 6857 Freed
********* FSUIPC Log file closed ***********

 

Best regards,

Ken
 

Link to comment
Share on other sites

Hi Pete,

  I completed two successful flights > KSFO-KDEN and MHTG-PHNL.  Then retried the PHNL-MHTG route and had the same problem as earlier.  I'm getting prepared to (re)start the problematic PHNL-MHTG route again, and this time with a new (different) flight plan.

The logs from tonight's failed flight are below.

 

Well, you omitted to show the WideServer log file, but I don't think it will show a problem either -- neither of the logs show anything wrong, if fact they show a perfect session.

 

However, the two logs you do show are for different times and days, 

 

Date (dmy): 10/05/15, Time 01:11:16.158: Client name is KENS_LAPTOP1

 

compared to

 

 187 System time = 09/05/2015 22:57:47

 

and in any case the FSX session continued for some 7100 seconds after RCV4 started, but you closed the Client after only 180 seconds or so!

 

You need to show logs relating to the same session, the one where you get the problem.

 

Are you seeing "waiting for connection" in the WideClient tite bar when you think you are losing connection?

 

Pete

Link to comment
Share on other sites

Hi Pete,

The Wide Client title bar always showed "Connected" even during the times when RCV4 and VAFS5 lost communication with FSX.  The degraded flights could be continued, but without RCV4.  I discovered

during the second degraded flight that by forcing Wide Client to close, and then restarting it that VAFS5 would pick up exactly where it needed to and nothing was lost and the flight continued to successful

completion (without RCV4). Seems perhaps my original flight plan file may have become faulty somehow.  It was a Great Circle route using numerous Lat / Lon waypoints.  The new route that I

created was much more on the Jetways with conventional fixes and just a few custom waypoints.  At this point I'm thinking I should apologize for bugging you with this.  It would be nice to know what

happened to cause the issue > perhaps FSX, RCV4, and or VAFS just choked on the original flight plan.  I had used the original FP successfully one time about a week earlier which is one thing

making me "scratch my head".     Some digital strangeness perhaps........

Today I successfully completed the PHNL-MHTG flight using the new flight plan (jetways routing / waypoints). 

Thank you for your help with this;  and for the awesome Flight Sim utilities which I have thoroughly enjoyed using for many years.

Best regards,

Ken

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.