Jump to content
The simFlight Network Forums

FSX CTD on Aircraft Change if FSUIPC Enabled

Recommended Posts

I recently upgraded from Win7 to Win10. FSX seems to run OK, but one problem I'm having is if I attempt to change a/c from within the sim using the aircraft drop down menu after loading a flight, I get a CTD every time. Through process of elimination over the past two weeks the problem seems to be related to FSUIPC 4.955C, or FSUIPC's interaction with FSX under Win10. If I disable FSUIPC in the FSX dll.xml file, the problem goes away; if I re-enable FSUIPC, the CTDs return. This happens even with every other dll.xml program entry disabled except dll.xml itself. I have tried reinstalling FSUIPC4 but that didn't help.

What is particularly strange is I have FSX-SE on the same machine and it does not exhibit this CTD problem. 

FSUIPC log file is below. After loading my default flight with a C172, I tried to switch aircraft to the default Baron 58 and the result was an immediate CTD.

Thanks for any ideas.


********* FSUIPC4, Version 4.955c (14th June 2016) by Pete Dowson *********
Windows version reported as 6.2.?.9200
fsx.exe version = 10.0.61472.0
Reading options from "C:\FSX\Modules\FSUIPC4.ini"
Running inside FSX on Windows 8.0 or later
Module base=66DA0000
User Name="Alan Klayton"
User Addr="arklayton@comcast.net"
FSUIPC4 Key is provided
WIDEFS7 not user registered, or expired
       47 System time = 17/08/2016 12:13:00
       47 FLT path = "C:\Users\Al\Documents\Flight Simulator X Files\"
       47 ------ Module Version Check ------
       47        acontain.dll: 10.0.61472.0
       47             api.dll: 10.0.61472.0
       47        controls.dll: 10.0.61472.0
       47      fs-traffic.dll: 10.0.61472.0
       47             G3D.dll: 10.0.61472.0
       63        language.dll: 10.0.61472.0
       63            sim1.dll: 10.0.61472.0
       63        visualfx.dll: 10.0.61472.0
       63         weather.dll: 10.0.61472.0
       63          window.dll: 10.0.61472.0
       63 ----------------------------------
       78 Trying to connect to SimConnect Acc/SP2 Oct07 ...
       94 FS path = "C:\FSX\"
      453 ---------------------- Joystick Device Scan -----------------------
      453 Product= Saitek Pro Flight Rudder Pedals
      453    Manufacturer= Saitek
      453    Vendor=06A3, Product=0763 (Version 1.1)
      453    Serial Number= Saitek
      453 Product= Saitek Pro Flight Yoke
      453    Manufacturer= Saitek
      453    Vendor=06A3, Product=0BAC (Version 3.4)
      453    Serial Number= Saitek
      453 -------------------------------------------------------------------
      719 LogOptions=A0000000 00000001
      719 -------------------------------------------------------------------
      719 ------ Setting the hooks and direct calls into the simulator ------
      719 --- CONTROLS timer memory location obtained ok
      719 --- SIM1 Frictions access gained
      719 --- FS Controls Table located ok
      719 --- Installed Mouse Macro hooks ok.
      719 --- Wind smoothing fix is fully installed
      719 --- G3D.DLL fix attempt installed ok
      719 --- All links checked okay
      719 -------------------------------------------------------------------
      719 SimConnect_Open succeeded: waiting to check version okay
      719 Trying to use SimConnect Acc/SP2 Oct07
     2047 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)
     2047 Initialising SimConnect data requests now
     2047 FSUIPC Menu entry added
     2078 c:\users\al\documents\flight simulator x files\Default Safe Flight C172 35L KCOS.FLT
     2078 C:\FSX\SimObjects\Airplanes\C172\Cessna172SP.AIR
     2516 Monitor IPC:024C (S32) = 3560696
     4500 *** EVENT: Cntrl= 66514 (0x000103d2), Param= 0 (0x00000000) ATC_MENU_CLOSE
    12656 Monitor IPC:024C (S32) = 3316512
    22547 Monitor IPC:024C (S32) = 3176272
    24438 System time = 17/08/2016 12:13:25, Simulator time = 12:13:03 (18:13Z)
    24703 Aircraft="Cessna Skyhawk 172SP EPAV"
    25422 Starting everything now ...
    26594 Advanced Weather Interface Enabled
    32531 Monitor IPC:024C (S32) = 3127844
    49531 Sim stopped: average frame rate for last 25 secs = 29.8 fps
    49531              Max AI traffic was 2 aircraft
    52719 Monitor IPC:024C (S32) = 3123900
    87469 C:\FSX\SimObjects\Airplanes\Beech_Baron_58\Beech_Baron_58.AIR
    94359 System time = 17/08/2016 12:14:34, Simulator time = 12:13:28 (18:13Z)
    94359 *** FSUIPC log file being closed
Minimum frame rate was 30.1 fps, Maximum was 30.9 fps
Minimum available memory recorded was 3055Mb
Average frame rate for running time of 25 secs = 29.8 fps
G3D fix: Passes 11205, Null pointers 0, Bad pointers 0, Separate instances 0
Maximum AI traffic for session was 3 aircraft
Memory managed: 25 Allocs, 25 Freed
********* FSUIPC Log file closed ***********



Link to comment
Share on other sites


I've been trying to figure out what has been causing the CTDs for about two weeks now and have noticed the faulting module varies, but the two most commonly reported faulting modules are:

KERNALBASE.dll,  path C:\WINDOWS\System32\
API.dll,  path C:\FSX\

and FSX.exe is located in C:\FSX.  FSUIPC seems to work fine as long as I don't try to reload an a/c.


Link to comment
Share on other sites

On 8/17/2016 at 8:06 PM, ark1320 said:

FSUIPC log file is below. After loading my default flight with a C172, I tried to switch aircraft to the default Baron 58 and the result was an immediate CTD.

The log is from a sessions which closed normally, not with a crash. A log from the crash might show that point reached in FSUIPC's actions, but one from a successful session is not useful I'm afraid.

On 8/18/2016 at 3:40 AM, ark1320 said:

FSUIPC seems to work fine as long as I don't try to reload an a/c.

Are you running somewthing which is possibly using FSUIPC to get something into or out of FS which might still be happening when the current aircraft is being unloaded?

What sort of CTD is it? The actual error code is significant.

Crashes in "Kernalbase.dll" are serious -- that's at driver level! FS's own API.dll can be related to aircraft loading.




Link to comment
Share on other sites


When I went to collect more log data much to my surprise I found the problem had gone away, at least for now! I can't explain it -- maybe there was some kind of Win10 update behind the scenes. Hopefully the problem won't come back, but this kind of magical fix leaves me a bit nervous.




Link to comment
Share on other sites

 In case it helps someone, it now seems the source of the CTDs was actually an out of date ASUS utility program, AI Suite II, that needed to be updated for Win10. AI Suite II runs at startup and provides access to the Bios and motherboard settings.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.