Jump to content
The simFlight Network Forums

Saitek X55 Throttle - unable to set axis

Recommended Posts

Hi Pete - 

Running P3D 3.3.5 under W10 Pro 1511 with version 4955g

I have ch yoke, ch throttle quadrant, ch rudders and Saitek x55 Rhino Stick & Throttle connected.

Fsuipc sees all connected devices and I can program all EXCEPT the x-55 Throttle. When I move the throttle or press a button - nothing happens in FSUIPC window. Any movement from other items including x55 stick gets readings displayed. The X55 is two units, each with it's own USB connector. I have tried moving the around to different USB ports with same result. Downloaded and installed latest (9/15) drivers from Saitek.

The x55 throttle is recognized within P3D and the axis can be calibrated.

Log attached - you'll see where I unplugged the throttle and put it in a different port - FSUIPC sees that - just apparently not getting a signal.

Any insights other than going back to W7?







Link to comment
Share on other sites

16 minutes ago, vgbaron said:

Fsuipc sees all connected devices and I can program all EXCEPT the x-55 Throttle.

Hmmm. Strange -- the INI file shows TWO X-55 sticks connected:

3=Saitek Pro Flight X-55 Rhino Stick
4=Saitek Pro Flight X-55 Rhino Stick

Both have unique GUIDs assigned by Windows. But neither 3 or 4 show anything in the axis or button assignments? You have them both assigned to different letters:

E=Saitek Pro Flight X-55 Rhino Stick
F=Saitek Pro Flight X-55 Rhino Stick

Could you try the JoyIDs program. Use it to check which number is truly assigned by Windows to that stick (the ONE stick?), if any, and either way then changing it to some other number (e.g. 6 or above, which are free it seems).  See the FAQ thread entitled  "Fixing joystick connections not seen by FSUIPC " for details.  Delete the above "stick" entries in the INI file first.

You do actually already have some button assignments to both the E stick and the F stick!

15=PF,2,C65570,0     -{GEAR_TOGGLE}-
16=PF,5,C65752,0     -{PARKING_BRAKES}-
17=PF,3,K83,8     -{Key press: S}-
18=PF,4,C65589,0     -{SPOILERS_TOGGLE}-
19=RF,12,C65758,0     -{FLAPS_INCR}-
20=RF,10,C65759,0     -{FLAPS_DECR}-
21=PF,13,K120,8     -{Key press: F9}-
22=PF,11,K123,8     -{Key press: F12}-
23=RF,9,C66278,0     -{RUDDER_TRIM_LEFT}-
24=RF,7,C66279,0     -{RUDDER_TRIM_RIGHT}-
25=RF,8,C65615,0     -{ELEV_TRIM_UP}-
26=PF,6,C65607,0     -{ELEV_TRIM_DN}-
27=PF,0,K65,8     -{Key press: A}-


28=PE,5,C65752,0     -{PARKING_BRAKES}-
29=PE,3,K83,8     -{Key press: S}-
30=PE,1,K112,11     -{Key press: ctl+shft+F1}-
31=PE,13,K120,8     -{Key press: F9}-
32=PE,11,K123,8     -{Key press: F12}-
33=RE,10,C65759,0     -{FLAPS_DECR}-
34=RE,12,C65758,0     -{FLAPS_INCR}-
35=RE,9,C66278,0     -{RUDDER_TRIM_LEFT}-
36=RE,7,C66279,0     -{RUDDER_TRIM_RIGHT}-
37=RE,8,C65615,0     -{ELEV_TRIM_UP}-
38=RE,6,C65607,0     -{ELEV_TRIM_DN}-
39=PE,4,C65589,0     -{SPOILERS_TOGGLE}-

Not sure how you did that if they aren't responding. I assume one set of those above is redundant, and should also be deleted. The renumbered stick should appear as device E if you delete the current allocations before reloading, so delete the PF and RF entries (which, oddly, were made before the E assignments, another strange thing!).

If you do really only have the one stick, then I can only think that somehow Windows has old spurious entries in the Registry (which is where FSUIPC finds this data), and one "real" entry, but the latter has no ID assigned -- a seemingly common problem with Win8 and later, but rare in Win7 and before. JoyIDs fixes the Registry entry giving the ID number.

Once you'd done all this, best change the "AutoAssignLetters=Yes" to "No" before next reloading in case the Stick wanders around again.



Link to comment
Share on other sites

Success. I played around with Joyid and moved both the stick and throttle down. I now have two of EACH listed but it works.  Just a wild guess, but using USBDeview, it shows dual entries for the stick and throttle - listed as HID and BULK, I'm guessing that is in the registry and fsuipc picks it up.


Let's see if the settings stick!

Thanx for the help Pete!




Link to comment
Share on other sites

6 hours ago, vgbaron said:

it shows dual entries for the stick and throttle - listed as HID and BULK, I'm guessing that is in the registry and fsuipc picks it up.

Ah, I see. Yes. The "BULK" one should probably be ignored (but gets listed incorrectly it seems). FSUIPC should only use the HID ("Human Interface Device") interface.

I'd like to modify FSUIPC to eliminate the "BULK" listing and auto-letter assignment, but I'm not sure where the difference lies in what I'm reading. Do you think you could show me the USBDeview output, and the joystick listings in your INI file now, telling me which is the one you actually see? (I don't have access to any devices which do this sort of thing).



Link to comment
Share on other sites

I've looked at this. It is very complex. The USB class number seems to be the only differentiator, and I can find no way of reading that except by referring to yet another part of the Registry, which is very obscurely somehow related to the stuff I'm reading. I was hoping I could read it from the USB interface itself -- it must be there someplace, but I'm blowed if I can find it.

Really, with class "0xff" ("vendor specific") I don't know why it is coming through when I'm only inquiring about HID devices only. Seems a bit of an oddity in Windows to me.

So, i'm going to leave it as it is for now. If I do come across anything more specific and easier to implement I'll look again.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.