Jump to content
The simFlight Network Forums
Pete Dowson

Fixing joystick connections not seen by FSUIPC

Recommended Posts

Sometimes the installation program for a joystick does not fill in all of the Registry entries, with one entry important for the way FSUIPC works omitted. This is the Windows joystick ID number, a value from 0 to 15.


 


This seems to be more prevalent on Windows 8 and 10, but wherever it occurs the following might help:


 


Download JoyIDs here http://airgroup51.ne...hp?topic=2435.0


Install the program then run it. You should see your connected joystick(s).


 


Double click on the problem one (should highlight green) and click on a different Id# to move it there. This will fix the entry in the Registry. You can move it back again if you wish. It won't affect anything else.


 


Pete


 


Share this post


Link to post
Share on other sites

Hello Pete,

 

I have a similar problem as the one described in this forum topic.

 

My saitek yoke is not recognized in FSUIPC4 on a networked PC running widefs.

 

Symptoms;

 

NO ID nr. or joystick ID appears in FSUIPC on networked pc running with updated WIDEFS.

 

I tried creating a Joystick ID nr- with the "Joyids" software as you suggested and my device appears as "SAITEK ID nr.#1" on this software table,  but it doesn't change anything. Still no joystick or axis control in FSUIPC4 on network PC.

 

I tried the same procedure connecting the Yoke to the Server PC running FS and yes it does registrer on FSUIPC when activating the yoke axis.

 

 

On the network PC I can program button functions in the "Buttons and keys" window but no axis control,

Moving the yoke produces no signal at all nor any ID.

 

I also reviewed my FSUIPC4 and WIDEFS versions and upgraded both as they weren't up to date and rebooted the system twice but

this did not solve the problem.

 

I am running out of options on my side.

Your expert advise is required.

 

Erik

 

Share this post


Link to post
Share on other sites

Hello,

 

I have the same problem with a SAITEK pro flight yoke installed on a networked PC running updated WIDEFS (registered).

I can asign buttons and keys on FSUIPC4 installed on server PC but no axis.

FSUIPC and WIDEFS are up to date. I had an older version but installed the latest version from Shiratti.com (version 4.954).

This did not solve the problem, nor did "Joyids" software. It did asign an ID nr. and "saw" the yoke but this did not help FSUIP in registering my yoke on the client PC.

 

I tried also to connect the yoke to the server and FSUIPC was able to register the yoke's ID and axis.

I hope this might help recognize the yoke on the client PC but no luck there.

As I am running out of ideas I think I need your help.

 

Erik

Share this post


Link to post
Share on other sites

Please always post support questions in the Support Forum.  You are lucky I saw these posts!

 

Axes are not read nor transmitted by WideFS, only buttons and switches. This is documented. If you want to send axes from a client PC you'd need to write a Lua plug-in to do it.

 

Pete

Share this post


Link to post
Share on other sites

Hi Pete,

 

Thanks for the quick reply-

I ignored that Widefs didn't control joystick axis inputs over a client PC. Must have missed that in the docs.  I expect that I got confused as many users use FSUIPC to overcome such glitches with their controls running directly on FS (server).

I learned something here.

 

Cheers!

 

Erik

Share this post


Link to post
Share on other sites

With a similar situation, I tried to download JoyID from the site above and it was blocked by Norton. Is there a problem with the program from this site?

Share this post


Link to post
Share on other sites

With a similar situation, I tried to download JoyID from the site above and it was blocked by Norton. Is there a problem with the program from this site?

 

No. It'll be a false positive I should think.

 

Withrecent versions of FSUIPC4 you shouldn't really need to use JoyIDs, as I've now built code into FSUIPC4 to do similar things, assign IDs where none can be found in the REgistry.

 

Pete

Share this post


Link to post
Share on other sites
Hello Pete,

I’m building a cockpit B737 www.ph-nic.eu

With:

Fs 2004

FSUIPC             

Interface: Leobodnar BU0836

I have some problems with my axis assignments.

5 analogue axis are placed on the following positions.

X-axis                  Aileron                no problem      

Y-axis                  Elevator             no problem

Z -axis                 Flaps                   no problem      

U-axis                  Throttle 1          no problem

R-axis                  Throttle 2          no problem

V-axis                 Spoiler               big problem!

 

I have tried to connect the spoiler but it gives no response.

On the interface I have 8 analogue connections.

Three of them do not  reacted.

 

How can I make connection so I see them in de FSUIPC window? 

 

With kind regards,

Nico Weesjes

 

 

 

Share this post


Link to post
Share on other sites

It would really be better to post support questions to the Support Forum. They'd be seen earlier, usually.

 

FSUIPC3 sees any axis which can be read using the original Windows joystick API.  There are only 6 of these -- X Y Z R U V.  It sounds like what you think of  as "V" is actually one of those only supported by DirectInput, which is used in FSUIPC4.

 

FSUIPC4, using DirectInput instead, supports 12 axes: X Y Z R U V, plus sliders S  T,  and POVs P Q M and N.  Maybe the Bodnar board puts yuor missing 3 onto one of these latter ones. See if any of the three are recognised in the Buttons & Switches tab -- FSUIPC3 did support two POVs as sets o 8 switches.

 

Pete

Share this post


Link to post
Share on other sites

Can I use FSUIPC4 in FS2004? Or only FSUIPC3?

 

FSUIPC4 is only for FSX and P3D. FSUIPC3 is for FS98, CFS1, CFS2, FS2000, FS2002 and FS2004. They are totally different internally.

 

Pete

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.