Jump to content
The simFlight Network Forums

Joystick failure moving from 4.957 to 4.966

Recommended Posts


Thankyou for such a great Interface! I hope you're having a great Easter.

My PC background: ASUS Z170 Pro Gaming Motherboard, Intel i7-6700k, Corsair 32g Ram, EVGA GTX 1060, SSD & HDD, Windows 10 Home and FSX SE.

In summary, I upgraded from FSUIPC v4.957 to v4.966 last night. Since doing so, FSUIPC v4.966 fails to recognise 2 joysticks of the same make and model as the 2 that are recognised and functioning.

My FS PC has a total of 7 USB joysticks, all plugged in to the back and front of the PC and 2 via a USB HUB: 2x Logitech Attack 3. 2x Logitech Attack Extreme 3D Pro, 1x CH Rudder, 1x Saitek Yoke (plus peripheral throttle) & 1x Saitek USB Throttle Quad'.

The problem: I can only get FSUIPC 4.966 to recognise 1 Logitech Attack 3 and 1 Logitech Attack Extreme 3D. Having all 4 Logitech's plugged in, operate normally as per Windows. All 4 are seperately recognised, all can be individually calibrated in Windows. For whatever reason, FSUIPC 4.966 can only see one of each make and model [Logitech only]. To define the word "See", I mean that 2 do not function at all inside FSUIPC - i.e button presses or axis scans are not showing up/registering in the FSUIPC GUI.

During testing, I have reformatted & reinstalled Windows and FSX (Clean). The BIOS was reset and reflashed. This was my initial action as I thought there was some sort of conflict. Upon further testing, I retained an old copy of FSUIPC.dll (version 4.957) from an FSX folder backup. In the functioning FSX 'modules' folder, I renamed the newly installed FSUIPC.DLL (version 4.966) to 'FSUIPC.DLL.off', put the retained v4.957 FSUIPC.DLL into the 'Modules' folder, launched FSX - VOILA! FSUIPC now recognises all 4 joysticks. To further test, I did the reverse - renamed the working FSUIPC.DLL [4.957], renamed 'FSUIPC.DLL.off' [4.966] to FSUIPC.DLL, relaunched FSX. Sure enough, back to only recognising 1 Logitech Attack 3 and 1 Logitech Attack Extreme 3D. The other several joysticks all appear to be functioning normal in FSUIPC. Deleting FSUIPC.ini and letting FSUIPC build another makes no difference. I also tried the version on Eric's website - same result. I have also tried JoyIDs - but has not positive effect.

So, my question is - what changed between 4.957 and 4.966. Is there an option I'm missing in the INI to ensure that the 4 joysticks can all be recognised and operate as they do in 4.957? Or am I banished to stay forever in version 4.957?

Not sure if the below is of any help - it's an excerpt from a new/fresh INI created by 4.966 showing the joysticks. FSUIPC knows that the 4 joysticks are there, but only 2 of them are functional/working. In the below list, 0 and 3 are the only ones working/recognised in FSUIPC GUI. 1 and 8 don't respond at all in FSUIPC - as if they're not even plugged in to the USB.

0=Logitech Extreme 3D
1=Logitech Attack 3
3=Logitech Extreme 3D
8=Logitech Attack 3


Again, everything functions as normal in 4.957. The INI built by 4.957 is the same as 4.966.




PS: pls tell me I'm silly and it's a very cool new feature in 4.966 that I've missed!

Link to comment
Share on other sites

4 hours ago, McLellyn said:

So, my question is - what changed between 4.957 and 4.966

A lot! There were more than 9 major releases and uncounted interim ones. If you want a complete history refer to the History document in your FSUIPC Documents folder along with the more recent changes listed in the Changes document in the download zips.

As Thomas says, we need to see the INI and LOG files.  It would also help me to double check what FSUIPC is doing if I could see the Registry entries for your devices. (I'm a bit worried about setups with two devices of the same type and I'd like to improve this if I can). To do this:

Run Regedit (from the place Win10 allows you to type in program names to look for them). You will see it comes up with an Explorer type Window. Navigate right down to


then, in the File Menu select Export ... and choose a place to save the data -- save it as a Txt file, NOT a Reg or you won't be able to upload it here.

then, before leaving Regedit, do the same (but with a different name of course) with


(Don't worry if you can't find one of the above. As long as one of them is there. But there are both normally).

Then please show me both files.



Link to comment
Share on other sites

Further to my last reply, to help me work out what is wrong could you please add these lines to the [General] section of the FSUIPC4.INI file:


then run the Sim (only till ready to fly, then close) and show me the FSUIPC4.LOG.

You can remove those two lines afterwards.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.