Jump to content
The simFlight Network Forums

Mixture axis cannot be calibrated to go below 0


elmond
 Share

Recommended Posts

FSUIPC 5.121a

I am somewhat at a loss here

mixture.png.d60416b54b628b49899f65177a47a243.png

When I do not calibrate my mixture axis I can have the full range, so the mixture will go from 0 to 100 % in the sim (see mixture 2). As soon as I calibrate the mixture control (Mixture 1) I get an out of 0 if i move my mixture all the way back (in -16383). This results in the sim for the mixture to only go from 50% to 100%, so no leaning below 50. I need to calibrate though in order to use the reverse feature as otherwise my controls are physically the wrong way around. Any help is greatly appreciated, I am not able to figure this out by myself.

 

elmond

Link to comment
Share on other sites

8 hours ago, elmond said:

When I do not calibrate my mixture axis I can have the full range, so the mixture will go from 0 to 100 % in the sim (see mixture 2). As soon as I calibrate the mixture control (Mixture 1) I get an out of 0 if i move my mixture all the way back (in -16383). This results in the sim for the mixture to only go from 50% to 100%, so no leaning below 50. I need to calibrate though in order to use the reverse feature as otherwise my controls are physically the wrong way around. Any help is greatly appreciated, I am not able to figure this out by myself.

Remove the "No reverse zone" selection!

With that selected the whole range of your axis is calibrated to a 0 to +16383 range.  That is needed for all sorts of axes, including those mixture controls which don't have an are below "cutoff". For a range of -16383 to + 16383 you are using the reverse xone which for some reason you have specifically selected!

Pete

 

Link to comment
Share on other sites

@Thomas Richter 

/1 yes

/2 https://pastebin.com/ThrcZ0YN

/3 I'd am sorry but you come across really condescending to me. It felt the same way in my rebuy post, with all the red markings and such and now EXCLAMATION MARK, you NEED TO SHOW. Might be just me, but I'd really appreciate it if this were not the case. Otherwise I'd like to ask you to not answer to my posts anymore.

@Pete Dowson

Sadly this does not fix it for me. This was just from testing. The behaviour was there before. I have deleted my old FSUIPC5.ini and created a full new one for 5.121a as I had problems with the specific axis assignments under 5.11 or something. Only thing I added was the things to load. Apart from that I have not tinkered with the config

See the below picture. I reset both axis. Then I tried to calibrate Mixture 1 to its minimum to no effect. After I press reset and then set I get the result, shown as in Mixture 2. For some odd reason I get 0 set as the default low. Standard p3dv4 flight.

image.png.331684fe72174e142b91327cf094c069.png

I cannot remember changing anything else on the system, hence I am so puzzled about it. It worked in V3 flawlessly. Thank you for looking into it.

Edited by elmond
Typos and rephrasing
Link to comment
Share on other sites

Moin Moin,

>>> /3 I'd am sorry but you come across really condescending to me. It felt the same way in my rebuy post, with all the red markings and such and now EXCLAMATION MARK, you NEED TO SHOW. Might be just me, but I'd really appreciate it if this were not the case. Otherwise I'd like to ask you to not answer to my posts anymore. <<<

Viel Spass dann mal.

Thomas

Link to comment
Share on other sites

6 hours ago, elmond said:

I'd am sorry but you come across really condescending to me. It felt the same way in my rebuy post, with all the red markings and such and now EXCLAMATION MARK, you NEED TO SHOW. Might be just me, but I'd really appreciate it if this were not the case. Otherwise I'd like to ask you to not answer to my posts anymore.

I don't see anything "condescending" in Thomas's pos! Is it just one explamation mark which upsets you? In that case many of my posts will be more upsetting to you. And "you need to show" was NOT capiralised, as you have done (=SHOUTING!), and is quite true. In any problem report you do need to show things like the INI and LOG files, as these contain things relevant to you being assisted.

Thomas helps fill in for me, especially when I am away, and it is completely voluntary. He has a full time job too, and spends his own time helping. It's a shame you don't appreciate this.

6 hours ago, elmond said:

Sadly this does not fix it for me. This was just from testing. The behaviour was there before. I have deleted my old FSUIPC5.ini and created a full new one for 5.121a as I had problems with the specific axis assignments under 5.11 or something. Only thing I added was the things to load. Apart from that I have not tinkered with the config

Normally, for nearly all aircraft, the actual mixture axis value inside the Sim -- the value being written by FSUIPC -- does go from 0% (zero fuel or full lean)) to 100% (full rich). Internally these values are represented by 0 and 16383 respectively.  A negative mixture value does not mean "reverse" -- there's no sucking fuel back out! ;-)

Looking at the INI file you posted (still no LOG?), you seem to have assigned Mixtures 1 and 2, direct to calibration, yet only calibrated Mixture 1, not 2. For the only profile you have, "Comanche", you have Mixture 1 assigned, but with no calibration at all.

So, it is now time to ask what add-on aircraft you are using, because maybe it is a property of the aircraft?

 One other thing:

6 hours ago, elmond said:

It worked in V3 flawlessly.

P3Dv3?

Why didn't you simply copy over your existing INI file? There's no difference in FSUIPC5 from FSUIPC4 in this area. If it was okay in P3Dv3 it will be okay in P3Dv4, assuming it isn't a bug in P3D or the aircraft.

Pete

 

Link to comment
Share on other sites

Something else just occurred to me.

There is a problem, especially with Saitek devices, where a registry error causes 50% of the axis movement to be missed. Viewing the "IN" values in the Axis Assignments tab, Instead of going from -16383 smoothly to +16383, it starts at -16383 but with a verysmall movement, jumps directly to 0. Then smoothly to +16383.

There is a fix in the Registry for the (see FAQ subforum thread
Fixing problems with 50% (or digital on/off) action with Saitek levers
but you can also get around it by calibration: just find the zero spot, just above the one place giving -16383, and calibrate that as you minimum input instead.

I've just tried this and it works fine (I used the default King Air).

Pete

 

Link to comment
Share on other sites

31 minutes ago, Pete Dowson said:

I don't see anything "condescending" in Thomas's pos! Is it just one explamation mark which upsets you? In that case many of my posts will be more upsetting to you. And "you need to show" was NOT capiralised, as you have done (=SHOUTING!), and is quite true. In any problem report you do need to show things like the INI and LOG files, as these contain things relevant to you being assisted.

Yeah I am sorry about that then Thomas, Ijust tried to say how I felt on my end and ought have used other words. :( Shouting was also not my intent.

Quote

Thomas helps fill in for me, especially when I am away, and it is completely voluntary. He has a full time job too, and spends his own time helping. It's a shmae you don't appreciate this.

Normally, for nearly all aircraft, the actual mixture axis value inside the Sim -- the value being written by FSUIPC -- does go from 0% (zero fuel or full lean)) to 100% (full rich). Internally these values are represented by 0 and 16383 respectively.  A negative mixture value does not mean "reverse" -- there's no sucking fuel back out! ;-)

Yeah it seems like the problem lies with the A2A aircraft I use. As soon as I have the axis calibrated the Comanche exhibits the behavior that the mixture can only be moved to 50%. The problem must be in the handling of the axis by for example the Comanche then. I was mistaken when I thought this happened with other planes as well.

Quote

Looking at the INI file you posted (still no LOG?), you seem to have assigned Mixtures 1 and 2, direct to calibration, yet only calibrated Mixture 1, not 2. For the only profile you have, "Comanche", you have Mixture 1 assigned, but with no calibration at all.

So, it is now time to ask what add-on aircraft you are using, because maybe it is a property of the aircraft?

I did the different mixture calibrations just for demonstration purposes. It made it easier for me to test the values having one axis setup one way and one the other. The Comanche has the second axis not setup as it is a single engine plane and I thought I may use it for something else.

Here is an accompanying log https://pastebin.com/Euf0Sjis

Quote

 One other thing:

P3Dv3?

Why didn't you simply copy over your existing INI file? There's no difference in FSUIPC5 from FSUIPC4 in this area. If it was okay in P3Dv3 it will be okay in P3Dv4, assuming it isn't a bug in P3D or the aircraft.

I had my old config copied over but as I said, I had problems with one of the former FSUIPC 5 versions regarding the saving of profiles.

Problem persisted mainly between keyboard and chair here me thinks. I did not check correctly with default aircraft. Thank you for looking into it.

 

elmond

Link to comment
Share on other sites

30 minutes ago, elmond said:

Yeah it seems like the problem lies with the A2A aircraft I use. As soon as I have the axis calibrated the Comanche exhibits the behavior that the mixture can only be moved to 50%.

It sounds like it is reading the axis imput and not directly affected by the actual value that it  creates internally. Some add-on aircraft are like that. For those you probably need to simply assign to the FS control (not "direct to calibration") and not calibrate.

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.