Jump to content
The simFlight Network Forums
ipa

FSUIPC stop working FSX

Recommended Posts

Hi:

 

I know there is a lot of posts here about this issue but I have not found any answer I can use. Then, sorry if doubling any post.

Today FSUIPC decided to stop working properly. I noticed that when trying to use ChasePlane.  The camera doesn't move. After many searching, I found that FSUIPC is not loaded on the add-on menu bar. I reinstall it and delete the ini. file. The event is that chase plane load and works only 2 seconds. after that it's dead. 

I have: latest FSUIPC on W7  

 

Attached is the log files plus the ini . Any help will be highly appreciated

 

IPA

 

 

FSUIPC4.log

FSUIPC4.ini

FSUIPC4_prev.log

Share this post


Link to post
Share on other sites
1 hour ago, ipa said:

know there is a lot of posts here about this issue

Is there? Where? There's absolutely no others about Chaseplane crashing.  I think you posted inthe wrong place by mistake?

1 hour ago, ipa said:

Today FSUIPC decided to stop working properly. I noticed that when trying to use ChasePlane.  The camera doesn't move

I'm fairly sure that ChasePlane doesn't use FSUIPC.

1 hour ago, ipa said:

I found that FSUIPC is not loaded on the add-on menu bar. I reinstall it and delete the ini. file.

If FSUIPC isn't loading then your previous session of FSX crashed and Windows has marked it not to load. you need to fix the reason for the crash.

And why delete the INI file?  That removes all of your settings. If you don't use FSUIPC why is it installed?

1 hour ago, ipa said:

The event is that chase plane load and works only 2 seconds. after that it's dead. 

That's most definitely nothing to do with FSUIPC. sorry. Go to ChasePlane support.

1 hour ago, ipa said:

Attached is the log files plus the ini

The INI file merely shows that you aren't using FSUIPC for anything.  The Logs show nothing except a good FSUIPC session lasting only 3 minutes and one minute before you closed the session.

You really are in the wrong place! Sorry.

Pete

 

Share this post


Link to post
Share on other sites

Hi:

 

First, thank you for your reply. 

Sr. if Chase Plane indeed does not use FSUIPC, why the FSUIPC module is not loaded in FSX? Then, forget what I said about Chase PLane, maybe is it an unrelated issue but then, what happens with FSUIPC not showing in add-on menu? I don't know how to read the log file. I am not an expert in this matters. BTW, I already ask in ChasePlane forum. 

Best

 

IPA

Share this post


Link to post
Share on other sites
4 hours ago, ipa said:

why the FSUIPC module is not loaded in FSX?

Because, as I said:

4 hours ago, Pete Dowson said:

If FSUIPC isn't loading then your previous session of FSX crashed and Windows has marked it not to load. you need to fix the reason for the crash.

So, you need to find out why your FSx is not terminating properly. It might appear to when you end a session, but it FSUIPC is not loading the next time without a re-install, that is a clear indication that the previous session actually terminated inproperly. Check the Windows Event viewer to see what crashes it has recorded in it Application Logs.

4 hours ago, ipa said:

I don't know how to read the log file. I am not an expert in this matters.

There's no need to read any log file! Who asked you to?

Pete

 

Share this post


Link to post
Share on other sites

Mr. Dawson:

Sorry to bother you and being annoying around here but I still have the problem with the FSUIPC Module not showing in add-on menu. Today I deleted (uninstalled) all add=ons from FSX. I also uninstalled FSUIPC. The result is everything worked ok. At the exit, there was not any crash. After re-installing FSUIPC the problem shows up again plus a CTD . 1. No Module load 2. ChasePlane camera not working 3. CTD  I am tired of uninstalling and reinstalling the FSUIPC4 . I am sure is something wrong with my system or installation but how do I get help on this issue? How do I clean the registry for a fresh FSUIPC installation? Is it the latest something to take into account?

 

Thank you

 

IPA

Edited by ipa

Share this post


Link to post
Share on other sites
51 minutes ago, ipa said:

Sorry to bother you and being annoying around here but I still have the problem with the FSUIPC Module not showing in add-on menu. Today I deleted (uninstalled) all add=ons from FSX. I also uninstalled FSUIPC. The result is everything worked ok. At the exit, there was not any crash.

Seems likely with no add-ons at all!

52 minutes ago, ipa said:

After re-installing FSUIPC the problem shows up again plus a CTD

Any details, Windows crash information. Check the Event viewer. I can't help without iformation. The FSUIPC log from that would also be useful.

53 minutes ago, ipa said:

1. No Module load 2. ChasePlane camera not working 3. CTD 

So the CTD occurred WITHOUT FSUIPC loading? If so it  obviously isn't FSUIPC causing the CTD.

It sounds more like a ChasePlane problem. Have you tested without it?

55 minutes ago, ipa said:

How do I clean the registry for a fresh FSUIPC installation?

FSUIPC doesn't change the Registry. There is nothing there to "clean" for FSUIPC.

If FSUIPC only runs after being freshly installed then the Sim is absolutely certainly crashing on exit. You won't necessarily see that it crashe! You MUST look at the Windows Event Viewer which should record these things, along with needed details!

Pete

 

Share this post


Link to post
Share on other sites

The Log file is this:

 

********* FSUIPC4, Version 4.974 (24th February 2018) by Pete Dowson *********
Windows 7 Professional 64 Bit with SP 1.0 reported as Build 7601 (OS 6.1)
fsx.exe version = 10.0.61472.0
Running inside FSX on Windows 7
Module base=5B980000
User Name=""
User Addr=""
FSUIPC4 not user registered
WIDEFS7 not user registered, or expired
        0 System time = 31/05/2018 12:48:58
        0 FLT path = "G:\My Docs from C\Archivos de Flight Simulator X\"
        0 ------ Module Version Check ------
        0        acontain.dll: 10.0.61472.0
        0             api.dll: 10.0.61472.0
        0        controls.dll: 10.0.61472.0
        0      fs-traffic.dll: 10.0.61472.0
       15             G3D.dll: 10.0.61472.0
       15        language.dll: 10.0.61472.0
       15            sim1.dll: 10.0.61472.0
       15        visualfx.dll: 10.0.61472.0
       15         weather.dll: 10.0.61472.0
       15          window.dll: 10.0.61472.0
       15 ----------------------------------
       31 Trying to connect to SimConnect Acc/SP2 Oct07 ...
       31 FS path = "E:\FSX\"
       31 LogOptions=00000000 00000001
       31 -------------------------------------------------------------------
       31 ------ Setting the hooks and direct calls into the simulator ------
       31 --- CONTROLS timer memory location obtained ok
       31 --- SIM1 Frictions access gained
       31 --- FS Controls Table located ok
       31 --- Installed Mouse Macro hooks ok.
       31 --- Wind smoothing fix is fully installed
       31 --- G3D.DLL fix attempt installed ok
       31 --- SimConnect intercept for texts and menus option is off
       31 --- All links checked okay
       31 -------------------------------------------------------------------
       31 SimConnect_Open succeeded: waiting to check version okay
       31 Trying to use SimConnect Acc/SP2 Oct07
       31 Opened separate AI Traffic client okay
     9017 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)
     9017 Initialising SimConnect data requests now
     9017 FSUIPC Menu entry added
     9032 G:\My Docs from C\Archivos de Flight Simulator X\Default.FLT
     9032 E:\FSX\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR
    66222 User Aircraft ID 1 supplied, now being used
    66222 Aircraft loaded: running normally now ...
   147904 System time = 31/05/2018 12:51:26, Simulator time = 12:49:06 (19:49Z)
   150151 Starting everything now ...
   150198 ASN active function link set
   150260 Ready for ActiveSky WX radar with additional data
 

Share this post


Link to post
Share on other sites
4 hours ago, ipa said:

Here you have what the event viewer says: 1=Error. 2= Warning. 

Error.txt

Warning.txt

I don't know what those are. you need to look at the entries in the Windows Logs- Application list which have the red error emblem and indicate FSX.EXE as the process.

5 hours ago, ipa said:

The Log file is this:

So, does the Log always finish there? And soon after loading and just when ready to fly? Or is FSX carrying on longer than two and a half minutes.

If it crashes there it almost always indicates that you have a corrupt weather file. Delete your wxstationlist.bin file (in your AppData\Roaming folder for Microsoft Flight Simulator), and the .wx files in your Flight Simulator X Files folder in Documents.

Of course, FSX crashing there has no relation at all the FSUIPC missing in the AddOns menu, nor to ChasePlane not working. So perhaps you need to elaborate?

Pete

 

 

Share this post


Link to post
Share on other sites

Please note I will be off-line till monday (no, not on holiday. Just a weekend with my brother!).

Pete

 

 

Share this post


Link to post
Share on other sites

Hello Pete!

 Thank you very much for your help and support to my questions!

At present, I am using FSX DVD for Windows XP and your FSUIPC 4.

We want to use our simulator through FSUIPC to interface FSX or

Prepar3D  and FSX or Prepar3D are  just as  the Visual Scenery.

Questions: What versions FSX or Prepar3D, can we write our

simulator Latitude, Longitude, Altitude, Pitch, Bank, Heading values

through FSUIPC to pass these Latitude, Longitude, Altitude, Pitch, Bank,

Heading as Viewpoints Values to FSX or Prepar3D?  

   THANKS!

 

Share this post


Link to post
Share on other sites
29 minutes ago, yindengxie said:

Questions: What versions FSX or Prepar3D, can we write our simulator Latitude, Longitude, Altitude, Pitch, Bank, Heading values through FSUIPC to pass these Latitude, Longitude, Altitude, Pitch, Bank, Heading as Viewpoints Values to FSX or Prepar3D?

What has this question got to t owith this thread? it's about FSUIPC stopping FSX working!

I think you've dne this before! can you please STOP adding to other threads and, if you have your pwn, different, question, create a thread for it. Please?

Pete

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.