Jump to content
The simFlight Network Forums

set the ACL entries for Modules access permissions failed, error = 1332

Recommended Posts

Dear Peter

After having read so many positive comments I could not resist to try it out (basically for me to operate separate commands for gear up and gear down).

FSUIPC 5 was already installed on my PC probably when I installed an add on some months ago. But not registered.  
At that time an ini file was produced. Attached later on.
I have de- installed that version by renaming the folder.  

I run Prepar3d version (Simconnectversion 4-2.0.0)
on a Windows PC with Intel® core ™i7-6700 CPU@ Ghz 3.40Ghz 3.41Ghz   16.0 GB RAM .
It runs under Windows 10: 64 Bit,  x64 based processor .

I use the Thrustmaster Hotas Whartog as controls.

The following add ons are listed under options

  1. Orbx Object flow

  2. A2A

  3. EDDK Cologne Bonn airport.   


Since two day I am registered as well to have access to all options. I have re installed the Module folder but it now has no ini folder (?) The menu on Prepar3d confirms that everything is there. And the pdf documents are all there under Module, but not the ini file. .

I have initially programmed some buttons and that works fine (have confirmed with ok) . If I select another aircraft the assigned functions do not work.

Once I leave Prepar3d settings are gone. 

Neither am I able to select profiles.

I have checked the original FSUIPC 5 ini file (in a renamed Folder) but the “UseProfiles=Yes” entry to set profiles is not there.

Enclosed find the last installation log and the original ini file

In the log file these lines may explain the problem: “  Looking in "C:\Users\Public\AppData\Roaming"
 ... No Prepar3D.CFG there
Attempt to set the ACL entries for Modules access permissions failed, error = 1332

I checked and I found the prepar3D.cfg file here: “C:\Users\Onnor\AppData\Roaming\Lockheed Martin\Prepar3D v4”

As a beginner I might have messed up things. I would be very happy if you find the time to give some  guidance.


Onno Reitsma


  1.  Initial ini file:



























FSVersionUsed="Lockheed Martin® Prepar3D® v4",









2)  Last log file:

Installer for FSUIPC5.DLL version 5.151


Looking in registry for Prepar3D v4 install path:

     HKEY_CURRENT_USER\SOFTWARE\Lockheed Martin\Prepar3D v4


... >>>  OK! FOUND Prepar3D v4!  <<< ...

     AppPath=C:\Program Files\Lockheed Martin\Prepar3D v4\




AppPath="C:\Program Files\Lockheed Martin\Prepar3D v4\"

Checking version of the Prepar3D v4 EXE:

... Version  (Need at least

Checking if there's already a version of FSUIPC5 installed as:

       C:\Program Files\Lockheed Martin\Prepar3D v4\Modules\FSUIPC5.DLL

... No previous valid version found.

Prepar3D v4 Modules folder created okay!

Okay -- installed FSUIPC5 into "C:\Program Files\Lockheed Martin\Prepar3D v4\Modules\FSUIPC5.DLL"

Looking for the current user's Application Data path:

... found as "C:\Users\Onnor\AppData\Roaming"

Now finding \Lockheed Martin\Prepar3D v4\Prepar3D.CFG for all users, including this one

Looking in "C:\Users\All Users\AppData\Roaming"

 ... No Prepar3D.CFG there

Looking in "C:\Users\Default\AppData\Roaming"

 ... No Prepar3D.CFG there

Looking in "C:\Users\Default User\AppData\Roaming"

 ... No Prepar3D.CFG there

Looking in "C:\Users\Onnor\AppData\Roaming"

Found Prepar3D.CFG in "C:\Users\Onnor\AppData\Roaming\Lockheed Martin\Prepar3D v4\Prepar3D.CFG"

Now checking DLL.XML ...

... There is a previous DLL.XML, checking for FSUIPC5 section.

... FSUIPC5 section already exists but will be replaced.

... FSUIPC5 section of DLL.XML written okay

Now checking for a SimConnect.XML file ...

... No SimConnect.XML file found. This is okay.

Looking in "C:\Users\Public\AppData\Roaming"

 ... No Prepar3D.CFG there

Attempt to set the ACL entries for Modules access permissions failed, error = 1332

"Modules\FSUIPC Documents" folder created okay!

   Removed "FSUIPC4 Offsets Status.pdf" okay

Now installing additional files into the "Modules\FSUIPC Documents" folder:

   Installed "FSUIPC5 User Guide.pdf" okay

   Installed "FSUIPC5 for Advanced Users.pdf" okay

   Installed "The 2016 List of FSX and P3D Controls.pdf" okay

   Installed "FSUIPC Lua Library.pdf" okay

   Installed "FSUIPC Lua Plug-Ins.pdf" okay

   Installed "Lua License.pdf" okay

   Installed "LuaFileSystem.pdf" okay

   Installed "Example LUA plugins.zip" okay

   Installed "FSUIPC5 Offsets Status.pdf" okay

   Installed "Profiles in Separate Files.pdf" okay

   Installed "FSUIPC5 History.pdf" okay

   Installed "Lua Plugins for VRInsight Devices.pdf" okay

   Installed "ASN WX Radar facilities in FSUIPC4.pdf" okay

   Installed "Offset Mapping for PMDG 737NGX.pdf" okay

   Installed "Offset Mapping for PMDG 777X.pdf" okay

   Installed "Offset Mapping for PMDG 747QOTSII.pdf" okay



All installer tasks completed.

Registration dialog exit: selected  FSUIPC REGISTER

Providing FSUIPC registration dialogue ...

Registration for FSUIPC5 was successful! (result code 00)


*************** End of Install Log ***************




Link to comment
Share on other sites

Hi Onno,

first, you are using an old unsupported version of FSUIPC5 - can you update to the latest supported version, 5.151.

If you still get error 1332, you can manually edit the Modules folder permissions yourself to allow full access, by right clicking on the folder properties:  select Security-->Edit-> Add, enter Everyone as the object name, then 'Check Names' and 'OK'. Then give 'Full Control' to the 'Everyone' group just added.

Alternatively, as your P3D installation is under the 'Program Files' folder (which is why you are having this issue), you could run P3D as administrator, which would then allow FSUIPC to write to the modules folder.



Link to comment
Share on other sites

Many thanks John for the very speedy advice !

I tried it out and yes it now works !

Strangely enough for me I still read the same error message in the log file, but as all seems now to work properly I will not ask for further explanations: this forum is not a sw course !!  

kind regards





Link to comment
Share on other sites

36 minutes ago, Onno Reitsma said:

Strangely enough for me I still read the same error message in the log file, but as all seems now to work properly I will not ask for further explanations:

That's ok, but I'll try to give it to you snyway.

I think the error is when the Installer tries to change the permissions and finds it can't do it. We never worked out why, because we are following what appear to be the rules -- and it always worked fine on Win 7.

Following John's suggestion you changed the rules manually, so it then worked, but the program still tries to change them (it doesn't check to see if they need changing first.

John is planning to avoid such problems by using different install methods, but that won't be soon.

Too late now, but it is best, really, to avoid installing P3D in Program Files, even though it defaults to that location. Sometimes other third-party addons have difficulties too. This is the reason many say you have to run them with administrative privileges. That shouldn't really ever be necessary. Only Installers should need that.



Link to comment
Share on other sites

What a wonderful service, you are providing.

I read what you are writing and can somewhat-ish follow the logic!

Am now completely assured that my set up is ok!  

The next time I need to re-install Prepare3d, I will do what you advice!.

Many Thanks

Onno Reitsma

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.