Jump to content
The simFlight Network Forums
Ganradlogin

Intalled FSUIPC now FSX-SE sticks on splash screen

Recommended Posts

It could be a corrupt weather file - could you first try adding the following to the [General] section of your FSUIPC4.ini file and try again:
      NoWeatherAtAll=Yes

If that solves it, it will be a corrupt .WX file in your Flight simulator Documents folder, or more usually the wxstationlist.bin file in the same folder as your FS-SE settings (the AppData folder). deleting both would help in that case. The reason is that FSUIPC reads weather through Simconnect and a corrupt file causes crashes and other errors.

If that doesn't work, could you also post your DLL.XML file (located under C:\Users\Colin\AppData\Roaming\Microsoft\FSX\) so we can see what else is running.

Thanks,

John

Share this post


Link to post
Share on other sites

Prior to your reply I removed all traces of FSUIPC4. Game not fixed. Within Steam I verified integrity of game files which were OK. Reinstalled FSX_SE. Still not fixed. Cleaned registry. Still not fixed so gave up, waiting your reply.

Re-ran FSUIPC4 installer (with admin rights). Appeared to run OK, but after searching for FSUIPC4.ini on C drive, it COULD NOT BE FOUND.

Tried launching FSX. OK'ed security warning about FSUIPC4.dll. Back to stuck splash screen and 55% CPU usage.

Note I've used FSX for over 250 hrs with no problems. The first install of FSUIPC4 without validation worked, and FSUIPC was visible in the FSX pull-down menu. It was only after the second install of FSUIPC4 with validation that the problem occurred. 

PS. During the first working install I went to FSX Settings-Controls and unchecked 'Enable Controller(s)'. could that have caused a problem?

 

DLL.XML

Share this post


Link to post
Share on other sites

First, the FSUIPC4.ini has now turned up. I'm positive it wasn't in the Modules folder when I looked and a full search of the C drive didn't find it. It now does.

I've tried John's advice to disable weather. No fix. I've now renamed FSUIPC4.ini to $FSUIPC4.ini. Again no fix.

 

2 hours ago, Ganradlogin said:

PS. During the first working install I went to FSX Settings-Controls and unchecked 'Enable Controller(s)'. could that have caused a problem?

Is there a way of enabling controllers again without opening FSX?

 

PS I now see that a new FSUIPC4.ini file is created presumably when attempting to open FSX

Edited by Ganradlogin

Share this post


Link to post
Share on other sites
On 12/30/2019 at 2:51 PM, Ganradlogin said:

FIXED !!

A suggestion on Steam worked:

Deleted Logbook.BIN in Documents>Flight Simulator X Files

 

Nice trick, thank you.  I was just experiencing the same issue.  What I did was remove (not delete - move) the logbook file to my desktop, run FSX, say yes at the error message, and quit FSX after successful startup (and new, blank logbook).  I replaced the new logbook file with the original logbook file.  Hopefully that would qualify as a permanent workaround in the future as that bug popped up for me two months or so ago.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.