Jump to content
The simFlight Network Forums

Ejets installed outside of P3D will not appear


Recommended Posts

Hi All,

Has something changed with regards to the installation in SP1.

With the original release I installed the aircraft outside of P3D and added the folders to the relevant menus.

Everything worked fine.

Since the installation of the SP1 I have none of these aircraft available in P3D.

I have checked all the relevant folders. I have noticed that the aircraft were installed using a different folder structure this time, and the previous files were not overwritten.

Any assistance appreciated.




Subject line changed reflect the issue - mods 

Link to comment
Share on other sites

So you didn't use the default install, ie, let the installer do it, for the the original release and therefore couldn't use the uninstaller to remove the pre-SP1 plane?

You haven't manually uninstalled your custom pre-SP1 install and then allow the SP1 installer to do its thing?

Link to comment
Share on other sites

4 minutes ago, bvanhout said:

the latest P3D convention

Unaware that this was something more than popular user mod.  Can you share where Lockheed Martin recommended this convention?

Please provide the details of your custom file structure for the coders to review.


Link to comment
Share on other sites

Your own installer gives the opportunity to install into an "Add-ons Folder".

This is the preferred method since P3Dv3. It negates reinstalling everything if you have a P3D problem

This outlines everything that can be installed outside the main P3D directory.


I do not have a "custom file structure" just one called "Prepar3D v4 Add ons" outside of the main P3D directory. The name is irrelevant as long as your Simobjects.cfg points to the add-ons folder.

My question remains, how come it worked with the initial installation in December but with SP1 doesn't work. Has something changed??????????????? was my initial question.

feelthere installer.jpg

Link to comment
Share on other sites

For the pre SP1 release I added manually the lines below in the add-ons.cfg, you may try that. I also did not use the P3D folder but my add-ons custom folder.

[Package.xx]   <- depends by your list
PATH=F:\Lockheed Martin\Prepar3Dv4_Addons\FeelThere EJets  <-depends to your path

On my side the installer, ran as admin did not see the module/add-on so I did it manually.

For SP1 might be the same issue but I did not install it yet.

Link to comment
Share on other sites

  • 3 weeks later...

I installed the normal way and then manually moved the Feelthere folder O/S of the root P3Dv4.5 drive. It's over 10gb, I do not want it taking up space on my SSD drive. So I created an addon.xml file with the following and placed it in documents\Prepar3D v4 Add-ons\FeelThere Ejets :

<?xml version="1.0" encoding="utf-8"?>
<SimBase.Document Type="AddOnXml" version="4,0" id="add-on">
  <AddOn.Name>FeelThere EJets</AddOn.Name>
  <AddOn.Description>FeelThere EJets</AddOn.Description>
    <Path>D:\P3D v4 Addons\FeelThere EJets\SimObjects\Airplanes</Path>
    <Path>D:\P3D v4 Addons\FeelThere EJets\Scripts</Path>
    <Path>D:\P3D v4 Addons\FeelThere EJets\Effects</Path>

Everything works fine.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.