Jump to content
The simFlight Network Forums

Tower!3D Pro Does Not Open


FroYo10101
 Share

Recommended Posts

Just downloaded and installed the game on a new computer (I have been playing this game on another computer for a couple years now). It opens to a black screen momentarily, then crashes a couple seconds after. Trying to do a normal run and a run as administrator yield identical results. Could anyone help me out?

Link to comment
Share on other sites

9 minutes ago, EliGrim said:

Try to disable WiFi and/or unplug your LAN cable or disable your network adapter.

If that works, you can try this as well:
https://steamcommunity.com/app/588190/discussions/0/3044978436772930644/#c3050610473979963629

Thank you very much, Eli. This worked perfectly. By the way, I really enjoyed all of the streams and videos you worked on with TP over on YouTube and Twitch!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.