Jump to content
The simFlight Network Forums

Tower 3D Pro and Windows 11


Recommended Posts

Is there a compatibility issue with Tower 3D Pro and Windows 11?   When I try to start the program I get a black screen and then get booted back to the desktop.

Its worked once, but now not at all. Tried several re-instlls, but nothing.

Help please.

Link to comment
Share on other sites

I am running Windows 11 and just installed Tower!3D Pro.  I would not start with the Ethernet adapter enabled.  This is how I fixed it:

Go to Network Settings, Advanced Network Settings, and added a second IP address to the adapter:
IP Address:
Subnet Mask:

Note - this may affect your ability to reach sites at feelthere.com

I don't know why the application is reaching out to this IP address and then crashing, but this is why the app works when you turn off the Network Adapter.  But added the second IP address, you (in effect) route that request to no place and it doesn't do whatever it is doing.


  • Upvote 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.