Jump to content
The simFlight Network Forums

Button events not identified anymore

Recommended Posts

Hi Pete, all

I am having a problem with button events, that are no longer identified, or at least not executed on the aircraft. Not sure where the problem lies exactly.

I am using several Arduino boards for my home cockpit. So far I was running all hardware, Arduino cards (Mobiflight) and the aircraft server (Jeehell) directly on the P3D computer. To increase performance on P3D, I now moved the Jeehell server, hardware and I/O cards to one of my networked computers to connect via WideFS (Arduino) and SimConnect(Jeehell). WideFS is working fine (I can use my Skalarki hardware for example. I could also test all LEDs connected to the Arduinos). But nearly all Arduino button events are not executed anymore. Mobiflight identifies the button press and also indicates that FSUIPC/WideFS is working. But the only function, that is executed on the aircraft, is the parking brake. All other functions (7 Arduino cards) are not working anymore. So I guess, there is a central aspect, that I am missing. But after diverse tests I still have no clue.

To narrow down on the error I tried configuring the entries again. I finally took a new Arduino board and just set up 2 functions: parking brake and taxi light. I tried connection on the client computer as well as on the P3D computer. Both with same effect: parking brake is working; taxi light isn't. I am using the same offsets settings, that used to work before. That's what I don't understand at all!

FSUIPC and WideFS are registered. In the FSUIPC log I could see, that both were running. However I couldn't figure out how to use the logging feature to check, if the different button events are recognized by FSUIPC at all.

Extract of last log:

21435 -------------------- Starting everything now ----------------------
    21466 ASN active function link set
    21466 Ready for ActiveSky WX radar with additional data
    22558 Advanced Weather Interface Enabled
   421265 Sim stopped: average frame rate for last 377 secs = 27.9 fps
   421265    Max AI traffic was 24 aircraft (Deleted 0)
   434416 === Closing session: waiting for DLLStop to be called ...
   450531 === DLLStop called ...
   450531 === Closing external processes we started ...
   451529 === About to kill any Lua plug-ins still running ...
   451685 === Closing global Lua thread
   452684 === About to kill my timers ...
   452887 === Restoring window procs ...
   452887 === Unloading libraries ...
   452887 === stopping other threads ...
   452887 === ... Button scanning ...
   452996 === ... Axis scanning ...
   453089 === Releasing joystick devices ...
   453089 === Freeing macro memory
   453089 === Removing any offset overrides
   453089 === Closing all WideFS threads

Thanks for your help!


Link to comment
Share on other sites


offset 0x0D0C works OK, in P3Dv4.

In case you cutted very important information from the log file it is neither clear what FS version you use nor which FSUIPC version is used. The info using P3D doesn't say anything, P3Dv1/v2/v3/v4 or v4HF ?

Incase neither FSUIPC nor WideClient recognize and handle Ardunio hardware, the interfacing to FSUIPC are entirely implemented by add-ons, as you use Mobiflight, it looks more likely of a problem with that.

For Button logging in FSUIPC you need to have Buttons programmed in FSUIPC, Buttons are Joystick buttons only or Hot Joystick Buttons via Offset 0x2910 / 0x3210.

Best is to show first a full log file, not modified or cut.


Link to comment
Share on other sites

1 hour ago, Thomas Richter said:

For Button logging in FSUIPC you need to have Buttons programmed in FSUIPC

Just to clarify that, the Buttons and Switches tab, used for assigning actions to these, will show the joystick number (or letter ID) for the joystick, and the button number. but the joystick device must be one which is recognised correctly. That recognition is recorded in the part of the Log you sadly cut off, and also in the INI file snd the FSUIPC5 joyscan file. Allthree files are useful and should definitely be shown in full as Thomas says.



Link to comment
Share on other sites

Thomas, Pete,

thanks for your quick response.

I finally found the error this morning: I didn't install the FSUIPC module for Jeehell on the computer, runnning the Jeehell server. I had it installed on the P3D computer only.

Now it's working as always before. But thanks again. Good to know now about the FSUIPC button logging feature!




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.