Jump to content
The simFlight Network Forums
Hossi

Problems with Joystick and FSUIPC5

Recommended Posts

Hi,

Since a few days I have WIN10 64 pro installed on my PC and according to P3Dv4.5 and FSLabs 2.02.424
reinstalled.
Throttle, Rudder and Brakes and Tiller are to be controlled with FSUIPC. Because Rudders are operated by foot pedals, the joystick's rotary stick is free and can be used as a tiller. This has always worked in WIN7.
Now it doesn't work anymore, because the rotation is only between 12287 and -4941. In Win7 and P3D the rotation range is 16383 to -16384.
At the moment I can only control the nosewheel with the rudder pedals.
Do you have any idea why the joystick under Win10 with FSUIPC 5 is limited in rotation now?

Kindly regards

Horst

 

Share this post


Link to post
Share on other sites
22 minutes ago, Hossi said:

Now it doesn't work anymore, because the rotation is only between 12287 and -4941. In Win7 and P3D the rotation range is 16383 to -16384.
At the moment I can only control the nosewheel with the rudder pedals.
Do you have any idea why the joystick under Win10 with FSUIPC 5 is limited in rotation now?

As well as what Thomas says, calibration in FSUIPC matches ANY input range (whether limited or not) to the full range acceptable to P3D. So you can calibrate in FSUIPC. 

But the calibration in Game Controllers should be done first because that will ensure you have the best precision with the incoming readings. Game Controllers calibration is stored in the Windows Registry and limits what FSUIPC can read.

Pete

 

Share this post


Link to post
Share on other sites

Hi,

Win10 recognizes the joystick but you can do nothing in the settings except remove it.
In the P3D calibration all axes move up to the stop left and right.
In the Axis Assignment in FSUIPC all axes show wrong values.
In the FSUIPC calibration only Aileron and Elevator show correct values, Rudder does not react.

Share this post


Link to post
Share on other sites
9 minutes ago, Hossi said:

In the P3D calibration all axes move up to the stop left and right.
In the Axis Assignment in FSUIPC all axes show wrong values.

FSUIPC uses the standard DirectX joystick input facilities to read the values. What it shows is exactly what is received. 

P3D uses the same methods UNLESS you select  "raw mode" instead of "DirectInput" in the "Other" section.  In its raw mode it bypasses DirectX and reads the USB stream directly. This is not the normal way.

If the DirectInput method gives "wrong values" (whatever that means -- you really need to be more specifc) it will because that's what DirectInput provides, and that is affected by Registry settings.

Those Registry settings, unless set properly by the installation procedure which takes place in Windows when it detects and recognises devices, are normally set by the Windows calibration, done by Game Controllers. You can get to that easily in P3D's "Calibration" section, clicking the "Calibrate Device" button.

You go on to say:

16 minutes ago, Hossi said:

In the FSUIPC calibration only Aileron and Elevator show correct values

Now what do you mean by "correct values"? If you've assigned them in the Axis assignments (and NOT in P3D) then the IN values ill match the values you see in the axis assignments, which you say are "wrong" (whatever that means). They ARE the same values! So you are not making sense there.

As for Rudder. How have you assigned that?

I think you need to start afresh. delete (or rename) your FSUIPC5.INI file (in the Modules folder) so that when P3D starts a new default on is produced. Then decide where you are going to assign devices -- P3D or FSUIPC. Do not use both for assignment, you MUST choose one or the other.  The calibration in FSUIPC is separate from this. FSUIPC calibration can be used for axes assigned in either place.

For the possible Registry mess the best thing to do would be to unplug your joystick device(s), use Windows Device Manager to uninstall them software/driver as well, then re-boot, plugging them back in for fresh recognition. That should re-write the Registry entries for them.

Pete

 

Share this post


Link to post
Share on other sites

Hi,

Now I got an advice how to start the calibration in Win10. Enter joy.cpl into the search window in the lower left corner of the settings and then you get into the calibration routine as you know it from Win7.
I tried to do the calibration. Unfortunately I was not very successful. Therefore I will accept your recommendation and register the joystick again in Win10, delete the existing FSUIPC ini file and do the calibration again. Then I will try to do the  Axis Assignment again

Thank you so much for your support

Kindly regards

Horst

 

 

Share this post


Link to post
Share on other sites

Hi,

Now, thanks to your recommendation, I have the joystick
newly set up and calibrated in Win10.
Now the joystick works as it should.
Then I started to set up the axes.
and now the joystick with the twist works as a tiller.
Thanks again for your support.

Kindly regards

Horst

 

Share this post


Link to post
Share on other sites
1 hour ago, Hossi said:

Now I got an advice how to start the calibration in Win10. Enter joy.cpl into the search window in the lower left corner of the settings and then you get into the calibration routine as you know it from Win7

I think the calibration selection in P3D does the same thing.

39 minutes ago, Hossi said:

Now, thanks to your recommendation, I have the joystick
newly set up and calibrated in Win10.
Now the joystick works as it should.
Then I started to set up the axes.
and now the joystick with the twist works as a tiller.

Good!

Happy flying!

Pete

 

Share this post


Link to post
Share on other sites

Hi, my joystick is setup with joy.cpl and all axis calibrated again in FSUIP (payed version) ; although the reaction with my FSLabs airbus is not realistic; i adapted SLOPE but this just changes the point of reaction to the stick input. On long final, the small stick movements have no reaction and if i move a bit further the airbus banks as quick and as hard as a cessna... how make this more realistic ?

Share this post


Link to post
Share on other sites
19 minutes ago, Pluto7777 said:

i adapted SLOPE but this just changes the point of reaction to the stick input. On long final, the small stick movements have no reaction and if i move a bit further the airbus banks as quick and as hard as a cessna... how make this more realistic ?

Really the designers of sophisticated aircraft models such as those from FSL should have all the flight controls reacting realistically assuming a linear input from your levers and joysticks.  Different response curves, like those offered by the FSUIPC slopes facility, are just there for you to make your experience more as you like it.

So, start with a linear response curve -- i.e. a slope of 0. Only do small adjustments as you feel you need to. From your description is sounds as if you have a rather extreme centre flattening which will of course steepen the edges. If you've done this because of jitter from your controls around the centre zone (or, for example, not always properly centering when released), then you should deal with that by calibrating with a suitable central null zone, not by using a flattened slope.

Pete

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.