Jump to content

Cannot download latest version FSUIPC7 because of various webbrowsers report SSL/DNS problem accessing the download page.


Recommended Posts

Hi, two different browsers are blocking my attempts to go to the download page. So, I am not able to download the latest update.

MS Edge reports an ERR_SSL_PROTOCOL_ERROR (see the attached image below)

then on a tablet with Android OS: "could not encounter the DNS address for forum.flightsim.com." We are investigating the problem." (btw: last text is my translation from Portuguese into English).




Link to comment
Share on other sites

Which version and from where are you trying to download? I've just tried both sites and they are all working ok. If having issues, try right-clicking the downloadable file and select 'Save as...'. 

Also, please don't posy in the announcements forum. I will move your post.


Link to comment
Share on other sites

On 6/6/2021 at 1:11 PM, paulsk said:

Hi, two different browsers are blocking my attempts to go to the download page...


The certificate gets recognized just fine for me - I tested with Chrome, Edge and Firefox.
I am able to ping the server and also perform both the reverse and forward DNS lookup via Cloudflare, OpenDNS, GoogleDNS and my ISP and also check the server records:

Fremont-CA - US157.90.xxx.xxx  0  157157xxxxxx
Toronto - CA157.90.xxx.xxx  0  109108xxxxxx  
Johannesburg - ZA157.90.xxx.xxx  0  198198xxxxxx  
Singapore - SG157.90.xxx.xxx  0  170170xxxxxx  

v=spf1 mx a ip4:x.x.x.x ip4:157.90.xxx.xxx ip4:157.90.xxx.xxx ip4:157.90.xxx.xxx ip4:135.181.xxx.xxx a:mail.in-xxxxxxxxxxx.xxx include:in-xxxxxxxxxxx.xxx include:_xxx.xxxxx.xxx -all


0 issue "digicert.com"
0 issue "letsencrypt.org"
0 iodef "mailto:domreq@xxxxxxxxxxx.xxx"

All of this shows that simflight.com and it's subdomains function perfectly.
I'd suggest you perform a small refreshing command:

1. In your browser go to Settings and choose to delete cookies, saved offline files and temporary files.

2. Right click Win button then left click Windows PowerShell (Admin)
Left click Win then in the search field type cmd and hit enter

3. In the new window that opens type:

ipconfig /flushdns

4. Hit enter - wait for it to finish - close

5. Restart your machine

5. And at the same time restart your router, switch or whatever you have (just power it off then on if you can't find the power button)

If you still experience the same issue you'll have to contact your Internet Service Provider.
But I hope this fixes it.

Link to comment
Share on other sites

  • 2 weeks later...

Hi Milan and Pete,

Thank for your reply. Today, Jun 21, 2021, I read @milan 's. I was able to login to this forum. I was also able to open www.fsuipc.com.

So, I thought: everything is OK. When I wrote my answer here in this forum to you, at the moment I pushed the button "Submit Reply", the Edge browser popped up that warning page as I uploaded on June 6. Then I removed the cookies from this forum and from simMarket. Then, from within a cmd session I issued the ipconfig ... command. Rebooted the desktop PC and also rebooted the router from my isp. After having internet again and my desktop PC had been rebooted, I tried again: logged into this forum, visited fsuipc.com. All OK, but at the time I wanted to send another reply in this forum I got again the warning page in Edge. Now I started a 2nd Windows PC that I have here. I logged into this forum OK. I called up the fsuip.com page. The page opened but with a warning on the address line saying (in Portuguese language) "not safe" See the screen shot. But the page of this forum shows the "lock", so that's OK.  Also opening fsluip.com using the Chrome browser gives the "not safe" warning.

So far my reply.






Link to comment
Share on other sites

www.fsuipc.com will give an unsafe warning, as its http only and not https. I've not added a certificate up till now, as its not really been needed. It will be updated at some point, when I get around to re-vamping the site. For now, just ignore the warnings.


Link to comment
Share on other sites

OK John. Now I'm back in the desktop PC that I had the browsing problems with.

I found also this: ERR_SSL_PROTOCOL_ERROR - Microsoft Community I did the steps as advised in there.

So let's see what happens when I am going to Submit this reply.

If you don't see another reply from me in an hour, then the problem for this forum site are over.


  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.