Jump to content
The simFlight Network Forums

guenseli

Moderators
  • Posts

    464
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by guenseli

  1. Yes, thats another one. For my version there are no keys to insert - therefore just 90 days. I treid to get my hands also on this free keys, but haven't worked :)
  2. Hello Pete, I got mine from here, I think I had subscribed for MSDN a while ago http://msdn.microsoft.com/en-us/evalcenter/jj554510.aspx I tried the public versions a few month ago, too, and yes, there is a big difference. Currently, the enterprise RTM it is not perfect as IE10 or the on-board-mail program have some bugs, but all in all it is rockstable and faster as WIN7; at least for me. In FSX I can't see any difference in frames or smoothing, but I haven't expceted this. MS has done a huge stept forward the last month/year in my opinion. I own a Windows Phone, just wanted to try out for cheap money and I'm very surprised and even IPhone users do admit a better usability! In combination with a MS Live ID and WIN8, it's a perfect workspace (no, I'm not a MS employee :mrgreen: ) The difference between enterprise and the WIN8 Pro version which will be relased end of october for public is not soooo big for a normal user I think. Enterprise is able to have the complee OS on an USB stick and has some developer features. But be aware, that this version ends after 90 days without any possibility to change to the nomal version. You have to reinstall in every case! Regarding the FSUIPC proble, I have inserted the logging lines into the ini and hope to catch the error this evening! Maybe we see then sth in the log. Greetings, Günter
  3. Morning Pete, Interesting to see so many people ranting about WIN8; I'm sure most haven't had a slight glance into it beside some screenshots of the metro menu ;-) All I can say is, that there is absolutely no difference in appearance between WIN7 and WIN8, except the startmenue is looking different - and you can use it on your tablet in a few month. The difference however is a much faster OS with some features I like very much now. What I wonder about is, that it (FSUIPC) works mostly but than from a day to another when I enter the menue, FSUIPC stops working. A restart of FSX solves this then. (exception yesterday evening). I haven't attached a LOG file, because, there you could not see anything. There is simply no loggin any more. But of course, I can attach one next time it happens. What I see, when I open the FSUIPC menue is, that there's then no reaction to joystick movement or button presses. When I close then the menue, I have no joystick movement in FS, too. Restarting FS solves this normaly. Same could happen with a default ini file, yes. As I said, this does not happen every time. There are days it is working normal as it should. I was just posting here in case, you have an initial idea about- maybe I have messed something up in my ini ... But I do not want you to dig deeper into that as I also have to say that I experiment now currently a bit with the OS and FSX and P3D. Maybe I had made some strange setting somewhere. In one month, when WIN8 is released to the public I have to reinstall in any case and I would then avoid to try out all the settings. I'm very confident WIN8 would be a success :razz: EDIT Yes, of course and I can of course set compatibility mode to test it, but no difference. Till now I haven't had one program that had any problems with win8. Even my old scanner who has just XP drivers is working.
  4. Hello Pete, this is a very strange bug, I fiddled now a few weeks with it around, now I have to ask you. I installed WIN8 64 enterprise version (RTM official version). Means also that I installed FSX (Acc) freshly ... with FSUIPC 4.853 Normaly I copy over the complete modules folder to have my setup instantly as I assigned everything through FSUIPC. What happens now is, that sometimes, when I enter the FSUIPC menue,FSUIPC stopps working. Currently this evening, it is for 100% that it is not working. This doesn't matter which aircraft it is. Before entering FSUIPC menue everything works, but if I call up FSUIPC menue, I can't see my axis or buttons in the FSUIPC interface. If I leave then the FSUIPC interface, everything has stopped working - moving a joystick does not have any result. Buttons do also not react (in the FSUIPC menue), but they do it through LINDA (where I have all my buttons assigned with) (as you surely know, LINDA needs FSUIPC to work, that's why I wonder) What I have tried to solve it: - complete new FSUIPC.ini with all assignments new. - "reload all assignments" of course - disabled USB poweroff in the OS - disabled any other OS power save thingy - changed my joysticks location to several USB ports (I have a Warthog, two Saitek throttles, a Bodnar BUX device and a X52 Pro) - all drivers updated - checked windows devices and joysticks show up and work as they should while they do not in FSUIPC any more - EZDOC hat switch is working also after FSUIPC has stopped For your info: as I said above it wasn't working for 100% this evening: this was resolved by restarting the PC. After that it was working. Don't know if that info is important. I insert hereinafter my first part of the FSUIPC.ini, maybe you see sth. (note, that I moved to P3D now: what I've described above happened with normal FSX, but is the same issue in P3D) I hope you do not say "doesn't interest me; WIN8 isn't officially released" Everything (except the new QW Bae146) is working under WIN8 without any problems. Many, many thanks, Günter [General] UpdatedByVersion=4853 History=EGYXFLP7LXO5XKTTH3XIW InitDelayDevicesToo=No MouseWheelMove=No MouseWheelTrim=No MouseWheelTrimSpeed=1 JoystickTimeout=20 PollGFTQ6=Yes BlankDisplays=No FixControlAccel=No FixMachSpeedBug=No DeleteVehiclesForAES=Yes AutoScanDevices=Yes VisibilityOptions=No OneCloudLayer=No CloudTurbulence=No CloudIcing=No GenerateCirrus=No SuppressCloudTurbulence=No MaxIce=-4 MinIce=-4 UpperWindGusts=No SuppressWindTurbulence=No SuppressWindVariance=No WindTurbulence=No TurbulenceRate=1.0,5.0 TurbulenceDivisor=20,20,40,40 SuppressAllGusts=No MaxSurfaceWind=0 WindLimitLevel=200 WindDiscardLevel=400 WindAjustAltitude=No WindAjustAltitudeBy=2000 SmoothBySimTime=No WindSmoothing=No WindSmoothness=2 WindSmoothAirborneOnly=Yes PressureSmoothness=0 TemperatureSmoothness=0 DisconnTrimForAP=No ZeroElevForAPAlt=No ThrottleSyncAll=No WhiteMessages=No ShowPMcontrols=No SpoilerIncrement=512 MagicBattery=No RudderSpikeRemoval=No ElevatorSpikeRemoval=No AileronSpikeRemoval=No ReversedElevatorTrim=No ClockSync=No ClockSyncMins=5 ClearWeatherDynamics=No OwnWeatherChanges=No TimeForSelect=4 LoadFlightMenu=No LoadPlanMenu=No PauseAfterCrash=No BrakeReleaseThreshold=0 SaveDataWithFlights=No ZapSound=firework ShortAircraftNameOk=Yes UseProfiles=Yes EnableMouseLook=No AxesWrongRange=No TCASid=Flight TCASrange=40 AxisCalibration=No DirectAxesToCalibs=No ShowMultilineWindow=Yes SuppressSingleline=No SuppressMultilineFS=No AxisIntercepts=No DontResetAxes=No InitDelay=0 GetNearestAirports=No OOMcheck=Yes WeatherReadFactor=2 WeatherRewriteSeconds=1 CustomWeatherModify=No SimConnectStallTime=1 InitialStallTime=10 NormalStallTime=1 LuaRerunDelay=66 Console=No LogEvents=Yes FSVersionUsed="Lockheed Martin® Prepar3D®",1.4.4747.0 SimConnectUsed=1.4.0.0 [VRInsight] 1=com3 [Programs] RunIf1=F:\Program Files (x86)\Lockheed Martin\Prepar3D\Modules\linda.exe [JoyNames] AutoAssignLetters=Yes A=Saitek Pro Flight Throttle Quadrant A.GUID={77A144F0-FA79-11E1-8002-444553540000} B=BU0836X Interface B.GUID={77A144F0-FA79-11E1-8003-444553540000} C=Saitek Pro Flight Rudder Pedals C.GUID={77A16C00-FA79-11E1-8005-444553540000} D=Joystick - HOTAS Warthog D.GUID={77A16C00-FA79-11E1-8006-444553540000} E=Saitek Pro Flight Throttle Quadrant E.GUID={77A16C00-FA79-11E1-8007-444553540000} F=Throttle - HOTAS Warthog F.GUID={77A19310-FA79-11E1-8008-444553540000} G=Saitek X52 Pro Flight Control System G.GUID={77A1BA20-FA79-11E1-800D-444553540000} 0=Saitek Pro Flight Throttle Quadrant 0.GUID={77A144F0-FA79-11E1-8002-444553540000} 1=BU0836X Interface 1.GUID={77A144F0-FA79-11E1-8003-444553540000} 2=Saitek Pro Flight Rudder Pedals 2.GUID={77A16C00-FA79-11E1-8005-444553540000} 3=Joystick - HOTAS Warthog 3.GUID={77A16C00-FA79-11E1-8006-444553540000} 4=Saitek Pro Flight Throttle Quadrant 4.GUID={77A16C00-FA79-11E1-8007-444553540000} 5=Throttle - HOTAS Warthog 5.GUID={77A19310-FA79-11E1-8008-444553540000} 6=Saitek X52 Pro Flight Control System 6.GUID={77A1BA20-FA79-11E1-800D-444553540000} [Buttons] ButtonRepeat=20,10 1=CP(+A,2)A,5,CL2:R,0 [MacroFiles] [LuaFiles] 1=ipcReady 2=linda 3=log lvars 4=A2A_Cowl 5=A2A_Flaps 6=A2A_Turbo [AutoSave] Next=1 Interval=60 Files=10 SaveOnGround=No AutoSaveEnabled=No [GPSout] GPSoutEnabled=No [GPSout2] GPSoutEnabled=No [WideServer] WideFSenabled=Yes [Sounds] Path=F:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Sound\ Device1=Primärer Soundtreiber Device2=Lautsprecher (High Definition Audio-Gerät) Device3=Kopfhörer (High Definition Audio-Gerät) Device4=Digitalaudio (S/PDIF) (High Definition Audio-Gerät) Device5=Digitalaudio (S/PDIF) (High Definition Audio-Gerät) [Keys] 2=97,8,1126,0 4=98,8,65907,0 5=99,8,65908,0 7=100,8,65909,0 9=101,8,65910,0 11=102,8,65911,0 13=103,8,65912,0 15=104,8,65913,0 17=105,8,65914,0 19=111,8,66506,225 21=96,8,1126,0 [Axes] 0=AX,256,D,13,0,0,0 1=AY,256,D,14,0,0,0 2=AZ,256,D,23,0,0,0 3=CX,256,D,7,0,0,0 4=CY,256,D,8,0,0,0 5=CR,256,D,47,0,0,0 6=DX,256,D,45,0,0,0 7=DY,256,D,46,0,0,0 8=EX,256,D,17,0,0,0 9=EY,256,D,18,0,0,0 10=EZ,256,D,22,0,0,0 11=FZ,256,D,10,0,0,0 12=FR,256,D,9,0,0,37 13=FS,256,D,21,0,0,0 [JoystickCalibration] AllowSuppressForPFCquad=Yes ExcludeThrottleSet=Yes ExcludeMixtureSet=Yes ExcludePropPitchSet=Yes SepRevsJetsOnly=No ApplyHeloTrim=No UseAxisControlsForNRZ=No FlapsSetControl=0 FlapDetents=No ReverserControl=66292 Reverser1Control=66422 Reverser2Control=66425 Reverser3Control=66428 Reverser4Control=66431 MaxThrottleForReverser=256 AileronTrimControl=66731 RudderTrimControl=66732 CowlFlaps1Control=66162 CowlFlaps2Control=66163 CowlFlaps3Control=66164 CowlFlaps4Control=66165 SteeringTillerControl=0 MaxSteerSpeed=60 Aileron=-16380,-512,512,16380 Elevator=-16380,-512,512,16380 Rudder=-16380,-2000,2000,16380 LeftBrake=-16380,16380/16 RightBrake=-16380,16380/16 Throttle1=-16380,-512,512,16380/32 Throttle2=-16380,-512,512,16380/32 ElevatorTrim=-16380,-512,512,16380 SlopeElevatorTrim=5 [/CODE]
  5. Many thanks Pete, outstanding service as always!!! Substracting from 16384 was the magic trick :) "If you are writing "var" back as an unteger it will be rounded down to the nearest integer in any case. To round up or down to the nearest, just add 0.5 first. i.e." Ah, ok will try that. Looks like a lot better then my "trick" many thanks and many greetings! Günter
  6. Hello Pete, as I'm not the big mathematician, I hope you could help me a bit: I have a LUA script assigned to an axis. Working so far. But I want the axis now the other way round: var = round((ipcPARAM+16384)/32768*100) Now, var is 100 at 16384 and I want var to be zero at 16384 and 100 at -16834 ("round" is a selfmade function for roundings as you surely assume) There must be somewhere a -1 inserted, could you point me please to the right direction? many thanks! Günter
  7. Maybe it works that you make a second Macro with return and assigning it in FSUIPC on "button release"? Just a guess ...
  8. Hello, there is a special LINDA forum on AVSIM. No, LINDA is just responsible for buttons. Axes should be assigned via FSUIPC You can assign all your buttons with LINDA to any Hardware which is showing up in LINDA. And all axes in FSUIPC
  9. Hello Pete, maybe a bit of uncommon question: is there a way to disable an DLL? Background is, I use Flight1 Soundstream (what I find absolut brilliant - If you don't know it, it plays FSX sound even when FSX window is not in focus. I have two monitors.) Unfortunately I have two addons which let FSX crash, or better said, Soundstream crashes FSX when I use these plane-addons. Windows error log shows clearly soundstream.dll to be the cause. Unfortunately #2, the Soundstream support (if there is any?) has no solution. Soundstream is a DLL located in D:\Flight One Software\Flight1 SoundStream\Flight1SoundStreamFSX.dll and has entry in the DLL.xml. Disabling this entry solves the crashes of course. Soundstream has no process in the taskmanager. Could it now be possible in any way to disable this DLL when one of these planes gets loaded? via LUA/LINDA? Or any other idea about this? I fear, that there is no solution, but I just wanted to ask. Or do you have an idea how to make play FSX sounds when window is not active? Many thanks for any suggestions?
  10. Thanks for your answer, Andrew. thats the behave I have, yes. the problem is, the error is still there, even when I remove the steering tiller assignment!
  11. Hello Pete, I use Rudder/Steering Tiller since ages on the same axes, my Saitek Pedals without any problems. (I have read during search now, that this is not recommended. But as I said, I haven't had problems) I updated to version 4.843 lately and now I have reproducable problems with my rudder. Fortunately I have backupped an old version 4.834 which is working perfect, and I see clearly the issue brought in with 4.843 The problem is, that I can't move my rudder to the right. This is a serious problem with high powered props like the A2A Mustang as I hav not a chance to hold the 2000 hp on the runway. Til about 50 knots, there's almost no rudder movement to the right, left is ok. Axes and calibration is ok. This issue is also present, when I remove steering tiller from the same axes. Hope you got an idea, Pete. Beside this, hope you have a nice trip! Günter
  12. Mister "sunshine" from germany, if I could help, please let me know. You can write here in german or PM me and I will translate for you or support you! I do not think, you are on a good way here ... ^_^ Again in german: Hallo, wenn Du Fragen hast, dann kontakte mich per PN oder frag hier auf Deutsch ich werde versuchen Dir zu helfen oder wenigstens übersetzen. Aber so wirst Du leider nicht weit kommen ... Günter
  13. Good morning Pete, good you sorted it out what PMDG does with this axis ... :cool: This "issue" must be longer there, I think. I have bought EZDOK camera a few weeks ago and changed from using 2D panels for overhead, pedestal etc to "real VC views" with EZDOK (great addon btw). And as I have also a left handed mouse I suddenly noticed this issue. I contacted PMDG support (fast answer, great support, but took a short while because the corresponding developer was on route) and we looked for an EZDOK issue first, After that I uninstalled the NGX completely and reinstalled it by advice from PMDG. Then "grandsurf" came up with this FSUIPC idea luckiliy :razz: Have you tried it with your right mouse button also? My left mouse button is also working, but as I have a left handed mouse, my right one is the primary. Maybe that is it ... ok, glad, this issue is sorted out now!!! Hope, PMDG is reading this also and take a a note for this rare cases ... Many thanks, Günter
  14. ok, take a seat please, Pete ;) And the villain is: (drum roll) CowlFlaps1=0,16380 Checked and double checked, restarted FSX, inserted all my old stuff and configurations into my fresh FSUIPC. ini and disabled this line --> working! And: inserted the old FSUIPC4.ini and deleted this line --> working! :cool: I hope strongly that this isn't a "next day I start my PC and issue is back" thingy, but I tested it now several times...
  15. ok, seems the Joystickcalibration makes some error :???: I have now inserted step by step every difference between my old file and the new (working one) and have tested if the error happens. By filling in the Calibration part, the issue comes up [JoystickCalibration] AllowSuppressForPFCquad=Yes ExcludeThrottleSet=Yes ExcludeMixtureSet=Yes ExcludePropPitchSet=Yes SepRevsJetsOnly=No ApplyHeloTrim=No UseAxisControlsForNRZ=No FlapsSetControl=0 FlapDetents=No ReverserControl=66292 Reverser1Control=66422 Reverser2Control=66425 Reverser3Control=66428 Reverser4Control=66431 MaxThrottleForReverser=256 AileronTrimControl=66731 RudderTrimControl=66732 CowlFlaps1Control=66162 CowlFlaps2Control=66163 CowlFlaps3Control=66164 CowlFlaps4Control=66165 SteeringTillerControl=0 MaxSteerSpeed=60 Aileron=-16380,-512,512,16380 Elevator=-16380,-512,512,16380 Rudder=-16380,-512,512,16380 SlopeRudder=4 Mixture=-16380,16380 LeftBrake=-16380,16380/16 RightBrake=-16380,16380/16 Throttle1=-16380,-512,512,16380/32 Throttle2=-16380,-512,512,16380/32 Throttle3=-16380,-512,512,16380/32 Throttle4=-16380,-512,512,16380/32 ElevatorTrim=-16380,-512,512,16380 Spoilers=-16380,16380 Flaps=-16384,16380 CowlFlaps1=0,16380 CowlFlaps2=0,16380 CowlFlaps3=0,16380 CowlFlaps4=0,16380 PanHeading=-16380,-512,512,16380 SlopePanHeading=15 SlewAlt=-16380,-512,512,16380/16 [/CODE] Note: this is very early in my FSUIPC4.ini, means I haven't yet now inserted any aircraft specific settings. And this is 100% reproduceable. If I remove this, the NGX is working again ... I will now exclude line by line of the calibration and hopefully find one single line causing the error ...
  16. Yes, of course I have the old one! Because I know, you'd like to investigate :razz: Sent per Mail ...
  17. Jep, tried it! Working! Deleted also the old FSUIPC4.ini and now it works ....
  18. Is this recommended with the install of 4.80? (I haven't read any instructions :oops: )
  19. ok, I join in here: have also a problem, possibly related to FSUIPC with the NGX. I have my system setup with a left handed mouse (don't know if has something to do with) When I press several (not all) keys inside the NGX VC (not the 2D panel) my primary (right) mouse button will generate an action on press and one on release. I have made a little video to show this behave (as example the HGS): http://www.youtube.com/watch?v=vXlsk10QFMk I have contacted PMDG support a few days ago and after a few suggestions (reinstallation etc) the issue is still present. Grandsurf brought the idea up, that disabling FSUIPC solves this error. I tried it (by removing the FSUIPC.dll from modules folder) and everything works as it should. I have also EZDOK camera, but I disabled this already without success. And changed my system to right handed mouse and reinstalled the NGX as per advice from PMDG support. There is absolutely no issue with any other addon, even not from PMDG, just the NGX. I told PMDG now that disabling FSUIPC solves the issue - hope they, or you, Pete, have an idea whats going on. Unfortunately I couldn't say if its since FSUIPC 4.80 or already with earlier versions - I have this issue since a few weeks. I bought EZDOK camera at this time and used 2D panels before, so I haven't had this issue. Hope you have an idea about this (as always) many greetings and many thanks, Günter
  20. Thanks Pete, the BrakeReleaseThreshold cures the issue. Now I understand what it is for and yes, you are right, this is now a developer thing. Will talk to them ... Many thanks for the fast support as always! (p.s. but yes, if I press the brakes slowly, then the 65588 is not sent!)
  21. Hello Pete, I (and a few other users) have issues with some adons (do not want to name the developer here, sorry) But if I press the brakes fully down with my saitek pedals, the brakes will release. This will not happen, when I press my brakes down slowly - only when I press then (relatively) fast. The issue is not occuring on any other addons, and not with FSX standard planes. I have assigned and calibrated (as any other axis) my brakes through FSUIPC. This issue does not occur with FSX assigning. --- now, I have had a look what happens there (with LINDA console) and found out, that at the end, when I press down my pedals, there will be the control 65588 parameter zero sent!? I don't know why it is so, and I don't know if it's specific with Saitek pedals (seems so), and I can't explain, why not other addons are affected. But obvisously, these (65588, 0) is the reason why the brakes release! Hopefully you have a kind of idea for a solution here how to avoid these 65588,0 sending? many greetings, Guenter
  22. There can't be enought threads to praise Pete! And I'm glad to joyn every thread I see, to say how glad we could be with a man like Pete! Thanks! Hope you had a good start into 2012 and that everything elese goes well, especially halth! Günter
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.