Jump to content
The simFlight Network Forums
CathyH

No INI File in FSUIPC5 P3d V4

Recommended Posts

I kept wondering why Fsuipc was not keeping my control assignment, looked, no INI file, I don't have seperate prfiles for each plane, so what's wrong? can you assist, please?

Insert other media

Thanks

Share this post


Link to post
Share on other sites
2 hours ago, CathyH said:

I kept wondering why Fsuipc was not keeping my control assignment, looked, no INI file

If you are looking in the correct Modules folder, where FSUIPC5.DLL is kept, and there is no INI file and no LOG file, then FSUIPC has never actually run!

I suspect that you have Explorer hiding known filetypes from you. The INI file will look like a "configuration file" or similar whilst the Log file will be a "text file". Do as the documentation says and change the folder options in Windows Explorer to not hide filetypes.

The will also be a FSUIPC5.Joyscan.csv file, and a KEY file with your Registration.

Pete

 

Share this post


Link to post
Share on other sites

Sorry peter, I tired that, no INI file still. It will accept the assignments but will not save them. In the Modules folder, there is a documents subfolder there is a DLL file, an install log, copy attached, a DLL and a key file. Unhiding file types is always the first thing I do when I get a new system anyway

 

Cathy

FSUIPC5 Install.log

Share this post


Link to post
Share on other sites

Hi,

your problem might be the security setting in Windows. As you installed in the default Programs folder instead of any different folder, what is always suggested, 

AppPath="C:\Program Files\Lockheed Martin\Prepar3D v4\"

So Windows seems to block programs from writing files in that folder. Also did you install maybe P3D with administrator rights and FSUIPC without or vice versa? The both needs to be installed with the same level.

Thomas

Share this post


Link to post
Share on other sites
41 minutes ago, CathyH said:

Sorry peter, I tired that, no INI file still. It will accept the assignments but will not save them. In the Modules folder, there is a documents subfolder there is a DLL file, an install log, copy attached, a DLL and a key file.

These files are all written by the Installer. But the Installer also changes the read/write permissions on the folder too, so that any program, including itself, can write to it. Are you sure you, or some other program, did not create the folder beforehand. I think the Installer only does it when t creates it itself.

Just in case, it might be worth deleting the Mdules folder entries, then re-running the Installer using run as ... administrator.

There are plenty of installations for P3D3 in Program Files [x86]. I'm pretty sure there are many also with the 64-bit version in Program Files, but I've not know the permissions change not to work before.

Let me know. I'll try some experiments on permissions here if you can't make it work. Are you using Win 10?

Pete

 

 

Share this post


Link to post
Share on other sites

Yes Windows 10 64 Bit Home. I will re download FSUIPC in case it got corrupted during download. I have already tried a delete and reinstall with it, and with zero resulat, but I will try with the re download version

 

Thanks

Share this post


Link to post
Share on other sites

OK, Pete, it is now working, but what a bloody kerfuffle! I had to go into the modules folder and change permissions for every user to aqllow full control, then cancel read only. I now have an INI file

 

Thanks for the help

Share this post


Link to post
Share on other sites
9 hours ago, CathyH said:

OK, Pete, it is now working, but what a bloody kerfuffle! I had to go into the modules folder and change permissions for every user to aqllow full control, then cancel read only. I now have an INI file

Good, but sorry about the "kerfuffle". You don't really have to change permissions for every user, you can just add "EveryOne" to the list in the top half, and allow EveryOne access.

Didn't you try deleting the Modules folder before a re-install, running the Installer "as administrator"?

However, none of this should be necessary at all. I don't know what is going on in your case as it has never happened before.

Pete

 

Share this post


Link to post
Share on other sites
7 hours ago, Pete Dowson said:

However, none of this should be necessary at all. I don't know what is going on in your case as it has never happened before.

I've been researching and experimenting here with possibly better ways of automatically setting permissions on folders (files within them can inherit these). I think I've implemented one which will add "EveryOne" to the Security list for the Modules folder, AND set full access.

It works fine here, bit I'm not really able to test it in the proper circumstances on any system of mine as none have the sort of difficulty you had. However, the improvement will be incorporated in the next FSUIPC5 update and will hopefully prevent this sort of problem in future. So thanks for your report forcing me to look at it again!

Pete

 

Share this post


Link to post
Share on other sites

Hi, 

I am having exactly the same problem. I can not find my .ini file. My view is set to show the hidden files as well. 

Any suggestions ?

Nico (:

Share this post


Link to post
Share on other sites

Nevermind, everyone having this problem, run p3d and FSUIPC as an administrator !!! Took me 3 weeks to figure it out. 

Have a nice day 

Share this post


Link to post
Share on other sites

3 weeks? You should have posted earlier!!

Basically your problem is that you installed P3D in the default 'Program Files' directory, which is restricted by windows. Always better to install in a different (and unrestricted) folder/directory. Installing FSUIPC does try to set the permissions to allow this, but for some reason this sometimes fails on Windows 10 - you may find that you have an error in your install log for this.

Rather than running as n admin, you can manually give permissions to 'Everyone' to the Modules folder.

I will be releasing a new installer at some point this year which will allow you to choose the xml add-on install method instead and so allow installation of FSUIPC outside of the main P3D folder.

John

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.