Jump to content
The simFlight Network Forums
Sign in to follow this  
Wispy

FSUIPC Registered version Disconnects during flight P3D V4.1

Recommended Posts

I keep having an issue where FSUIPC stops working at the same point in a flight I'm trying to do.  Everything I'm in running that relies on FSUIPC stops working at the same time. This happens in different aircraft so I know it's not a specific aircraft issue. I've tried 4 flights in 2 different aircraft and the same thing happens in the same spot. I've tried re-installing FSUIPC with no change. I have no payware airports in the area so nothing really new should be loading at that time of the disconnect. Never had an issue like this before. Anybody have any ideas?

 

Share this post


Link to post
Share on other sites
8 hours ago, Wispy said:

I keep having an issue where FSUIPC stops working at the same point in a flight I'm trying to do.  Everything I'm in running that relies on FSUIPC stops working at the same time.

Can you find the FSUIPC5.log file after this happens (it's in the P3D4 Modules folder) and show me please? You can either attach it, or use the <> button above the edit area to paste in its content.

Pete

 

Share this post


Link to post
Share on other sites

Hello Pete! Thanks for the reply. Here is my log. I did another complete FSUIPC uninstall and re-install and the same thing still happens in the same spot during the flight. Very weird. I'm at a total loss.

 

******** FSUIPC5, Version 5.122 (17th November 2017) by Pete Dowson *********
Running inside Prepar3D v4
Module base=7FFB09AB0000
Windows 10 Home 64 Bit reported as Build 16299, Release ID: 1709 (OS 10.0)
Prepar3D.exe version = 4.1.7.22841
Checking the Registrations now ...
User Name="Chad Quail"
User Addr="cquail@hotmail.com"
FSUIPC5 Key is provided
WIDEFS7 not user registered, or expired
        0 System time = 30/01/2018 15:55:43
        0 FLT path = "C:\Users\Chad Quail\Documents\Prepar3D v4 Files\"
       16 ------ Module Version Check ------
       16        acontain.dll: 4.1.7.22841
       16             api.dll: 4.1.7.22841
       16        controls.dll: 4.1.7.22841
       16      fs-traffic.dll: 4.1.7.22841
       16             G3D.dll: 4.1.7.22841
       16        language.dll: 4.1.7.22841
       16            sim1.dll: 4.1.7.22841
       16        visualfx.dll: 4.1.7.22841
       16         weather.dll: 4.1.7.22841
       16          window.dll: 4.1.7.22841
       16 ----------------------------------
       16 FS path = "G:\Program Files\Lockheed Martin\Prepar3D v4\"
       78 ---------------------- Joystick Device Scan -----------------------
       94 Product= Saitek Pro Flight Rudder Pedals
       94    Manufacturer= Saitek
       94    Vendor=06A3, Product=0763 (Version 1.0)
       94    GUIDs returned for product: VID_06A3&PID_0763:
       94       GUID= {C48A4480-69C0-11E3-8008-444553540000}
       94       Details: Btns=0, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R511,U0,V0,X127,Y127,Z0
       94 Product= Joystick - HOTAS Warthog
       94    Manufacturer= Thustmaster
       94    Vendor=044F, Product=0402 (Version 1.0)
       94    GUIDs returned for product: VID_044F&PID_0402:
       94       GUID= {EFCFE6A0-69BA-11E3-8001-444553540000}
       94       Details: Btns=19, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U0,V0,X65535,Y65535,Z0
       94 Product= Throttle - HOTAS Warthog
       94    Manufacturer= Thrustmaster
       94    Vendor=044F, Product=0404 (Version 1.0)
       94    GUIDs returned for product: VID_044F&PID_0404:
       94       GUID= {121E4DA0-69C0-11E3-8007-444553540000}
       94       Details: Btns=32, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R16383,U1023,V0,X1023,Y1023,Z16383
       94 -------------------------------------------------------------------
       94 Device acquired for use:
       94    Joystick ID = 2 (Registry okay)
       94    2=3 axis 0 button joystick
       94    2.GUID={C48A4480-69C0-11E3-8008-444553540000}
       94 Device acquired for use:
       94    Joystick ID = 3 (Registry okay)
       94    3=Joystick - HOTAS Warthog
       94    3.GUID={EFCFE6A0-69BA-11E3-8001-444553540000}
       94 Device acquired for use:
       94    Joystick ID = 1 (Registry okay)
       94    1=Throttle - HOTAS Warthog
       94    1.GUID={121E4DA0-69C0-11E3-8007-444553540000}
       94 -------------------------------------------------------------------
      109 LogOptions=00000000 00000001
      109 SimConnect_Open succeeded: waiting to check version okay
      109 Opened separate AI Traffic client okay
    26984 Running in "Lockheed Martin® Prepar3D® v4", Version: 4.1.7.22841 (SimConnect: 4.1.0.0)
    26984 Initialising SimConnect data requests now
    26984 FSUIPC Menu entry added
    26984 ... Using Prepar3D with Academic License
    27000 C:\Users\Chad Quail\AppData\Local\Lockheed Martin\Prepar3D v4\Prepar3D_Default.fxml
    27000 G:\Program Files\Lockheed Martin\Prepar3D v4\SimObjects\Airplanes\IRIS Raptor Driver\Raptor.air
    59047 G:\Program Files\Lockheed Martin\Prepar3D v4\SimObjects\Airplanes\TFDi_Design_717\Aerodynamics.air
   140547 Aircraft loaded: running normally now ...
   140547 User Aircraft ID 2 supplied, now being used
   141203 System time = 30/01/2018 15:58:04, Simulator time = 15:56:12 (20:56Z)
   141203 Aircraft="TFDi Design 717 Delta Air Lines"
   148234 Starting everything now ...
   148266 Exception 25 "ILLEGAL_OPERATION", Ref 1102, Index param -1 on read AddData for "GPS WP ETE"
   148281 Exception 25 "ILLEGAL_OPERATION", Ref 1105, Index param -1 on read AddData for "GPS APPROACH MODE"
   148297 ASN active function link set
   148297 Ready for ActiveSky WX radar with additional data
   148313 Exception 25 "ILLEGAL_OPERATION", Ref 1108, Index param -1 on read AddData for "GPS APPROACH IS WP RUNWAY"
   148375 Exception 25 "ILLEGAL_OPERATION", Ref 1111, Index param -1 on read AddData for "GPS APPROACH WP COUNT"
   148453 Exception 25 "ILLEGAL_OPERATION", Ref 1114, Index param -1 on read AddData for "GPS APPROACH APPROACH ID"
   148516 Exception 25 "ILLEGAL_OPERATION", Ref 1117, Index param -1 on read AddData for "GPS APPROACH IS MISSED"
   148594 Exception 25 "ILLEGAL_OPERATION", Ref 1120, Index param -1 on read AddData for "GPS FLIGHT PLAN WP INDEX"
   148625 Exception 25 "ILLEGAL_OPERATION", Ref 1123, Index param -1 on read AddData for "GPS ETA"
   149359 Advanced Weather Interface Enabled
   173109 Weather Mode now = Theme
  2682641 Sim stopped: average frame rate for last 2542 secs = 35.6 fps
  2682641    Max AI traffic was 44 aircraft (Deleted 0)
  2777484 Sim stopped: average frame rate for last 92 secs = 30.5 fps
  2777484    Max AI traffic was 44 aircraft (Deleted 0)
  2778734 === Closing session: waiting for DLLStop to be called ...
  2796422 === DLLStop called ...
  2796422 === Closing external processes we started ...
  2797422 === About to kill any Lua plug-ins still running ...
  2797578 === Closing global Lua thread
  2798594 === About to kill my timers ...
  2798797 === Restoring window procs ...
  2798797 === Unloading libraries ...
  2798797 === stopping other threads ...
  2798797 === ... Button scanning ...
  2798891 === ... Axis scanning ...
  2798984 === Releasing joystick devices ...
  2798984 === Freeing macro memory
  2798984 === Removing any offset overrides
  2798984 === Clearing any displays left
  2798984 === NOTE: not calling SimConnect_Close ...
  2798984 === AI slots deleted!
  2798984 === Freeing button memory ...
  2798984 === Closing my Windows ...
  2798984 === Freeing FS libraries ...
  2799984 === Closing devices ...
  2799984 === Closing the Log ... Bye Bye! ...
  2799984 System time = 30/01/2018 16:42:23, Simulator time = 16:50:39 (21:50Z)
  2799984 *** FSUIPC log file being closed
Minimum frame rate was 13.0 fps, Maximum was 64.0 fps
Average frame rate for running time of 2634 secs = 35.5 fps
Maximum AI traffic for session was 44 aircraft
Memory managed: 646 Allocs, 645 Freed
********* FSUIPC Log file closed ***********
 

Share this post


Link to post
Share on other sites

As an addon I also noticed that the entire aircraft behaves oddly at this point. The control column will slowly rotate to full left deflection but not actually seem to move the control surfaces. When moving my stick and rudder it's moving the yoke and rudders in the cockpit but they don't seem to be deflecting the actual control surfaces. The aircraft will slowly roll left and pitch down. This issue has been arising just before TOD going into KJFK (default scenery). Also, I am unable to open up FSUIPC in the menu at this point.

 

Edited by Wispy

Share this post


Link to post
Share on other sites

Looks like there is some bug in SimConnect, in its GPS data handling. Or, more likely I think (or this would be happening to many more folks) some sort of corruption in your P3D 4 installation.

Please try uninstalling the P3D4 Client (using the Windows control panel), and reinstalling it. This won’t affect any add-on

Pete

 

Share this post


Link to post
Share on other sites
1 hour ago, Pete Dowson said:

Looks like there is some bug in SimConnect, in its GPS data handling. Or, more likely I think (or this would be happening to many more folks) some sort of corruption in your P3D 4 installation.

Please try uninstalling the P3D4 Client (using the Windows control panel), and reinstalling it. This won’t affect any add-on

Pete

 

I'll give that a try. I just recently did a re-install of the client so maybe something got corrupted in the process. I'll do another uninstall and re-install and see if that helps. I'll let you know what happens.

 

Thanks again for the quick responses. Very much appreciated!

 

Chad

Share this post


Link to post
Share on other sites

I did an uninstall of the P3d Client and re-install. Same issue. There seems to be something at that exact geographic location that's killing FSUIPC. I'll try flying different routes and see what happens.

Share this post


Link to post
Share on other sites
12 hours ago, Wispy said:

There seems to be something at that exact geographic location that's killing FSUIPC.

It has got to be eiither bad weather data (but that usually crashes the simulator), or bad AI Aircraft textures seen in that area (but again you'd expect the same). Of course, it the end it could be down to any sort of corruption withing the simulator caused by bad data in that area. FSUIPC itself is certainly not aware or nor cares about where in the world you are.

It's also unlikely to be only affecting FSUIPC, though that might be the more noticeable effect. If SimConnect is doing strange things that could affect almost any add-in or add-on. FSUIPC is 99.9% dependent on SiConnect behaving correctly.

Pete

 

Share this post


Link to post
Share on other sites

Hi Pete,

I may have found out the possible cause. I have been using ProjectFly's Simstall client for flight logging. I was trying to do a flight from CYVR in the PMDG 777. Within 2-3 minutes FSUIPC would quit. This happened 4 times in a row. I then loaded the same flight without Simstall and everything worked fine. I'm not 100% sure it's the cause yet.

Share this post


Link to post
Share on other sites

Hi,

it is not FSUIPC that quits but SimConnect stalls and in case ALL applications that uses SimConnect will stop working, and of course any application that uses FSUIPC as well. Does the SimStall uses SimConnect to communicate with FS?

Later: Their web page says you need FSUIPC for FSX/P3D. But doesn't say it is compatible with P3Dv4?

Thomas

Share this post


Link to post
Share on other sites
34 minutes ago, Thomas Richter said:

Hi,

it is not FSUIPC that quits but SimConnect stalls and in case ALL applications that uses SimConnect will stop working, and of course any application that uses FSUIPC as well. Does the SimStall uses SimConnect to communicate with FS?

Later: Their web page says you need FSUIPC for FSX/P3D. But doesn't say it is compatible with P3Dv4?

Thomas

 Hi Thomas,

It should be compatible. When you install the program it automatically finds the appropriate directory. I've been watching many streamers on Twitch and YouTube who are running it no problem in P3d v4.1, I'm going to ditch the program anyway. I personally could care less about logging time and it chews up an extra 2% CPU that I'd rather have focused on something else. I'll do some more testing to see if I get the same issue without using it.

 

Chad

Share this post


Link to post
Share on other sites

Update:

 

I spoke too soon. Doing a long test flight and 1/2 way the issue came up again. I was doing a long cruise flight from CYVR - EGLL in the 777 had time acceleration on. Could this be causing issues?

Share this post


Link to post
Share on other sites
12 minutes ago, Thomas Richter said:

It shouldn't but maybe PMDG causes a SimConnect stall when in time acceleration.?

Do you use as well latest FSUIPC5.123c ?

Thomas

Hi again,

I am using the latest version of FSUIPC, fresh download. Going through all the issues I have I can't see a common theme anymore. I get the issue using FS Labs A320, TFDi 717, and PMDG aircraft. Had with and without Simstall running, had it now with and without time acceleration. Something somewhere is killing it in the sim but I have no idea what. I wish there was some kind of error message to help figure this out. I'm at the point now of having spent dozens of hours trying to figure this out.

AS16 is the last thing to investigate, but I havn't seen any issues with it.

Share this post


Link to post
Share on other sites
7 hours ago, Thomas Richter said:

To eliminate those AC's as the source, did you try the same flight with a default AC?

Thomas

I haven't tried that yet. I'm in the process of testing out each add on one at a time to narrow it down. I'll post an update if I rein the problem in.

 

Thanks again for the help and suggestions, very much appreciated.

 

Chad

Share this post


Link to post
Share on other sites

Finally have everything working again. I had to do a complete uninstall of P3D following the proper procedures. I then re-installed all my scenery and aircraft again with a few exceptions. So far everything is working as it should. One item I didn't install was UTLive. My problems started about the time I installed it even though I had it disabled in P3D. 

 

Chad

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.