Jump to content
The simFlight Network Forums
jdriskell

FSUIPC Not Controlling Throttles

Recommended Posts

I use FSUIPC in conjunction with FSX-SE to control all my aircraft from the PMDG models to the stock aircraft without issue.  I have a set of CH Rudder Pedals, Yoke and Throttle Quad.  FSUIPC controls every aircraft properly except Manfred Jahn's Douglas C-47 Beta V3.14.  I have defined separate prop, throttle and mixture controls in FSUIPC as "Send direct to FSUIPC for Calibration"  for each CH throttle lever.  Prop and mixture controls work properly but the throttle controls do not seem to interface with the sims throttles so they do not move from idle cutoff.   What am I missing?  Can I track these assignments via a log to determine the problem? 

 

Thanks in advance for your help.

 

Jim Driskell

Share this post


Link to post
Share on other sites

Hi,

as it is as well for PMDG ac's highly recommended not to use the FSUIPC calibration facility and send the control instead 'Send to FS as normal axis', it might be the same problem for the add-on you use.

Thomas

Share this post


Link to post
Share on other sites
14 hours ago, jdriskell said:

Can I track these assignments via a log to determine the problem?

You can monitor the axis values being sent by activating the 'Axis controls' logging from the logging tab. You can also monitor the throttle values by monitor the appropriate offset in the right hand side of the logging tab. For example, Throttle1 lever value is at 088C  (2 bytes).

However, as Thomas says, you may be better off sending to FS as a normal axis rather than using FSUIPC' calibration facilities.

John

Share this post


Link to post
Share on other sites

In FSX-accel, boxed  -
For what it's worth, had the C-47 all setup for a flight.. Since ready, did some testing/looking around prior to departure.
I have my controls as "send to FSUIPC calibration" and they work just fine. Even tried to break them by setting them up much differently - still worked.
Looked at the VC animation code too.. Nothing really special about it except for a middle click to "link" both throttles together, but this only for mouse driven commands to the throttles.

 

<!-- LEFT ENGINE ONLY, RIGHT HAS THE SAME LOGIC -->
(M:Event) 'MiddleSingle' scmp 0 == if{ 
    (L:Engine link levers, bool) ! (>L:Engine link levers, bool) quit 
}
 
(M:Event) 'LeftSingle' scmp 0 == if{ 
    (A:General eng throttle lever position:1, part) 0 > if{ 
        0
    } els{ 
        (A:Throttle lower limit, part) 
    } 
    (>L:Mouse min, part) (M:Y) (>L:Mouse Y, position) quit } 

(M:Event) 'WheelUp' scmp 0 == if{ 
    (A:General eng throttle lever position:1, part) 0.01 + 1 min sp0 
    } els{ 
        (M:Event) 'WheelDown' scmp 0 == if{ 
            (A:General eng throttle lever position:1, part) 0.01 - (A:Throttle lower limit, part) max sp0 
        } els{ 
            (L:Mouse Y, position) (M:Y) - 150 / (A:General eng throttle lever position:1, part) + (L:Mouse min, part) max 1 min sp0 (M:Y) (>L:Mouse Y, position) 
            }
        } 
l0 16384.0 * (L:Engine link levers, bool) if{ d (>K:THROTTLE2_SET) } (>K:THROTTLE1_SET)

If I were to guess - it may be something like a "model specific" plan was setup at one time and never fully finished.
Having a different set of eyes look at the FSUIPC4.ini may shed some light.

Roman

Share this post


Link to post
Share on other sites

I got the Douglas C-47 Beta V3.14 sim to respond to FSUIPC throttle input, but only after I first loaded the old DC-3 airways Virtual Airline sim which always responds to its FSUIPC controlled inputs.  I shut down the old DC-3 sim and reloaded the Beta version and the throttles started working.  I found that I could then redefine the throttles in FSUIPC a couple of different ways.  Either way worked.  But when I shut down FSX-SE and restarted it, the Beta version had the same problems unless I loaded the other DC-3 version first and then ended its flight before reloading the Beta version.  Don't know what is going on because every other sim works properly.

Since then, I have turned off power management on the USB connections as recommended by Pete Dowson and I'll redefine the controls as  "Send to FS as Normal axis" and report back on my findings.  The only other sim that I've had to do this to is the PMDG DC-6/C-118.  Every other PMDG model uses FSUIPC as the calibrator.

I'm also beginning to think my CH Throttle Quad may be getting a little long in the tooth as it's over 10 years old.  the third and fourth lever don't calibrate equally.  This is not the problem here, but it's vexing.

Thanks for the input,

Jim Driskell

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.