Jump to content
The simFlight Network Forums
lee@schaefferhome.com

Some Buttons Are Not Passing to Prep3d

Recommended Posts

I'm new to FSUIPC, so maybe there is something simple I'm missing.

I have FSUIPC ver 6 and Prepar3d ver 4.5

I'm using a CH Flight Sim Yoke.

The other day I setup all the controls and buttons the way I wanted and everything was working fine.

Today, three of the five of the assigned buttons are not working.  FSUIPC seems to read the button being pushed, and the actions seem to be still programmed, but the command isn't firing in Prepar3d.

One button is for the brakes.  This is not working.

A toggle (up / down) button is assigned Gear Up and Gear Down.  Another toggle button is assigned Flaps Incr and Flaps Decr.

I've tried these buttons on multiple air craft and get the same results.  I tried planes that were working the other day and others that I haven't used since I initially setup the FSUIPC commands.

Enable Controls is unchecked in the Prepar3d options.

 

 

FSUIPC6.log

Share this post


Link to post
Share on other sites

Hi,

please send your FSUIPC6.log and FSUIPC6.ini files unaltered as they are after short session fully closed.

As well activate on Logging Tap in FSUIPC Button and Key operation and as well Events (non axis controls).

Thomas

Share this post


Link to post
Share on other sites

Hi,

 

I have the exact same issue since a few days. I updated now to the newest version (6.0.8) to see if the problem remains and unfortunately it does. None of my buttons works anymore although they are recognized within FSUIPC.

Unfortunately my FSUIPC6.log has the size of 434 KB and I can't attach it here.

Edit: I should add that it is working just fine in P3Dv4.5 but not in P3Dv5

Edited by officercrockey

Share this post


Link to post
Share on other sites
2 hours ago, officercrockey said:

Unfortunately my FSUIPC6.log has the size of 434 KB and I can't attach it here.

You can zip it up and then attach. We also need to see your FSUIPC6.ini file.

2 hours ago, officercrockey said:

I should add that it is working just fine in P3Dv4.5 but not in P3Dv5

Did you rename your FSUIPC5.ini file to FSUIPC6.ini (and also move it to the new installation folder, if you changed that)?

Share this post


Link to post
Share on other sites
7 minutes ago, John Dowson said:

You can zip it up and then attach. We also need to see your FSUIPC6.ini file.

Did you rename your FSUIPC5.ini file to FSUIPC6.ini (and also move it to the new installation folder, if you changed that)?

Yes I renamed the FSUIPC5 ini to FSUIPC6.ini and moved it to the new installation folder. I was using it in P3D v5 just fine and it just stopped now working 2-3 days ago. 

Unfortunately the ZIP file is still too big for the 20 KB limit (really? 🙂 ). I uploaded it on google Drive and here is the link:

https://drive.google.com/file/d/1aWGvaNKg39zWwSGl7zQAZpmBJBmkUnoV/view?usp=sharing

 

The log file is full of entries like this:

34953 Exception 7 "NAME_UNRECOGNIZED", Ref 1164, Index param 2 on MapClientEventToSimEvent for "GEAR_TOGGLE", id=65570 [0x10022]

 

Share this post


Link to post
Share on other sites
56 minutes ago, officercrockey said:

Unfortunately the ZIP file is still too big for the 20 KB limit (really? 🙂 ). I uploaded it on google Drive and here is the link:

https://drive.google.com/file/d/1aWGvaNKg39zWwSGl7zQAZpmBJBmkUnoV/view?usp=sharing

We probably did not need the whole log in any case. If it is that big after Zipping then it must contain a lot of repetitive stuff, of which we'd only need a sample.

I can't get the file from your drive. I guess you shared it with John?

59 minutes ago, officercrockey said:

The log file is full of entries like this:


34953 Exception 7 "NAME_UNRECOGNIZED", Ref 1164, Index param 2 on MapClientEventToSimEvent for "GEAR_TOGGLE", id=65570 [0x10022]

 

Aha!  That means that your P3D installation is corrupted, or is getting corrupted. The names used for the control events are the same in P3D4 and P3D5, yet it looks like SimConnect is not finding them in its list.

Things to do to try to fix this: 

1. First uninstall the P3D5 client (only) -- don't deactivate.

2. Then re-install the client -- there's an installer for this (an .msi file) in your downloaded P3D5 package.

3. Test again.

4. If still the same, try adding "NoWeatherAtAll=Yes" to the [General] section of the FSUIPC6.INI. This stops FSUIPC asking SimConnect to access the weather files. These files are binary and they are not checked before use by SimConnect. Any corruption in one of those can wreak havoc in memory as a consequence.

5. Test again. If then there are none of those errors, please see

Although yours isn't crashing, it is still a corruption problem.

6. If nothing above helps, then please try with no other addons -- possibly one is causing the corruption.

Pete

 

Share this post


Link to post
Share on other sites

Hello Pete,

sorry, it seems like I didn't share it with anyone. I fixed that now.

I also tried all of your steps and point 4 was the one that helped. After I add NoWeatherAtAll=Yes to my ini file, it works again. After that I deleted that entry again from my ini and deleted the wxstations.bin (now in P3D\Weather). After that everything works fine now. 

Thanks for your quick help. This certainly wasn't an obvious solution!

Share this post


Link to post
Share on other sites
2 hours ago, officercrockey said:

This certainly wasn't an obvious solution!

No. That's the problem with memory corruption. It can have any number of effects.

I've been pleading with Lockheed-Martin ever since they first released P3D however many years ago so do some sort of checking of the validity of that weather data before they use it to set their internal tables, but with no result so far. I might have another go at them.

Pete

 

Share this post


Link to post
Share on other sites

You forgot to add the .log file to the zip archive. You are also using FUIPC6 v6.0.7 - please also update to the latest version, v6.0.8.

Edited by John Dowson
Using old FSUIPC version

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.