Jump to content
The simFlight Network Forums

FS2020 V1.8.3.0 crash with FSUIPC


bertranda
 Share

Recommended Posts

Hello,

I noticed since FS V1.8.3.0 update that it CTD when start loading after choosing plane and departure airport, this, only when FSUIPC is running. If I start FSUIPC after loading the flight, no CTD.

but this means I have to close FSUIPC each time I want to change airport or plane, or anything else that require returning to menu.

it is not convinient. befor this last patch of FS, I could launch FSUIPC before starting FS and let it run this no issue.

Idon't know what kind of log would help.

 

Best Regards.

Link to comment
Share on other sites

11 minutes ago, bertranda said:

Idon't know what kind of log would help.

To start with, could you attach your FSUIPC7.log (from after you have experienced the CTD) and also your FSUIPC7.ini file please, both files are located in your FSUIPC7 installation folder.

Can you also check the windows event viewer, and see if there is a crash log available there. If so, please paste its contents as well.

Link to comment
Share on other sites

1 minute ago, bertranda said:

I just restart the sim today and I'm under mandatory update process. Let's see what will come out after update.

Good luck! Lots of reports of crashes with the new update, especially if using the VFR map.

Note you can also disable  'Exit with FS' from the FSUIPC7 options menu. Then, if MSFS crashes, FSUIPC will remain open (and you will know that it is an MSFS crash and not related to FSUIPC7).

Link to comment
Share on other sites

Hi

I can tell that my Sim is up and  running ever since the first FSUIPC7 and never crashed...... would like to have all of my Avionics Rack buttons work, but can´t make it happen.

PS: Is there an update to FSUIPC7 for MSFS2020?...where?

Regards
Paulo

Link to comment
Share on other sites

Hello John,

I finaly could do some test again.

apparently, FS doesn't crash with FSUIPC only, it crash when prosim is open as well.

prosim alone = ok

Fsuipc alone = ok

fsuipc + prosim = crash.

if I run everything after the flight load, no problem.

you can find in attachment, fsuipc log  and windows log folowing FS CTD.

for prosim side, I'm affraid I can't ask any support since I kept my V1.XX lisence because I didn't want to move to V2.

 

Best Regards.

FSUIPC7.log windows log.txt

Link to comment
Share on other sites

There are some folks apparently using ProSim with MSFS, but with v2 I think, if not even v3.

Note that ProSim uses SimConnect too, more than FSUIPC I think. And frankly I'd be surprised if v1 even recognizes FSUIPC7  

A SimConnect log might help you identify whether a specific sequence is doing it, but I don't really see how you would follow that up with unsupported software in use.

Pete

 

Link to comment
Share on other sites

Hello Pete,

Prosim V1 is working fine with FSUIPC 7, at least enough for my use so far.

there is a warning in prosim log that simconnect is missing and some functionality will not be available. I don't know which one, maybe weather radar, because I notice it doesn't work.

I'm waiting for a 737 now.

 

thanks for your support.

 

Best Regards.

Link to comment
Share on other sites

On 10/1/2020 at 2:38 PM, John Dowson said:

Sorry, what do you mean? FSUIPC7 is for MSFS only, and is being continually updated. See 

I add a comment to that topic when an update to FSUIPC7 has been released.

 

 

Thank you John and sorry for missing out on the FSUIPC7. Got it now and it´s working fine with my PFC Avionics Rack with the exception of the lower part of it (GPS buttons and Altitude Pre-Select) also can´t programa the Reset-Start-Freeze-Map-Con-Instr buttons.
Thank you so much for all the hard work and support.
Paul

Edited by PSantos
Link to comment
Share on other sites

1 hour ago, PSantos said:

(GPS buttons and Altitude Pre-Select) also can´t programa the Reset-Start-Freeze-Map-Con-Instr buttons.

There are many buttons/switches that can't be programmed at the moment either due to lack of controls or controls not working, especially for AP systems (G1000 etc).

Also. it seems that, depending on the aircraft and the AP system used, you may have to switch authority from the FCU to enable, and this may also apply to the MCP. I am referring  to this post:

Quote

I have found this possibly interesting post on MSFS forums :

"There are no commands that are visible in control settings GUI. But you can control the FCU authority with these Sim Connect sim events; HEADING_SLOT_INDEX_SET SPEED_SLOT_INDEX_SET ALTITUDE_SLOT_INDEX_SET VS_SLOT_INDEX_SET Sending these with parameter 2 gives the authority to FCU, and sending with parameter 1 activates selected mode for each knob. You’ll need to use a 3rd party controller interface software that use sim connect; ....."

Maybe that these "SLOT_INDEX" variables or controls set to 1 allow normal operations for the knobs of MCP ?

I cannot send them directly to simconnect... never even tried to do this directly, only used FSUIPC.

See this topic for further details: 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.