Jump to content
The simFlight Network Forums


Recommended Posts

I spent an hour last night trying to get this to work... Finally went to bed with V2 uninstalling.  Glad to know I'm not alone.  I'll reinstall tonight and wait until Pete is able to address it.  I hope it's quick as I hate dealing with all my controls in the simulator itself.

Link to comment
Share on other sites

I have installed version 4.92 and it is not working in p3d v2.0 it shows in add-ons but nothing happens when you click on it.

Also in the installer file it warns you of the following: WARNING This version of Prepar3D is later than any known by this FSUIPC4

There may be problems. Please check for a later version of FSUIPC4.


Craig Hustadt

Link to comment
Share on other sites

A little more info for Pete when he returns: When I load P3D1 my SPAD setup screen shows in the bottom left hand corner "FSUIPC Status Connected" but in P3D2 the SPAD setup screen shows "FSUIPC Status Disconnected".


As others have indicated if I copy the dll.xml filew into "\App Data\Roaming\Lockheed Martin\Prepar3D v2\dll.xml" Prepar3D V2.0 will not start. Prepar3D V1.4 is working fine on a seperate drive.


Cheers, Mac

Link to comment
Share on other sites

Dont copy the whole dll.xml, you need a fresh install of it for P3D. Try this version instead. It wont make the GUI appear but it will hopefully stop the crashes and you can copy your FSUIPC4.ini file over from FSX to get some functionality working. Some parts of FSUIPC will still not work though.

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">
        <Name>FSUIPC 4</Name>

Link to comment
Share on other sites

Does not work for me.


I have a registered copy of FSUIPC 4921f and have been using FSUIPC in 1.4 for a long time with no problems.


I ran the full FSUIPC installation program, entered my registration codes for FSUIPC and WideFS.  It detected my P3D 1.4 installation and the V2 installation.


It is working fine in P3D 1.4.


I, like others am not able to get the FSUIPC menu to come up when clicking on FSUIPC on the P3D V2 Addons menu.


I tried renaming the SimConnectP3D2.dll in the P3D V2 modules folder as described above.  The FSUIPC menu does indeed come up however it is indicating that I have an unregistered copy.


Am I missing something??

Link to comment
Share on other sites

Copy your .key file from either FSX or P3D v1 to the P3D V2 modules folder.

Hey Andy,


You got it!!!  Works fine now, I should have thought of the key file (getting old and dumb, that's why we need bright guys like you around).


Thanks again



Link to comment
Share on other sites

Sorry guys it does not yet work for me. Thanks for trying. No problem, Pete should be back today or tomorrow.

Did you read posts 15 thru 20??  You should be able to get it going no problem.  Give us some specifics and maybe we can help.

Link to comment
Share on other sites

Go to modules and rename the SimConnectP3D2.dll how you want. Then start P3D. In this case FSUIPC load the ESP original client. It works without problems


There are still problems because some of the hooks in that version of FSUIPC are not correct for the released version of P3D v2!


The version of FSUIPC for the released version of P3D v2 is not available yet. I was on holiday! I will release it when I've done it, probably before the weekend!



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.