Jump to content
The simFlight Network Forums

Recommended Posts

Hi,

Just got back into using Tracon 2012 but have an issue with the the text to speech engine in it. 

It use to work great but now the messages are a bit garbled and it appears to be swapping out words for what it thinks it is suppose to be. Will understand what you say but the responses are not what they should be saying.

Don't have this issue with Tower 3d so not my set up. Can hear and speak great with that. Almost 100% speaking and text engine is crystal.

What is the latest release version of Tracon?

Checked all the usual suggestions and even a complete reinstall.

Anybody else having issues?

Thanks

Share this post


Link to post
Share on other sites
9 minutes ago, BEARDY said:

What is the latest release version of Tracon?

When did you purchase the game?  (Unless years and years and like just after release you are up-to-date.)

Share this post


Link to post
Share on other sites

Hi,

Thanks for replying. Will put both replies here.

Purchased Jan 2018 but not from FeelThere. Sp1a on installer. Sometimes when there is a newer version of anything bought from Just Flight they email to say but I suspect I may have the newest version.

The "pilots" respond to what I say but their reply is a mixture of what I say and nonsense. Readback was always  good before. Strange. It has been a while since I played it and don't think I have since Win 10 upgrade so can't say when it started. If nobody else has issues with Win 10 then don't know what is causing it as Tower 3d is almost 100% speaking and readback is all OK. No issues with hearing what is said by the "pilots". Pretty sure it is not a speech engine issue with windows.

I did a fresh install with no add ons (have RT and other sectors) but it is the same. Tried various compatibility mode settings but no difference.

Thanks again

Share this post


Link to post
Share on other sites

Hi,

Forgot to say that the issue seems to affect numbers more than anything. Sounds like one becomes "mullens" four becomes "fuller". It is difficult to pick it up exactly. Down to "funny" hundreds which I think is supposed to be down to 800s.

It's after five minutes of mispronunciation that I give up

Thanks again

Share this post


Link to post
Share on other sites

Hi,

Yes, set to US English. 

It is weird as it use to work flawlessly. Tower 3D is perfect with the text to speech and I have no issues speaking to or hearing replies. Callsigns, numbers, runways, taxi instructions are all perfect when read back.

I realise that it is an older program and Microsoft have updated their Speech engine since the XP days. Also have issues with London Control due to it not being compatible but that is mainly with that program not understanding what is being said, no mispronunciation from the "pilots". It worked great under XP. Typical, that MS couldn't make their Speech Engine backwards compatible. With Tracon, the "pilots" can understand what is being said, it is just their replies are a mixture of sense and nonsense in the same sentence.

To give you an idea here are some examples of what I think they are saying from LAX sector 0700 arrivals. 

Redwood 371 = Redwood B 7 Mullens

AAL 185 = American Mullens Deep Funny

Citrus 49 (Niner) = Citrus Fuller Niner

Atis Info TANGO = TANGLE

If others have no issues then it must be at my end but I cannot figure it out. It is annoying because I know it use to work.

Uninstalled and reinstalled language pack and set everything up again but still same issue.

Thanks for your time on this.

Share this post


Link to post
Share on other sites

Hi,

Just wondering if anybody else is experiencing this issue? If not then it narrows it down to a problem with my computer's speech engine.

Thanks again

Share this post


Link to post
Share on other sites

i had it after installing 3D, i never got round to uninstalling 3d to confirm it was 3D messing it up but I suspect it is. - they use different voice engines i think?

Share this post


Link to post
Share on other sites
4 hours ago, BEARDY said:

Hi,

Just wondering if anybody else is experiencing this issue? If not then it narrows it down to a problem with my computer's speech engine.

Thanks again

It’s an 8 year OLD game that isn’t played much anymore. I wouldn’t let the lack of responses influence you one way or the other. 

Share this post


Link to post
Share on other sites

Hi,

Just did a reinstall of Tower 3D. Never thought to try Tracon when it was uninstalled. Might be, although I can't remember it being an issue before. Pretty sure I had Tower 3D before Tracon. But I'm getting old and I could be mistaken. 

Might try if I ever do another reinstall.

Cheers

Share this post


Link to post
Share on other sites

Hi,

Yeah, being old has it's issues. ;>).

A lot of older stuff stopped working after XP. London Control was another. I use to get almost 100% recognition with that. Down to about 35% now. Results in some interesting conversations and a few near mid air collisions. Good for opening menus and files to blank out the screen while controlling.

Tracon is still playable as it understands me, it is just the readback that is the immersion killer.

I still enjoy it and haven't even played half of the add on sectors yet.

Ah well, off to give Redwood B7Mullens some radar vectors.

Many thanks

Share this post


Link to post
Share on other sites

Hi,

I got this fixed. Turns out that has been my fault all along. DOH!!!!

I used the Microsoft speech engine speech dictionary to add words to help with recognition thinking (stupidly) that it would help with the computer better understanding what I was trying to say when using London Control ATC Sim. The readback didn't affect LC as it uses a different system for pilot comms. These were mostly airlines and sector names with a few numbers.

After going demented trying to find a solution and many, many uninstall/reinstalls I came across by chance a post on a website, on an unrelated issue, that suggested to someone that the entries in speech dictionary might be an issue. I deleted all the words I had inputted and now everything works. Did not think the TTS engine would  be using words I put in and confuse itself. Completely threw me as it wasn't happening with Tower3D.

Moral of the story: Don't dabble in the unknown.

Useful if somebody else has similar issues.

Redwood Three Seven One. WHOOHOO!

Thanks and sorry.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.