Jump to content
The simFlight Network Forums

Issue with installing Tower!3d on new laptop


Recommended Posts

Hi all

Been playing Tower!3D for almost a year now on my 13 year old desktop. Works fine, but visual was not that great (no HD screen etc, only 4G of memory etc).

Bought a new laptop 2 weeks ago, HP Envy Windows and is quite an upgrade in performance with everything I use.

Everything, except for Tower!3D. Whatever I try, it will not run the program.

 

Please see the attached file (short movie clip) of what happens when I try to run it after installing.

That very short moment that I see the opening screen is as far as it will go. Next time when I try to run the program, nothing happens...

 

Have tried multiple redownloads en clean installs, but it won't work. 

Anyone an idea of what is wrong, or what I am forgetting/should do different?

 

Thanks for the help/suggestions upfront.

Regards,

Twan

Link to post
Share on other sites

Hi Scoobflight.

Which alert are you referring to? If you mean the one before the game opens it says: DO you agree that this app from an unknown source makes changes to your computer?

The video card is: NVIDIA GeForce MX450

Processor: Intel Core i7 (4,7GHz)

16G memory DDR4

 

I am the only account on this PC. I believe that this would make the administrator, correct? If not, then I might need some help 🙂

 

Link to post
Share on other sites
1 minute ago, Twan Trienekens said:

therefore I will not be able to run Tower!3D

Tower requires a real video card.

 

Try running the installer as admin and then running the game as admin.

Link to post
Share on other sites

Hi scoobflight.

As you can see in the attached movieclip, I am trying to run as administrator.

Please understand, I have had this game almost a year on my previous computer, and it ran and played good on it.

Therefore, I understand the usual issues 🙂

 

 

Link to post
Share on other sites

As @scoobflight said run the installer as admin and also try to install the game outside the Program Files directory. Either on another harddisk or partition, or you create a games folder on your C harddrive. Also make sure that no antivirus software is blocking the program.
Your laptop should be more than sufficient to run Tower!3D. Your MX450 should not be the issue here.

Link to post
Share on other sites

Hi guys.

Really appreciate the help! Thanks 🙂 

 

 

Uninstalled, re-installed as admin, ran the program as admin...

Twice.

No luck.

 

Made a seperate folder on my C drive named Games, made another folder in the Games folder named Tower 3D

Shut down Norton Firewall for an hour

Re-installed as admin, ran the program as admin...

 

No luck 😞

 

 

Link to post
Share on other sites
5 hours ago, MJKERR said:

If not, then go to the output.log and delete it
Run the .bat file, then try to run Tower 3D
Now look at the output.log and attach for someone to investigate

For future reference, the output_log.txt is automatically recreated every session. So deleting it is unnecessary as is running the bat file. The tower bat file actually creates a game.log file. 

Link to post
Share on other sites
3 minutes ago, Twan Trienekens said:

Hi,  @MJKERR

This I don't follow I'm afraid 🙂

I understand computers, but I don't "speak" computer that well lol.

 

My laptop only has 1 SSD of 512GB in it. Can you please explain what I need to do now?

Personally, I’d ignore this advice because it is irrelevant.

Have you tried turning off Wi-Fi before launching the game?

Link to post
Share on other sites
10 minutes ago, MJKERR said:

I could not find this model number
The nearest UK specification has one HDD and one SSD

As above, uninstall
Right click on the downloaded installer, right click and Run as Administrator
Equally, the program may be looking for the default directory

@Twan Trienekens has already uninstalled and installed in two locations with the same results. Why do it again?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.